Missing basic cards

Bug Report
I saw some other threads of the same topic, just thought I would make another one to hopefully alert the devs. After getting to level 10 and unlocking all the basics for my warlock, the game crashed. When I reopened it I'm still level 10 but only have 14/20 basics and can't get them back.
Same thing here. Got to level 10 on my priest. Unlocked all 20 basic cards. Went to create custom priest deck. After saving it, game crashes. Now it says I only have 14/20 basic priest cards even though I leveled up to 14 now and will not let me use my custom deck because cards are missing.
I'm having a similar problem. I just unlocked my first non-mage deck (the Priest), and my game crashed shortly afterwards. Now I have no Priest cards except for the one card I got in an expert pack.
I posted this elsewhere, but here's my take on this as well:

This is a bad problem that I hope Blizzard fixes ASAP. From my vantage point, it appears like the following happens:

1. Get to level 2, unlock 2 new cards (in this case, Assassin's Blade)
2. Go to Collection, add 2x Assassin's Blade to Rogue Deck
3. Go back to practice, start a game w/ Rogue
4. Game crashes thanks to our friendly sprites
5. Reload game, go to practice mode
6. See that Rogue deck has an X through it
7. Go to Collection... Assassin's Blades are still in the deck but not backed up in the collection screen
8. If you remove the Assassin's Blades, they appear to be gone for good (cannot re-add them), but this then makes the deck playable

So there is some issue where the basic cards are not actually being unlocked permanently, then causing a host of problems.

Please fix Blizz!! Makes it extremely hard for us new players to actually get into casual/ranked mode if we can't even unlock the most basic cards.
This problem just happened to me a few hours ago:

logged off, then logged back on to play a game only to find me level 10+ custom shaman deck has a big red X over it. I cant use it to play against anyone or the AI.

I replace a few cards and it becomes playable, but a new problem arises in that I only have 18/20 basic cards for the Shaman and I can't even see the missing two in my collection or anything.

Hope this gets sorted.
same problem with me and paladin. just got to level 10 and unlocked blessing of kings, tried to play a game vs my friend, game crashes. logging on again now I dont have Blessing of Kings.
Same here with savage roar. Happened just like TexaStranger described
Same thing happened to me just now. I got disconnected from the game and when i logged back in, i saw two of my custom decks (shaman and hunter) crossed out with a red X. I checked the deck and found out that 2 basic cards were missing from each deck. I tried to reconnect but nothing happened. I also tried to level my shaman but the missing cards didn't re-appear. I also tried removing the decks and making a new one, but the missing basic cards are still not in the collection. I hope this gets fixed. :S
Leveled my priest to unlock the extra cards, unlocked all of them and reached level 12(10+). client crashed and then upon logging in did not have my unlocked class cards despite being level 12.

Basic cards shows 12/20; but i am unable to get unlock-able cards, tried leveling twice just in-case, but still nothing.

Please rectify this as soon as possible, many of us newer players need these basic cards for the dailies etc.
This problem seems to be pretty prevalent. My hunter collection is now missing cards and I stopped getting new basic cards despite reaching level 8. I am stuck at 14/20 basic cards
Magically fixed itself. Not sure why.
This same thing is happening to my Shaman deck. I only have 18/20 cards and im lvl 13. I really hope this gets fixed asap! thanks
08/14/2014 10:34 AMPosted by Dutchy
This same thing is happening to my Shaman deck. I only have 18/20 cards and im lvl 13. I really hope this gets fixed asap! thanks


Do not resurrect half a year old threads.

There are actually a few recent threads regarding this issue.

The issue is being checked out currently:
i was just changing my rogue deck and assassins blade dissapeared, it was in my deck and now it dissapeared and i cant find it anywhere. what happened

Join the Conversation

Return to Forum