Updating Battle.net Agent stuck forever

Mac Technical Support

I know this problem has been posted before, but I have tried all the solutions I could find on the issue, but nothing has worked for me. I'm not sure if it is a Hearthstone or a Battle.net App/Agent problem. PS! This is on a Macbook Air.

In any case, the point I've come to now, is that I deleted all the Hearthstone and Battle.net files manually (as I couldn't delete them through the agent), and I tried to reinstall Hearthstone. However, the first thing that pops up after downloading the Hearthstone or the Battle App, is "Updating Battle.net Agent".

What can I do to have this fixed? I was thinking I might not have deleted all the files on my Mac. The other alternative is that my computer is from Europe, but I am currently in the US. Could that have anything to do with this? Either way, any help would be much appreciated.

I am stuck abroad for work, and have too much spare time not to play Hearthstone :(

Thank you !
Hi Ezekiel,

Have you tried everything on our support page here?
Rate me! https://www.surveymonkey.com/s/Velnrak
I've been having this problem since sometime in the middle of December. I have tried *every* troubleshooting step detailed one every help page on Battle.net Support (I ***PROMISE*** I have tried *everything*).

Nothing has worked.

The problem first manifested as the Battle.net Agent being unable to update itself. So I tried all the troubleshooting steps related to that, finally deleting the Agent and attempting to reinstall. That's basically where I am now and where I have been for over a month.

I cannot play Hearthstone. I cannot play Diablo III. I cannot plat WoW.

I cannot play *ANY* Blizzard games right now, because the Agent is very broken, and in my opinion the Agent was not yet ready for an open beta.

macGuyAG, can you make a new User Account, and try installing on that User Account?
Rate me! https://www.surveymonkey.com/s/Velnrak
I've been having this same problem on one of my Macs for months as well. My other machines are fine, but something about my primary iMac just borks the Blizzard updater agent every single time.

Attempting to debug it shows that this is where it is dying every single time, even with a freshly downloaded copy (after having deleted the entire /Users/Shared/Battle.net folder).

There has got to be something specific to this machine that is horking it that I have yet to be able to track down (I've tried to nuke every single cache, prefs, etc file that fs_usage says the Blizzard apps are touching and haven't figured it out yet).

If someone from Blizzard wants to send me a symbol file for this executable I can reproduce it and tell you guys what is exploding.

[darkstar:~/Library/Application Support] kdyke% lldb /Users/Shared/Battle.net/Agent/Agent.2380/Agent.app/Contents/MacOS/Agent
Current executable set to '/Users/Shared/Battle.net/Agent/Agent.2380/Agent.app/Contents/MacOS/Agent' (i386).
(lldb) run
Process 4381 launched: '/Users/Shared/Battle.net/Agent/Agent.2380/Agent.app/Contents/MacOS/Agent' (i386)
Argument[0]: '/Users/Shared/Battle.net/Agent/Agent.2380/Agent.app/Contents/MacOS/Agent'
Database Insert: /option
Database Insert: /agent
Database Insert: /
Database Insert: /version
Database Insert: /repair
Database Insert: /update
Database Insert: /uninstall
Database Insert: /update/client
Database Insert: /install
Database Insert: /gamesession
Database Insert: /agent/download
Database Insert: /backfill
Database Insert: /game
Database Insert: /createshortcut
Database Insert: /game/diablo3_enus
Database Insert: /game/client
Database Insert: /spawned
Database Insert: /agent/download
Database Insert: /register
Session Hash created: '10994966099092294759'
Firing Event: "database flush event"
Firing Event: "database flush event"
Queuing /update/client
Insert to Queue at HEAD
Initialize HttpProtocol Server Called.
Start Queued Task 'Update Clnt'
Agent started on port #1120
Registered Periodic Event: "auth validation event" with a resolution of 10000 and a start delay of 10000
Registered Event: "shutdown event"
Registered Event: "database flush event"
Registered Periodic Event: "network connection event" with a resolution of 60000 and a start delay of 0
Handle Event: "network connection event"
PostTo succeeded status: 0 for url: http://us.patch.battle.net:1119/patch
Post Data:
<version program="Clnt"><record program="Agnt" component="cdn" version="1" /><record program="Agnt" component="cfg" version="1" /><record program="Clnt" component="Mac" version="888" /><record program="Clnt" component="blob" version="1" /></version>
Post Response:
<record program="Agnt" component="cdn">
<record program="Clnt" component="Mac">
<record program="Clnt" component="blob">
Incremental patch:
-source url: http://dist.blizzard.com.edgesuite.net/tools-pod/NA/b2005/l-888-2005-mac.mpq.torrent.A118E06B29C01D000DCF118C1D705CE8
-dest: /private/var/folders/w1/w872_pd94ps_tfvsc5zd2t2m0002hf/T/Cleanup At Startup/Blizzard/AgentUpdate_ACA0B4A6/l-888-2005-mac.mpq
Downloader State change: 1
Downloader State change: 0
Process 4381 stopped
* thread #9: tid = 0xde63, 0x002452f1 Agent`___lldb_unnamed_function9792$$Agent + 11, stop reason = EXC_BAD_ACCESS (code=1, address=0x353a3774)
frame #0: 0x002452f1 Agent`___lldb_unnamed_function9792$$Agent + 11
Agent`___lldb_unnamed_function9792$$Agent + 11:
-> 0x2452f1: movl (%ecx), %eax
0x2452f3: testl %eax, %eax
0x2452f5: jne 0x24531c ; ___lldb_unnamed_function9792$$Agent + 54
0x2452f7: leal -16(%ebp), %edi
(lldb) bt
* thread #9: tid = 0xde63, 0x002452f1 Agent`___lldb_unnamed_function9792$$Agent + 11, stop reason = EXC_BAD_ACCESS (code=1, address=0x353a3774)
frame #0: 0x002452f1 Agent`___lldb_unnamed_function9792$$Agent + 11
frame #1: 0x0023f6fb Agent`___lldb_unnamed_function9763$$Agent + 53
frame #2: 0x0023dec1 Agent`___lldb_unnamed_function9758$$Agent + 1243
I would just like to say I've been persistently watching these forums for this solution, but I'm not sure if there's enough motivation to fix it. I am writing this on behalf of me and other mac users here that are not able to update the battle.net Agent.

For the record, I have tried reinstalling the client and manually patching the agent via the article linked above and creating a new mac user account. All the above have not worked.
btw, if you look at the views on this post and compare it to the other posts, then you would probably think this bug is affecting many of potential hearthstone mac users.
Hey All,

I was having this same problem on OS X 10.6.8 (Snow Leopard). I went through all the steps outlined in the support pages to no avail.

I just installed the Battle.net agent and Hearthstone successfully. The problem was my network's firewall. I was connected to a network that I wasn't able to administer, and something in their set up was blocking the download of the agent. I thankfully had access to another network that I manage.

If you don't manage your own network, I would try other networks (coffee shops, random open networks, etc.).

If you do manage your own network, pull up your router's administration page to ensure that you're not blocking any traffic.

Why is there nothing in the support tab for this, i;ve had this problem for getting ALL OF MY BLIZZARD CLIENTS... please help
Could you guys try to enable the Mac Firewall in Security and allow the connection under Firewall Settings and add Battle.net Agent to it.
I had the same problem, and I retraced myself back to when I had installed some software for my Razor phone and it had installed some kind of client software and once I remove the client software my Hearthstone link was good as new.
Hey, I'm having this same issue too - 2011 Macbook pro, firewall off, tried it on a new user and it isn't working, tried everything on the support page and it isn't working, currently unable to access any blizzard games.
I had this problem and was able to resolve by manually updating the agent (Advanced Troubleshooting section of the Mac troubleshooting page).
Try disabling Proxy Settings.

Choose Apple menu > System Preferences, and then click Network.
Choose the network service you use from the list, Ethernet or AirPort for example.
Click Advanced, and then click Proxies.
Uncheck any protocols that are enabled.
Click OK to save the changes.
Tovics! You are a god!

I had some random proxy enabled from my college Wifi that obviously blocked certain downloads to prevent students from abusing their internet!

haha, can't believe it was that simple :)

Join the Conversation

Return to Forum