Cannot Cancel Finding Opponent In Play Mode

Mac Technical Support
Frequently when I enter into Play mode and search for an opponent, the timer will go on for some time, for minutes at a time. I have never successfully been able to find an opponent once the "Time in Queue" exceeds one minute. However, more pressingly, whenever the time exceeds one minute (and perhaps before, I simply only notice it after a minute) I become unable to click the "Cancel button. I cannot leave the Play mode screen, and must wait as the game finds an opponent (or rather does not find an opponent) or I have to quit out of the game entirely.

As a secondary note, I have tried to load into a Practice mode game a number of times, and it, too, will load endlessly. I can understand how sometimes there isn't an opponent in Play mode, but in Practice it should take no more than loading a pre made AI, correct?
As an addendum, in Play mode the timer as to how long I am in Queue occasionally disappears, to the same result of an endless wait for an opponent.

Join the Conversation

Return to Forum