HearthStone constantly hanging on Mavericks

Mac Technical Support
Hi,

I'm trying to play HearthStone on my MacBook. The game is constantly hanging (not responding). It happens all the time, especially when I join the arena. Already lost 2 battles because of that. If you wish I can provide log files, and my machine specifications.

HearthStone 1.0.0.4482
MacBook Pro
OSX 10.9.1
Hello Trix,

Please do so.
happens to me too Trix, extremely frustrating. don't know if it's Mavericks specific or what.
I'm having this same problem. It seems to occur when I play a card or use an ability, but before the effects of that card/ability complete. For example, I click the Fireball card and select my opponent. The animation begins and the fireball is ready to release but instead remains just sitting on top of my character. After a delay of seemingly random length the action then completes.

I've managed to sit and wait out several of these delays, others have been so long I gave up and had to quit the game (concede would not work). The last that would not complete was after I played a Raid leader (?I think) card. It was placed on the board, but its effect of raising attack of other cards did not complete. I can move the mouse, clicking on the corner art triggers their animations, but I cannot select another minion on the board, I cannot play another card, I cannot end the turn, and I cannot concede. I've only played another person once, and thankfully I didn't get hung up though I did have several short hangs (just 3 or 4 seconds, more than enough to be noticeable).

I cannot find any helpful logs. The only thing in the Logs folder is the install log. Is there information I can find and submit to help track this kind of error?
THis lag happens with other games i play like starcraft ii. only excpet you can take your time in HS and i dont get dropped like you guys do so i guess i have that going for me. I think this is mavericks problem.
May I ask,

the people who are experiencing issues , does your Mac have a SSD or a HDD? It seems to run perfectly fine on a SSD.
I am using an MBP mid-2009 with:
OS X 10.9.1 (13B42)
HDD: SATA, ST9160314ASG Media
Video: NVIDIA GeForce 9400M 256 MB
RAM: 4 GB 1067 MHz DDR3
CPU: 2.26 GHz Intel Core 2 Duo

I haven't set explicit port forwards for any battle.net services, leaving UPnP to handle it.

Here also is the 'lsof -i | grep battle' output during my most recent hang. In this case it was just trying to start a new practice match. 'battlenet' I believe is port 1119 and bnetgame is port 1120:
Agent 36026 stephen 13u IPv4 0x8bf5f6865dc0f00b 0t0 TCP smzmbp.hawaii.rr.com:64784->iir.blizzard.com:battlenet (CLOSED)
battle.ne 48008 stephen 66u IPv4 0x8bf5f6865faa300b 0t0 TCP smzmbp.hawaii.rr.com:49783->12.130.244.193:bnetgame (ESTABLISHED)
battle.ne 48008 stephen 79u IPv4 0x8bf5f6865fcd0823 0t0 TCP smzmbp.hawaii.rr.com:49859->us.battle.net:https (ESTABLISHED)
Hearthsto 50324 stephen 31u IPv4 0x8bf5f686572e600b 0t0 TCP smzmbp.hawaii.rr.com:50482->12.130.247.217:battlenet (SYN_SENT)


So basically it is stuck waiting for a response from the battle.net server if I read that right.

---
Edit:

Today I fired up b.net and Hearthstone to give it another go. The Battle.net app updated itself and I proceeded to have three uninterrupted practice games! Unfortunately, on the fourth game it hung up again on my turn after I clicked a minion card and ordered it to attack (the card is magnified in size from my selection but never proceeded to perform the attack animation). I've left it running while I checked my internet connection status and updated this post and the game is still very much hung up. Attaching the battle.net Agent/App and Hearthstone lsof data in case it's at all helpful.

lsof -i | grep battle
Agent 36026 stephen 13u IPv4 0x8bf5f6865dc0f00b 0t0 TCP smzmbp.hawaii.rr.com:64784->iir.blizzard.com:battlenet (CLOSED)
Agent 49078 stephen 33u IPv4 0x8bf5f686621b4823 0t0 TCP smzmbp.hawaii.rr.com:50690->iir.blizzard.com:battlenet (CLOSED)
battle.ne 49108 stephen 44u IPv4 0x8bf5f686633de823 0t0 TCP smzmbp.hawaii.rr.com:51004->12.130.244.193:bnetgame (ESTABLISHED)
battle.ne 49108 stephen 46u IPv4 0x8bf5f68661aab00b 0t0 TCP smzmbp.hawaii.rr.com:51590->beta.worldofwarcraft.com:http (SYN_SENT)


lsof -i | grep Hearth
Hearthsto 49144 stephen 10u IPv4 0x8bf5f68660a7e823 0t0 TCP smzmbp.hawaii.rr.com:51605->12.130.247.239:bnetgame (ESTABLISHED)
Hearthsto 49144 stephen 12u IPv4 0x8bf5f686622cd00b 0t0 TCP *:stgxfws (LISTEN)
Hearthsto 49144 stephen 38u IPv4 0x8bf5f6866224e823 0t0 TCP smzmbp.hawaii.rr.com:51126->12.130.244.193:bnetgame (ESTABLISHED)
Hearthsto 49144 stephen 41u IPv4 0x8bf5f68661fa8f1b 0t0 UDP *:vpnz
So after playing for a bit in the 'live' and arena modes I've discovered that when against a real person the 'hang' is somehow overcome by the timer. In practice games the game never resyncs most of the time. In live, it sometimes recovers fairly quickly but will always recover (at least so far for me) by the time the game starts the rope burning animation. I don't know if this is what the others in the thread have experienced. I didn't start trying to play live games until the latest battle.net update so cannot say whether this was the case prior to that.
I keep having this problem as well. I literally just left an arena match where I tried to play a card on the 4th turn and it simply never let me make another move until round 6, when I lost. PS, the card played was Dark Iron Dwarf and it simply never let me give a minion +2 or therefore continue. For the next two rounds I simply had to wait for the timer to expire and on the 6th round when it finally let me play a card it completely messed up the order (I tried attacking with the 4drop Dwarf and instead it finally buffed the enemy that +2 instead). This happens to varying levels I would say in about 1/4th to 1/3 of all my games. It's so frustrating I'm finding it extremely difficult to keep playing, especially in matches where I've spend money like the Arena, in which this nearly always happens. Often, it does allow me to resume play once the timers begins, but this too is random.

I ran the log others have been running, but had already shut down hearthstone I'm afraid.

The next time this happens I will get the log and try to record it to upload to youtube.

battle.ne 97161 brandonferretti 44u IPv4 0x9566a1c00a6b49fd 0t0 TCP 192.168.0.17:60828->12.130.244.193:bnetgame (ESTABLISHED)


I'm using: Retina, 15-inch, Early 2013
Processor 2.7 GHz Intel Core i7
Memory 16 GB 1600 MHz DDR3
Graphics NVIDIA GeForce GT 650M 1024 MB
Software OS X 10.9.1 (13B42)

EDIT: I played two more matched, and it did happen, although in a very optimal way as it only lasted about 10 or so seconds twice in a row. Video here: http://youtu.be/zyNPkAbXLa8
02/04/2014 08:52 PMPosted by Jon
OK, I've found a solution for my issue.

Here's a summary of the problem I was encountering: installation of the game was fine, but in the Battle.net launcher, whenever I tried to click on the "Play" button for Hearthstone, the Hearthstone icon would appear in the dock, and the Hearthstone menu would appear at the top of the screen, but no window of the game would come up. Putting the mouse over the Hearthstone bar at the top, the cursor would turn into the spinning beachball of death.

So then on a hunch what I tried was to use the program "WhatsOpen" (search "WhatsOpen mac" on google for download link) to check the files that Hearthstone was accessing. The list was pretty ordinary except for one that caught my eye, "/Users/me/Library/Fonts/Gorilla.ttf", a font that I had installed a while ago. I removed the font and BAM! the game is working. It must have been corrupted font or something.

So you might want to try and see if there are any weird files that Hearthstone is accessing. Obviously this particular solution will probably only help those who've installed fonts, but it might be useful.
02/05/2014 06:08 PMPosted by BeerBuddha
I just wanted to add that this solution works perfectly.
However you dont need to download Whatsopen.

You can just run Activity Monitor - then when Hearthstone hangs - it will say non responsive, double click and hit Open Files.

Scroll at the bottom it will list the TTF file.

However Note that you will need to keep on trying until it works.

It took me 3 different fonts deletion before the game runs.

Im running on a macbook pro 2012 with Maverick installed.
enjoy
I can confirm that deleting the /Users/me/Library/Fonts/Gorilla.ttf works. I too had the font, removed it, and now the game actually loads.. imac 2011.
You guys saved me from weeks of headache truing to figure this crash at launch out.
For me it was the ANaRcHy font. I had to remove it from both font library folders before it would work.
Thank you so much. For me it was Hagrid.ttf - deleted it and Hearthstone launched! What a weird issue.

Join the Conversation

Return to Forum