error code 2600: can't reinstall

Mac Technical Support
All began when could not make the latest patch update for WoW. Every time it would try to install the update, it would stay at "initialising..." for a long time, then stop completely with an error message saying there was an internet connection problem. I looked through forums for people with similar issues and found that deleting the agent.db file from the folders can solve the problem. Even after doing so, I couldn't update or reinstall WoW, and ever since deleting the file, couldn't install Hearthstone and update launcher either. I uninstalled all apps and deleted files related to and its games, and tried to reinstall everything from scratch. I can get past selecting location to install the new launcher app, but during the actual installation it stops at 65% and then gives me "error code 2600" that something has went wrong. Until I get this fixed, I can't play any of my games at all
raisha, let's try these steps, and see if they help:

1) Reset your network to clear any residual connections and cache.
2) Flush the DNS Cache.
3) Try removing anything that looks like this line in your hosts file:

Rate me!
I am getting this same error. I am on a Mac. I began having problems when the new Hearthstone patch took effect. The first error I received said that it was closed because it couldn't transfer data.
Tried turning computer off/on, resetting modem. Finally just uninstalled Hearthstone and tried reinstalling only to get the error message that said their was a problem transferring data - after a day or two of this I checked to see if the minimum system requirements had changed - they had and realized I needed to update. Last night I updated my iOS to 10.9. I am still getting the same error message. Today, I deleted all the files for with the intention of redownloading it. Now, I can't even do that - it keeps giving me the error code: 2600. I found this forum and followed the steps recommended above and still nothing works.

Since Tuesday I have been reading forums and tech support fixes to try to get this to work and nothing has worked so far. I try to submit a ticket but I keep getting a note that says you may not need a ticket for this and kicks me to the forums. I am not sure what else to do. Please help.
me 2 :'( i tought it maybe had to do something with my stick
Hey guys I got this same problem then i updated my os to maverick and it worked, hope it works for you guys as well
I too have this issue, but I am using windows 7. Diablo III was disconecting me every time I created a game so I uninstalled it, then reinstalled it but it didnt change anything. I uninstalled and now am stuck with this problem.
I let it update and then it stopped working, none of the games in any way work now.
i've been having these same problems, and also non related "maybe" i can't play any videos, or they wont load or play for a few seconds then it crashes, ive tried almost everything and nothing seems to work, im using windows 7. but as far as wow and sc2 ive been getting these errors, idk if these both are related. my hard drive burnt out and i got a new one a few weeks ago and nothing but problems....
Velnrak's tip worked for me, thanks man.
Hey guys,

To those that couldn't get the fix even with the above tips, you need to enable your Secondary Logon in Windows Services.

Hit Windows + R on keyboard (to open RUN)
-> services.msc -> OK
-> locate "Secondary Logon" in Services (Local)
-> Open and change Startup Type to Automatic

Hope that helps!
Dear sir/mdm
It has been a week and I cant play my D3 anymore. I am using windows 8. When I put my disc inside, it reads, then when I double click to install, it prompts: Something broken, error 2600. Can somebody advise what is happening?? Can someone help? I am from the Asia region. Thks.
poloisback, please try these suggestions, and let us know if it helps over in the Diablo III Technical Support forum. Thanks!

Rate me!
Dear Velnrak,
Thanks for your help. Lots of victims in D3 have this problem currently, and lots of feedback about this error 2600, and blizzard did NOT reply at all. I SUSPECT they are looking into this matter(they should and better do!).

Thank you for your suggestions. Maybe I will just play my Steam Games until D3 settle this problem.
Getting the same thing for D3. This is fresh install, just got a new hard drive for my games plus a windows 7 fresh install. starts to install but I get "whoops somethings broke" almost immediately.

In an interesting development, I left the installation at the default location instead of my preferred hard drive and it installed with no problems.
Hi there, i had the same problem than you. I just changed the destination of the file and it worked perfectly.
Just wanted to thank Velnrak - the final step to fix a bunch of problems I was having, makes me want to give someone a kiss.
I still keep getting "Error 2600". Any suggestions?
I had the same problem.

Disabling the antivirus did the trick.
The link below offers a solution.

Join the Conversation

Return to Forum