Bug: HS won't launch (fixed)

Mac Technical Support
The bug: open battlenet, go to Hearthstone, hit 'play'. It says 'launching...', then 'playing now', then it goes back to 'play'. That all happens within about 2 seconds, without the Hearthstone icon popping up, without the launcher appearing.

I started out with the beta launcher, but the game's worked since then. I'm on a mac, too, if that matters.

Update: I tried uninstalling and reinstalling, no effect.

Update 2: Upgraded to Mavericks from OSX 10.8.5, now it works. Oy.
Can you check to make sure that the permissions are properly set up for Hearthstone? Make sure to close the app first and then give this a shot.

    1. Using Finder, navigate to the /Applications directory.
    2. Right-click the game folder and select Get Info.
    3. In the info box, go to the Sharing & Permissions section and click on the lock to unlock it. Enter your administrator password when prompted.
    4. Make sure all privileges are set to Read & Write.
    5. Click on the Action icon (cogwheel) and select Apply to all enclosed items. Select Yes to confirm the action.


Note: Step 5 must be done, even if the folder already displays Read & Write privileges. This helps ensure all enclosed files have the same permissions.
______________________________
Technical Support: Sunday-Thursday, 12pm - 9pm Pacific Time
How am I doing? // https://www.surveymonkey.com/s/Glaxigrav \\
No luck with that, same behavior as before.
I've finally got an error message!

"We couldn't launch %game% because your operating system wouldn't let us write to the registry.
Error: BLZBNTBGS8000000A, BLZBNTBGS80000022"


I ran the permissions repair through disk utility, but I'm getting the same problem, and no longer getting the error message.

Unfortunately, HS terminates before I can get anything useful from activity monitor.

Join the Conversation

Return to Forum