Purchase Issues with Plague Quarter

Technical Support
Prev 1 3 4 5 279 Next
gold purchase
tried 2 times and purchase failed
second login got back 700g from total of ~1360g
wing still closed
Cash or Gold purchase: Gold
Error received (if any): Was stuck at "Waiting for authorization" for some minutes, restarted the game and then the wing wasn't open but the 700 gold were gone.
Cash or Gold purchase: Gold, had 715, now 0
Error received (if any): "waiting for authorization" freeze, then the game crashed

For unknown reasons I can't seem to reply to my ticket, but anyway, thank you Game Master Sotarunu, very fast and kind :)
Cash or Gold purchase:
Gold

Error received (if any):
first attempt
something along the lines of "this item can't be purchased at this time"
-> restarted game

second attempt
stuck at "waiting for authorization"
-> terminated game from task manager
-> restarted game
-> 700 gold gone (down to 2020 from 2720) yet plage quarter still locked
Cash or Gold purchase: Gold - PC client
Error received (if any):"Gold purchase failed". After more tries the authorization window showed up and authorization failed.
I lost 700 gold and my wing is still not unlocked.
Cash or Gold purchase:

Just did an attempt to get the Plague wing with 700 gold.

Error received (if any):

Stuck at authorization. Had to cancel it after 5mins and when I rebootted the game my 700 gold was gone and the wing was still locked.
Hello! Tried to open the second wing with gold. Got stuck in the waiting for authorization part for 15 min or so. Then tried restarting the game. Started with 2025 gold, I lost the 700 and am left with 1325 gold, but the 2nd wing is not open. Windows 7 on EU server at about 2 am (gmt +3).
Cash purchase, no error, the wing is simply locked.
Yeah to all reading, I would strongly suggest you do not attempt to purchase any more than one time if you're losing gold. Myself and several others seem to have learned that the hard way. I have a sneaky suspicion that they wont be able to track the transactions, for gold anyhow and so it will be forever lost. But who knows until a member of staff confirms that..
Gold.

Attempted to purchase, was stuck on authorizing for ~30m.

Quit/restarted client, got a message that purchase failed (no gold was deducted). When I tried to purchase again, it says that I have a transaction in progress and need to finish that first.
Gold purchase on PC client
Stuck in "waiting for authorization" screen
relogged after several minutes of waiting
gold gone, plague quarter not open
Tried paying cash
EU server
Adding money to my account
In solo adventure it error'd every single time i tried to buy the whole adventure, saying the product was no available right now
Allowed me to enter my password when i tried to purchase from the shop instead but now its hanging on "Waiting for Authorisation"
EU server.
Cash or Gold purchase: Gold
Error received (if any): Waiting for Authorization screen

And i am currently stuck at this "Waiting for Authorization" screen, i didn't do any thing yet, just waiting...

So what should i do, close and reopen the game or just wait and something will happen?!
Purchased it with gold and the transaction kept pending for 10min. I closed the game and lost 700gold but the second wing was still locked.
Gold purchase

Error: Had saved ~1200 gold and tried to buy the new naxx quarter. After a couple of failed attempts the game was stuck for 10+ minutes at authenticating, so I quit the client (normally from menu, wasn't a hard kill). After restart I had only 700 gold. Tried to purchase the quarter again and it worked.
But still ~500 gold lost:/

edit: EU server
I had 1440 gold and i bought it and it took my gold then it was stuck for 5 minutes so restarted
now i have only 740 :/
Gold purchase!
Server EU

Error: Waiting autorization. Restarted after 15min and my 700 Gold is gone, the second quarter is STILL LOCKED!

Lost the 700 gold.

Edit: Second quarter opened when I restarted a game few times.
For you who are concerned about your lost gold, I just rebootted and the gold I had lost was back and the wing was still locked
Cash or Gold purchase: Gold
Error received (if any): few times Purchase Failed and stuck at "Waiting for authorization"

I lost 700 gold and haven't received access to 2nd wing.

Before: 3030 gold
After: 2330 gold

edit: Waiting for about 1 hour and 40 minutes and still nothing.
Gold purchase - EU server- PC

It subtracted me 800G due to the problem instead of 700g. The wing is opened now. So I lost 100g.

Thank you.

Join the Conversation

Return to Forum