Hearthstone doesn't load after starting the game

Technical Support
Hi,
recently I have changed the name of the folder I keep my games in, which is about only change that I think may have somehow caused this problem, but I find it unlikely.
The problem: After I start the game (via Battle.net launcher), i get loading screen (the one with closed doors and HEARTHSTONE sign in the middle) and that's where it ends. Loading screen simply does not dissapear, game seems like it can not finish loading. It does not seem to be frozen, as sign in the upper part of doors is still flashing.

As I was saying, I changed name of one of the folders in directory path to the game, but after I started battle net it correctly prompted me to locate the game and so I did.
Game was working flawlessly before. Now I can not play.

Also, Battle.net launcher is no longer using its icon, but rather default windows application one. I find this a very minor nuisance, I am just mentioning it because it is probably related to my issue.
The hang is more likely a firewall or connection issue.

http://us.battle.net/hearthstone/en/forum/topic/15269208205#5

http://us.battle.net/hearthstone/en/forum/topic/13021652494

The icon is probably because it's pointing to the icon, which you've now moved. If you right click it, then select properties, at the bottom is an option to 'change icon'. You should be able to find the icon in the battle.net folder.
Mine is doing the same thing on my tablet was just working and played fine 20 mins ago. I on the other hand have not changed anything so it has to be on your end not mine. What's going on just started doing it like 20 minutes ago
Will I get a answer
Guess not
Your answer would be the same as the one I gave the OP, check your system, check your ISP. If you are talking about a tablet you have to go through what I recommend in the common solutions to narrow down if it's your tablet or the connection. Additionally, tablet stuff would get replies over in the mobile forum, over here you are much less likely to get a reply for a mobile device. - http://us.battle.net/hearthstone/en/forum/13619661/
My problem is different, everything works properly after i turn on my computer and play at first, but if i turn off the game and later wanna play again - i can't. When i launch battle.net launcher it says ,,Playing now" and i can't do anything about it until i restart my pc. I tried to reinstal battle.net and heartstone but it didn't helped and i have that problem for few weeks now.
I can't get the game to load..
I have exactly the same problem. Waiting for some update I guess..?
I too have the same problem and it does not have to do with connection issues or anything else suggested as solutions. It's been like this for a couple days now and I tried deleting and re-downloading hearthstone and still running into same problem. If we could get someone to look into this that would be great because i don't think the problem is on our end. Unless with the new update some of the system requirements were changed?
Hello, Hearthstone is stuck on the saloon doors on my PC (AVG Security) but I am able to log in and play with no problems on Ipad.
Same problem here, stuck on the salloon doors. The thing is, it worked on a different computer earlier today... I can't seem to find a fix anywhere for this thing. It's the second day in a row i have this problem on my PC. Any help would be much appreciated. Thanks
Old thread - but still an issue. It's seemingly random if it decides to load. I can play 8 times in a row with no issues, but then out of nowhere have to try launching about 5 times before it'll decide it wants to start - it just sits on a black screen until I force quit and try again a couple of minutes later once the Blizzard/Battle.net app recognizes that HS isn't running anymore.
DrSpock, I'd recommend you start a new thread, describe the issue there, and post you dxdiag file in that new thread.
i have the same problem now can someone help me?
01/18/2019 11:19 AMPosted by BokuNoPico
i have the same problem now can someone help me?


06/05/2017 10:19 AMPosted by rabb1t
I'd recommend you start a new thread, describe the issue there, and post you dxdiag file in that new thread


Please help yourself...posting "me too" does very little when you consider that the game is available in a range of platforms (pc, mobile, mac) and each of those platforms have variations in software and hardware between their respective platforms.

So, post more info...specific info for your device...if it's mobile, make and model; if it's a pc, provide a Dxdiag and any related error logs (and start your own post instead of necro'ing). Maybe detail better what your issue is, instead of adding to the #MeToo movement.
This thread has been locked. Be mindful of resurrecting older threads. A more recent or new thread can be created to continue the discussion.

Join the Conversation

Return to Forum