Wacom tablet pen support has been removed with patch 3.1.010357

Mobile Bug Report
hey all, i have great news.
it's a temporary solution until blizzard finds a fix for this.

i created a simple script to map the pen button into mouse clicks.
i use my old lenovo x200t, and my wacom pen works again :)

1. first you need to download a program called auto hot key (AHK) from ahkscript [dot] org
this is the scripting engine. it's free. install it to default folder.

2. and here is my script that mapped the pen button into mouse clicks.
http://pastebin.com/raw.php?i=ZF2nu9qt
copy paste it to notepad, and save it to simplepen.ahk

3. double click the script (simplepen.ahk) to run it.

4. run hearthstone.

don't forget to run the script before running hearthstone.
to turn off the script, right click the AHK icon on system tray, and click exit.

note: if you have trouble clicking after running the script use keyboard and kill AHK. better yet, just restart you computer... :)

hope this works for you.
Unfortunately, the AutoHotkey solution isn't working for me. Upon running the script, clicks aren't working at all any more. Both pen and regular mouse clicks stop being registered and I cannot even start Hearthstone. Using my keyboard, I had to open the task manager and kill AutoHotkey.exe to regain control of the mouse.

Edit: I found a fix! http://pastebin.com/raw.php?i=ZF2nu9qt Using the ~ prefix in the AHK script seems to have resolved the issue, but it does have the side-effect of double clicking everything outside of Hearthstone. Not sure how to solve the latter.
Thanks a lot, jumantok
is there even hope that they'll fix it?
hey, i have updated the script to only active on hearthstone window.

http://pastebin.com/pw5mpKx3

hope this helps
Awesome, jumantok! Much appreciated.
This should be an easy fix for Blizzard. The question is if they care about it or not. Small target audience.
here's a crappy partial fix for those having the issue with wacom tablets:

if you go into wacom settings and change your pen from "pen mode" to "mouse mode", the game will start accepting your clicks.

mouse mode is pretty annoying to use when you're used to pen mode, but if you mess with the speed settings on it, you may be able to find something usable after some practice.

As long as you're using a newer wacom tablet, you should be able to set it up to only do mouse mode in hearthstone, so you won't have to change your settings back and forth. (i have an old tablet which uses the old drivers though, so i can't confirm it.)

It's still not a real fix since it doesn't work as before, but at the very least maybe it can help narrow down the problem for a real fix.

edit: oops, i hadn't seen the other fix post. well, if that doesn't work, you can try this too. and jumantok, thanks for the fix!!
Ive also got this issue, it was working fine until the update, now I cant click with my wacom.
10/04/2015 11:39 PMPosted by jumantok
hey, i have updated the script to only active on hearthstone window.

http://pastebin.com/pw5mpKx3

hope this helps


Saved my life, friend!
Still no update from Blizzard? An acknowledgement would be nice. I do not want to rely on AHK for something that worked before the last patch :C

In fact, I'm trying to use that AHK script (the updated one), but it isn't working with my Lenovo LT1423p.
10/04/2015 11:39 PMPosted by jumantok
hey, i have updated the script to only active on hearthstone window.

http://pastebin.com/pw5mpKx3

hope this helps


Im getting error on line 4

LineText:#If WinActive("Hearthstone")
Error: This line does not contain a recognized action

And then the AutoHotkey exit
Thanks so much, Jumantok! Worked easily.
Hey Blizz! Maybe fix your game? It's not like this bug was just found this is nearly a Month old!
Sheesh...
I can verify that this is also still broken for me, using Windows 7 and a Wacom Graphire4 tablet. Tablet works perfectly fine for everything, it just can't register clicks while in-game. I don't know what it is about the game that can forcibly disable clicking with a pen when it works just like a mouse for literally everything else, but a fix would be very much appreciated!
Same issue on my intuos 4.

Fix please.
Thank you!
Despite the patch notes for v3.2.0.10604 saying various UI issues have been resolved, this issue is still present. Very sloppy and disappointing.
Yeah, they def broke this in rel. 3.1.0 so of course it can be fixed.
But thank you for not caring Blizz, so nice of you greedy bunch.
This makes no noticeable difference for their profit, so why should they care?

Nobody even cares to read/answer this thread or other threads with the same prob.
That just bad considering there is no real bug tracking system.

Join the Conversation

Return to Forum