False Launch & Location Troubles

Technical Support
Greetings, Tech Support.

I went into my D: drive (I've rerouted everything from C:) and saw that Hearthstone was a separate folder from Battle.net. So I moved the Hearthstone folder into the Battle.net one, closed the window and saw that the Hearthstone desktop launcher was a white page. I went back into the new Hearthstone folder location, dragged the launcher onto my desktop and tried again, but got a message saying an accompanying file was missing. So I went into my start menu, found the desktop app, and tried that, but now whenever I launch, it starts fine, then closes to the Battle.net menu.

How can I fix this? Thanks in advance.

*EDIT* I'm on Windows 10 if it matters.
Hey AtheneOwns,

The Game folders are by default in a different folder then the Battle.net. You can place it in a different location if want. Usually you would want to pick a new location when you install it. By moving the file to a new location it broke the shortcut on your desktop. The shortcut would be pointing to the location to where the game used to be not to where it currently is. Also the Launcher needs to be in the game folder for it to work properly.

I recommend deleting the old Hearthstone shortcut and then moving the Hearthstone launcher back in to the Hearthstone folder. You can then right click on the Hearthstone launcher and create a new short cut.
If the above doesn't work, I'd recommend putting all the things back into the Hearthstone folder, deleting the desktop shortcut, going to the battle.net main window, and having it scan and repair Hearthstone. After that, click options again and have battle.net create a new desktop shortcut.
Thank you both for responses. Sorry for my own latency, I was at work.

I have acted upon both suggestions, however I still have an issue. When I launch from the desktop shortcut, Hearthstone opens, I see the tavern doors and then it crashes to Battle.net.

I repaired the game, it said no repairs were warranted.
With a little help from my cousin I managed to fix my issue through means of a custom shortcut. Thanks so much, take care. :)

Join the Conversation

Return to Forum