FPS FIX - SOLUTION

Technical Support
Since Blizzard isn't competent enough to dignify me with a response on this matter rather than the usual ''Update the video card driver and provide us with DXDIAG AND MSINFO files'' BS - you can use mine, proven method which can boost your FPS until they fix up this mess.

1.Go to Control Panel -> Folder Options - Show hidden files and folders.

2. After step one, go to Local Disk C - Users - Your username - AppData - Local - Blizzard

3. Open Blizzard -> Heartstone folder - and after that, open options.ini (wordpad or notepad).

4. ADD anywhere in the document

targetframerate=144
showfps=True
vsync=0

5. Set resolution to 640x480 by using these files in the document

graphicsheight=480
graphicsquality=0
graphicswidth=640

Also change graphicsfullscreen=False

6. Save the document, exit it.

7. Run Battle net, then Heartstone.

8. Go to Task Manager and set Affinity to RealTime.

9. Once your HS starts - you can drag it to the point where your FPS is pleasant. Drag it as in terms of resizing it, once I've set my HS to 640x480 (which is in windowed mode btw) it looks really small but luckily you can enlarge it with your mouse easily. The only way to see FPS right now for me is to use Fraps (you can get the free version below)

http://www.fraps.com/download.php

(ANYTHING ABOVE 45 IS pleasant for the eye, anything below 30 is sluggish).

This is the only way of getting that ''stolen'' FPS back. Hopefully this will prove of use to the people who have the FPS issue since Un'Goro.

IMPORTANT - YOU NEED TO SET IN OPTIONS.INI ''graphicsfullscreen=False'' OTHERWISE THIS WON'T WORK!
Finally someone found a solution! Thank you Sacramento, with this solution it is fine for me now atm, but I hope that Blizzard will fix it soon, so we can play the game as before!
This is working, thank you.
It's embarrassing when blizzard ignore a problem that <removed> ton of people are reporting...

[Edited for language by Moderator - please review the Forums Code of Conduct]
This helped me out. Thanks mate!
Great topic...I think this might help me since I haven't be able to load the game since patch 8.2. however, I can't execute this because of 2 elements:

graphicsquality=0 ----> I don't havbe this option in the file

Go to Task Manager and set Affinity to RealTime. --> It doesnt allow me. Instead the system places it under HIGH

Can you please help? Thanks
06/11/2017 12:26 PMPosted by jackhorny
Great topic...I think this might help me since I haven't be able to load the game since patch 8.2. however, I can't execute this because of 2 elements:

graphicsquality=0 ----> I don't havbe this option in the file

Go to Task Manager and set Affinity to RealTime. --> It doesnt allow me. Instead the system places it under HIGH

Can you please help? Thanks


Just add the graphics quality line, it should work.

As for the Affinity, you can use High, it's probably the administrator account so you need to look that up.
This fixed my problems. Thank you, sir.
Thanks! Adding only this line
targetframerate=144
fixed it for me.
01/01/2018 11:22 AMPosted by ManyFold
Thanks! Adding only this line
targetframerate=144
fixed it for me.


This solved my problem too. Just simple line and it was solved. Lmao of those who removed this line from the options of the game.
Totally worked, THANK YOU
update, this did not work.
145 fps for me.
Thank you very much!
Fixed my issues.

Thanks.
Oh wow. Options.txt (for me) was so easy to find in that folder.

All I needed was:
targetframerate=144
vsync=0

All of my stuttering and awful performance evaporated. Perfect 1440p 144hz Hearthstone. I was stuttering down to 25 and lower FPS with a 4770K and a 1070. A year of frustration ended with a simple Google search.

Blizzard: Why isn't this a default setting?

Sacramento: You are my hero. Thank you!
04/27/2017 06:44 PMPosted by Figaro
It's embarrassing when blizzard ignore a problem that <removed> ton of people are reporting...

[Edited for language by Moderator - please review the Forums Code of Conduct]


This issue has been around for a long time. It seems to affect me after a while. Glad all that $$ is going to bug fixes etc... /s
Thankyou very much. This fixed my issue.
Suspicious cause all my Steam games work great with high framerates on Windows 10. I think Blizz needs to put some more resources into making their game better instead of pumping out expansion after expansion.
TY so much it was 30 now its 103 FPS. :)

Join the Conversation

Return to Forum