resolution on mac broken again

Mac Technical Support
since of todays patch (caverns below nerf).

gotta reselect the resolution every single time after launching again or it looks stretched.
Hey cycledance,

Normally when I have seen there be an issue with game setting not saving between game launches it is due to a permission issues. The steps below will usually fix this.

Resetting Game Folder & File Permissions
Repairing Application Support Permissions
07/11/2017 06:49 AMPosted by Eloemaz
Hey cycledance,

Normally when I have seen there be an issue with game setting not saving between game launches it is due to a permission issues. The steps below will usually fix this.

[url="https://us.battle.net/support/en/article/Resetting-Game-Folder-File-Permissions-Mac"]Resetting Game Folder & File Permissions[/url]
[url="https://us.battle.net/support/en/article/Repairing-Application-Support-Permissions"]Repairing Application Support Permissions[/url]


did both step by step and the problem persists.

and it's no coincidence that this happened after yesterdays patch where obviously the window modes were tinkered with (see the menu bar thread).

this kind of stretching is new. but ever since the switch to unity 5 the game was slighlty blurry unless the resolution was reselected (i bet 99% of ppl did not notice) EXCEPT for the last patch where everything was perfect (this lasted a mere 41 days).
the same. two steps from Eloemaz not help. What else can resolve a problem?
I have the same problem. All the time need to go to options and click on the existing resolution to fix the problem.

BTW, I tried both steps, not working.

MacBook Air macOS Sierra 10.12.6
This is affecting me, too. Cycledance is correct. It is clearly not a game setting issue. It's not a case of the game changing resolutions, but a case of the game's graphics looking "scrunched in" for lack of a better term, on launch and then springing back to their proper shape if you adjust the resolution. It has been a longstanding Mac client issue that was temporarily 'resolved' by the patch most recent to the 9.0 KFT patch, at least for me. I also assume it has something to do with the Unity engine that Blizzard uses for Hearthstone.

MacBook Pro Retina (2012) - macOS Sierra 10.12.6
I've had the same problem for about a year. Game boots and options menu says it's in 1920x1080 but the screen is actually a bit squished (not sure exact resolution but there are black bars on the left and right side of the hearthstone title screen and then when you get to the actual menu it looks slightly squished horizontally). Clicking on 1920x1080 (even though it's already currently selected) restores the correct aspect ratio.
Yes, I do not use my MacBook Pro very often, only when I travel but not for work. Had to patch before getting my Hearthstone fix and I instantly noticed the screen was squished. I don't think this was ever the case on my Mac. Noticed in options it was set to the max resolution, changed it and changed back, I was surprised how it actually looked normal again, even though it was the resolution it was on when I started the game. Did a restart to see if it stuck and it was squished again. It appears that I will have to keep changing the resolution on and off every time I boot the game. This seems to be a Blizzard issue if it is capable of producing the native resolution, and I believe it did before I patched. This should be addressed unless Blizzard believes that Mac users are far and few between and the ones like me do not use Mac very often, but when I do or need to, I expect a company like Blizzard to be on their "A" game on all fields where they play.

Please address this, this should not be too much effort.

Thank you.
still not fixed with the update to unity 5.6.
Same thing, i usually just click on window mode and back to fullscreen to fix it but its soooo annoying to do EVERY logon...
Same here with 27“ iMac 2017. Very annoying.
Still not fixed!
https://imgur.com/a/cE8pa

Join the Conversation

Return to Forum