Game does not start

Technical Support
Each time I try to connect, the app open to loading screen and never actually open the game.
Same issue on both my iPhone and my android tablet. I tried multiple wifi access or phone network but nothing works.
I bought some packs on amazon and played last night and it was working perfectly fine.
Can you help?

Thanks
Sorry I should have add that I uninstalled the game and reinstalled it. Then I can log in with my account and go again to the endeless loading. This look to me like an issue with my account :(

Please help!
Same issue here. Yesterday evening everything was fine on my samsung phone. And this morning i got stuck while loading at the hearthstone logo. And stays there. I've also reinstalled the game. When i startup again i can login. But then stuck again at the loading.
Pls help
Since these are mobile issues I'd recommend checking/posting in the mobile forum.
http://us.battle.net/hearthstone/en/forum/13619661/

Also note times for maintenance. I see EU should have finished 12 hours ago, and you posted this 5 hours ago, but there may be something of note there if you are playing over there.
https://twitter.com/BlizzardCSEU_EN
I have check forum as per your link but nothing that solved my problem. Also I tried again today to play after the maintenance but still nothing works. I really suspect something wrong with my account.

Anyone have other solution or can help here?
Hi there LompeHenk and Chousty,

I looked over your cases and did some changes with your accounts. You should have Password resets in your email now to get back in. If this fixed the problem or you are still broken, please post the info here. Once again, even if it is fixed, I ask you post there.

/Nathardrick
Resetting my password worked!!!
Many thanks for the fast feedback and solving!
I have the same issue... can i do something or just wait for a password reset too?

Join the Conversation

Return to Forum