So sick of problems after every update!

Technical Support
So many people having a hard time launching the game after your latest update. Why can't your company get their !@#$ together! I shouldn't have to try and launch the game 6x just to get it to startup. I am sick of this! I can't even play right now! I have already tried to launch the game 6x and still not working!
11/12/2017 05:31 PMPosted by happyskunky
So many people having a hard time launching the game after your latest update. Why can't your company get their !@#$ together! I shouldn't have to try and launch the game 6x just to get it to startup. I am sick of this! I can't even play right now! I have already tried to launch the game 6x and still not working!


If this is an issue you actually want help with, I'd recommend actually describing what your settings are, what device you have (like if you say mobile I'd respond this isn't the mobile forums, and UI detection on mobile is known to not always detect correctly on some devices), maybe post a dxdiag file, mention your in-game settings, etc.
If you're having problems with every patch, it's highly unlikely that Blizzard is to blame.

Maybe if you actually followed up on your complaints with some info on your system, you might get some help.

Good luck!
Hey, happyskunky !

If you are getting a white screen (unresponsive) for Hearthstone when you launch it, can you try disabling the Blizzard streaming option in the Blizzard app Settings? The check box will be under the Streaming section.

I had this issue at home and this is what resolved it for me.

Join the Conversation

Return to Forum