Can't Sign In anymore from iOS/iPad

Technical Support
So I’ve been trying to login and hasn’t been working. I put in my info and it just sits there. So I finally came to the conclusion of maybe I just have to start over and so I did the tutorial and then when it takes me to the screen to make an account nothing loads. Please help I have spent money and have tried everything, I’ve restarted my phone, redownloaded the game.
On the iPad Pro this thing still happens
Change region and log in. Then get back to your usual region and you should be able to log in normally.
Having the same issue on iPad Pro - no idea how to fix it, I’ve tried everything. There is no option to change region that I can see, since re-installing.
New user here on iPhone XS, up to date software, and when I logged in to connect it took me back to the log in screen - tried again and it acted weird. Now if I try logging in it just says "Loading..."

To respond to the one suggestion I've seen, I've tried on both my home network and my work Wifi as well as on my cell network and all have the same problem. I'm not going to delete and redownload the game, because if I do that I'll lose all of my progress and frankly I'll just stop playing if that's the only solution.

20 year Blizzard fan from back in the original Diablo/Starcraft/Warcraft days, always loved the company, so I'm sure this will be fixed right.
I'd really like to see this topic get some Dev love. Otherwise you're going to lose users. Seems to be a common enough problem.
Still nothing but silence from Devs. Blizz is making money off the app but they can't make simple patches like this??
I’m having the same problem, and I’m new so it’s especially annoying because I’ve worked really hard and if I lose my progress I’m so !@#$ed

Join the Conversation

Return to Forum