Hearthstone won't start

Technical Support
Been having this issue since yesterday. I click the play button in the bnet app and when it loads. All the screen shows is the tavern doors but the game does not actually start. I tried running a repair but the bnet app says it does not need one. Not sure what to do to fix it.
Hey FinalBoss,

In this case, let's try closing the Blizzard app entirely and then delete the temporary Battle.net files. Security programs can also cause conflicts, so make sure that Hearthstone is allowed as an exception or temporarily disable the security program to test Hearthstone by itself.
I tried making HS an exception, deleted the file you mentioned, and even uninstalled by anti malware, but still no luck.
Is it possible to test an alternate network, like a mobile hotspot?
I have the same issue from yesterday. It is the same on different devices and only on Americas server. Europe and Asia works fine. Please help.
Any solution??

EDIT: It is working now, no idea why.

Join the Conversation

Return to Forum