Technical Support

Mar 13, 2014 Welcome to Heroes of the Storm Technical Support! Welcome to the Technical Support forum for Heroes of the Storm. This forum exists to provide Heroes of the Storm customers with a place to discuss technical issues with each other and Blizzard Tech Support staff members. Blizzard Tech Support staff regularly monitors and replies to this forum (between 8am-8pm Pacific, weekdays) and will do their best to assist you with your issue. If you cannot resolve your issue through the forum, we recommend checking our Knowledge Center for resolutions and workarounds for common issues at http://battle.net/support/ and if unable to locate a solution, please go ahead and create a new post regarding your issue using the guidelines below. Please keep all posts on topic. This means technical issues, advice, and discussion of technical issues. Game discussions, criticism, or commentary should be posted in the General Discussion forum. When requesting assistance with or discussing an issue, please create your own thread unless a topic for the issue already exists. Do not hijack threads with your new topic. Posting an issue which is similar but different from the original topic means that your request may be missed or the original request ignored. Please post a subject with a clear summary of your issue. Starting posts with "I need help!" or "Can't play no matter what" only serves to make your issue harder to resolve. We understand that emotions can run high while dealing with technical issues, but posting in an abusive or disparaging manner will not be tolerated, and does not advance our goal of providing assistance to the widest audience of customers in this forum. Please do not post direct contact info for other companies. It is acceptable to post links to websites where contact info can be found, but posting the information here on the forum is not permitted. To provide feedback on a ticket or customer support response you have received, please utilize the survey system built in-game or on the online ticket. We hope that this forum can continue to be a place where users can find quick resolutions to their issues. To help do this we ask that the Forum Code of Conduct and forum guidelines be observed at all times when contributing to discussions.Velnrak0 Mar 13, 2014
Jan 15, 2015 Patching and Installation Troubleshooting Patching and installation issues are some of the more common issues that we come across in the Tech Support Forums. This thread will highlight some troubleshooting steps that have been proven to resolve most of the patching and installation issues that you as a player may encounter. Most of the support articles linked below will include steps for both, Windows and Mac systems. However, if you require further assistance with a Mac Installation or Patching issue that has not been mentioned in this sticky thread, you will want to post in our Mac Technical Support Forum. Installation Troubleshooting Steps Patch Troubleshooting StepsDankorii2 Jan 15, 2015
Aug 18, 2015 Performance/Stuttering Troubleshooting Hail and well met, Heroes! If you should experience any kind of performance issues or stuttering within the Nexus, there may be some useful tools to help analyze and troubleshoot what disruptions may be occurring. This guide should help identify what may be happening, what steps to try, and what to include should you require further assistance from Technical Support! When troubleshooting an issue, please make sure to create your own thread, unless an ongoing issue has been stickied. Many issues will appear to be related, but are instead tied to individual system components or settings. By isolating each issue, it helps Technical Support provide better assistance and connect like issues together more quickly.Glaxigrav4 Aug 18, 2015
May 18, 2016 Game Crashes due to Overlay Software (Curse/Discord/Overwolf etc) We are currently aware of an issue resulting in game crashes when using overlay programs. Overlay programs are applications that display information over top of Heroes of the Storm (such as voice chat information). Since these applications add information in our rendering process, they may cause Heroes to crash. Temporarily disabling or uninstalling the overlay application may resolve the crash. Additionally, you can also try a Selective Startup to disable all background programs on restart, which may resolve additional crashes.Glaxigrav0 May 18, 2016
Apr 30, 2015 Overclocking Notice Greetings! We've been investigating a series of graphical and crash related issues lately, and have noticed that users may be running overclocked graphics cards. Overclocking is the process of forcing hardware to operate faster than the manufacturer's default clock frequency. Overclocking can cause marginal performance improvements, but will also create instability in your system resulting in glitches or crashes. This can cause trouble with games that run your hardware at full tilt, such as Heroes of the Storm and Starcraft II. What many users don't know, however, is that some manufacturers will sell cards with terms like "Superclocked," "Turbo," and "Supercharged" to denote that they have been overclocked. As we call out in our performance troubleshooting articles, we recommend contacting your card manufacturer for assistance with downclocking your card to safe parameters as set by the vendor (Nvidia, AMD, etc.). If you are not sure if your system is overclocked, you can use the following tools and steps: 1. Download a third-party tool such as GPU-Z, which shows clock speeds. 2. Once loaded, look for the Name and GPU Clock Speed. 3. Look up your graphics card clock speed through a search engine. Recommended search terms include <Graphics card name> base clock (Example: Nvidia GTX 770 base clock would lead to a product page here) 4. Compare the Base Clock Speed from the manufacturer's documentation and your recorded GPU Clock Speed. If your GPU Clock Speed is greater than the base, your card is overclocked. If you find that your card is overclocked, speak with your card manufacturer for assistance in adjusting the clock speed to that of the vendor-recommended settings. Popular manufacturers include Gigabyte, MSI, EVGA, PNY and ASUS. For Nvidia Cards: Opening the Nvidia Control Panel and clicking Help > Debug Mode from the menu will set your clock speeds to factory recommended. You can enable this mode to verify if overclocking is causing a game issue.Glaxigrav0 Apr 30, 2015
Apr 7, 2014 Payment & Purchase Troubleshooting If you are experiencing difficulties upgrading your account, or completing a character service, please follow these tips: Payment Option/Billing Profile A Billing Profile is required to make purchases within Heroes of the Storm. In the event that your purchase fails, double-check your Payment Options for accuracy as expired cards do not automatically remove themselves. 1. Log on to Account Management 2. Click on Settings and select My Payment Options 3. Click on Add a Payment Method 4. Add all the required information and click Save Payment Method when you are done 5. Success! You are finished adding a Billing Profile Multiple Billing Profiles and Primary Payment Method If you have multiple Billing Profiles on your account, make sure that the card you are using to make the purchase is set as the 'Primary Payment Method'. By default, we will always default to your Battle.net Balance before using your Primary Payment Method. 1. Log on to Account Management 2. Click on Settings and select My Payment Options 3. Look for the card you wish to use and click on ‘Make this my primary payment method’ You can also add, remove or edit payment methods on this Wallet page. Credit Card Payment Assistance/Invalid Credit Card Errors If you are encountering credit card errors and have already added a Billing Profile, please verify that all the information is entered as it appears on the card. This includes: Card holder’s Full Name Full Card Number Expiration Date Billing Address Verification Code Additional troubleshooting steps can be found in our Common Credit Card Payment Issues page. **Note** For security purposes, please DO NOT post any of the above information on the forums. Should you continue to experience any payment related issues and you have already talked to your financial institution, please contact our billing and account services team directly. ______________________________ Technical Support: Monday - Friday, 12pm - 9pm Pacific Time How am I doing?Glaxigrav0 Apr 7, 2014
Jul 20 End of support for Windows XP and Vista coming soon (post borrowed from Nate Valenta - Community Manager) Starting in October of this year, we will begin the process of ending support for Windows XP and Windows Vista in World of Warcraft, StarCraft II, Diablo III, Hearthstone, and Heroes of the Storm. Microsoft ceased mainstream support for these versions of Windows in 2009 and 2012, respectively, but since a decent portion of our audience was still using them at the time, we continued supporting them. However, there have been three major Windows releases since Vista, and at this point, the vast majority of our audience has upgraded to one of the newer versions. The games will not run on these older operating systems once they are no longer supported, so we encourage any players who are still using one of the older OSes to upgrade to a newer version. We’ll be rolling out this change on a staggered schedule, and will post further notices as we get closer to making the change for each game.Omrakos0 Jul 20
Jul 1 Common Connection and Latency Issues Greetings all, We've been working to improve some of the available troubleshooting resources for our games. Since connectivity problems are a common problem in gaming, we wanted to provide some information on what causes connection problems and what to do to resolve issues when you're having them. Table of Contents 1. Connection Troubleshooting Resources 2. FAQs 3. What to do if you need more helpDrakuloth4 Jul 1
Jun 14 Crash and stability issues using the 32-bit client on 64-bit OS If anyone is experiencing crashing and game stability related issues on a x64 (64-bit) operating system while using the 32-bit Heroes of the Storm client, please try launching the 64-bit Heroes of the Storm client instead. This resolution is not intended to increase performance or framerate. If you are having performance or framerate related issues, feel free to make a forum post in the Heroes of the Storm Tech Forum or contact us at http://us.battle.net/support/ and we will be do our best to help you figure out the cause. You can locate this option in the Blizzard App: Options dropdown on the Heroes of the Storm tab Select Game Settings Scroll down to the Heroes of the Storm section Make sure the checkbox for "Launch 32-bit client (instead of 64-bit)" is not checked. Press the "Done" button If switching to 64-bit makes the game unplayable, please create a support ticket and we can help you get the game in a playable condition while using 64-bit.Ibaraius0 Jun 14
Apr 9 Crashing and Windows 10 Creators Update Hello all, We have seen that the latest update to Windows 10 has been re-enabling the Xbox Game DVR. Heroes of the Storm could crash and have other performance issues when the Xbox DVR is enabled. To disable the DVR, please try the steps below for disabling it: 1) Open the Start menu. 2) Click Settings. 3) Click Gaming. 4) Select Game DVR from the sidebar. 5) Toggle Record in the background while I’m playing a game to Off. If disabling the game DVR does not resolve the issue, please also ensure that your graphics drivers are up to date: NVIDIA video cards AMD video cards Intel video cards After that, you're still experiencing crashes please create a new post with a DXdiag attached or contact customer support. DxDiag: 1) Press Windows + R Keys. 2) Type DxDiag and press Enter. 3) In the DxDiag window, click Save All Information. 4)Name the file "dxdiag" and click Save 5) Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable. Eloemaz0 Apr 9
3h Constant lag spikes I'm getting periods of big lag spikes that last for several seconds, then subside for maybe a minute or so. This keeps happening throughout every game, making it virtually unplayable. Any assistance would be very much appreciated. I've gone through all the troubleshooting steps from here, including the advanced ones: https://us.battle.net/support/en/article/15907?utm_source=internal-support_forums&utm_medium=posting&utm_campaign=BlizzardCSEU&utm_content=solution Here's a traceroute I ran while the issue was occurring: =========================================================== Tracing route to 24.105.30.129 over a maximum of 30 hops 1 9 ms 7 ms 9 ms 192.168.0.1 2 25 ms 19 ms 20 ms 10.57.64.1 3 22 ms 29 ms 29 ms 10.200.1.21 4 18 ms 19 ms 21 ms hostpool3-62.miracopa.orbitelcom.com [216.9.177.62] 5 19 ms 19 ms 19 ms 208-95-94-253.gilanet.net [208.95.94.253] 6 28 ms 29 ms 31 ms 6-2-11.bear2.Phoenix1.Level3.net [4.28.83.101] 7 39 ms 39 ms 30 ms 4.69.153.121 8 28 ms 30 ms 29 ms BLIZZARD-EN.edge2.LosAngeles9.Level3.net [4.53.230.238] 9 38 ms 30 ms 38 ms 37.244.0.35 10 911 ms 1055 ms 25 ms 37.244.0.103 11 33 ms 49 ms 39 ms 24.105.30.129 Trace complete. =========================================================== Here's a Looking Glass report: TRACEROUTE: traceroute to 66.182.125.137 (66.182.125.137), 15 hops max, 60 byte packets 1 24.105.30.2 (24.105.30.2) 1.528 ms 1.516 ms 1.529 ms 2 * * * 3 37.244.0.102 (37.244.0.102) 1.265 ms 1.315 ms 1.374 ms 4 37.244.0.34 (37.244.0.34) 1.169 ms 1.244 ms 1.299 ms 5 xe-9-3-0.edge2.LosAngeles9.Level3.net (4.53.230.237) 0.872 ms 0.906 ms 0.907 ms 6 * * * 7 GILA-LOCAL.bear2.Phoenix1.Level3.net (4.14.64.30) 26.010 ms 26.019 ms 26.003 ms 8 208-95-94-250.gilanet.net (208.95.94.250) 26.507 ms 26.498 ms 26.494 ms 9 hostpool3-61.miracopa.orbitelcom.com (216.9.177.61) 26.390 ms 26.268 ms 26.339 ms 10 * * * 11 * * * 12 * * * 13 * * * 14 * * * 15 * * * 21/08/2017 04:41:14 UTC -------------------- PING: PING 66.182.125.137 (66.182.125.137) 56(84) bytes of data. --- 66.182.125.137 ping statistics --- 4 packets transmitted, 0 received, 100% packet loss, time 2998ms 21/08/2017 04:41:14 UTC -------------------- MTR: Start: Mon Aug 21 04:41:14 2017 HOST: Blizzard Loss% Snt Last Avg Best Wrst StDev 1.|-- 24.105.30.2 0.0% 10 0.8 2.1 0.5 14.2 4.2 2.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 3.|-- 37.244.0.102 0.0% 10 1.3 1.3 1.2 1.4 0.0 4.|-- 37.244.0.34 0.0% 10 1.4 1.3 1.2 1.4 0.0 5.|-- xe-9-3-0.edge2.LosAngeles9.Level3.net 0.0% 10 0.9 1.1 0.9 1.7 0.0 6.|-- ae-1-11.bear2.Phoenix1.Level3.net 90.0% 10 17.0 17.0 17.0 17.0 0.0 7.|-- GILA-LOCAL.bear2.Phoenix1.Level3.net 0.0% 10 26.3 24.9 20.9 27.5 2.4 8.|-- 208-95-94-250.gilanet.net 0.0% 10 26.7 26.3 23.7 28.4 1.5 9.|-- hostpool3-61.miracopa.orbitelcom.com 0.0% 10 26.6 26.1 23.8 28.5 1.6 10.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 21/08/2017 04:41:14 UTC --------------------Khras1 3h
5h Disconnecting after game since new patch. After a game it shows a screen saying re-connecting, then it goes to the exit screen where I can only press Options, Hotkeys, or exit the game.The only option is to exit the game because it doesn't re-connect and I lost 4 games stimpacked XP because of this frustrating thing. It also happened to my friend many times. It's so annoying.EleMented11 5h
7h I finished my game but i got a penalty I just played a game and the game ended.I lagged then it showed something that said the game ended the only option to leave the game was exit to desktop.Then i clicked it but it showed a warning that if i leave too many games i will get punished.There was nothing else to leave the game so i clicked leave to desktop.I left like one game but that was from lag.Flakeyclub58 7h
11h Heroes of the storm module I've tried all the the steps for authentication module and it still hasn't worked can someone please help meXxLoLxX0 11h
11h Black Screen Mid game Since the latest patch i keep getting random black screen during the game, almost like an alt + tab out. When i look at my gamelog it says something about Focus Event. Chaning to fullscreen, then its immediately followed up by Focus Event. Changing to windowed. Help please. I am posting a copy of the gamelog below, it has happened over 30 times since the patch. GFX 20:31:37.025 ==================================================================================================== GFX 20:31:37.025 Heroes of the Storm (B56361) GFX 20:31:37.025 GFX 20:31:37.025 Executable C:\Program Files (x86)\Heroes of the Storm\Versions\Base56361\HeroesOfTheStorm_x64.exe GFX 20:31:37.025 <Parameters> -sso=1 -launch -uid heroes GFX 20:31:37.025 Parent Executable \Device\HarddiskVolume4\Program Files (x86)\Heroes of the Storm\Support64\HeroesSwitcher_x64.exe GFX 20:31:37.025 Grandparent Executable \Device\HarddiskVolume4\Program Files (x86)\Blizzard App\Battle.net.9093\Battle.net.exe GFX 20:31:37.025 LocalTime 2017-08-20 20:31:37.025 GFX 20:31:37.025 <ComputerUser> Owner GFX 20:31:37.025 <ComputerName> DESKTOP-BHV0NU1 GFX 20:31:37.025 <Exe.Architecture> x86_64 GFX 20:31:37.025 <Version> 2.27.1.56361 GFX 20:31:37.025 <DataBuild> B56361 GFX 20:31:37.025 <CodeBranch> branches/Heroes.27 GFX 20:31:37.025 <CodeRevision> 493607 GFX 20:31:37.025 <Locale.Assets> enUS GFX 20:31:37.025 <Locale.Data> enUS GFX 20:31:37.025 <Locale.Install> enUS GFX 20:31:37.025 <AccountCountry> USA GFX 20:31:37.025 <AgentVersion> 2.12.4.5750 GFX 20:31:37.025 TelemetrySessionId E4299A59-E826-4000-B8F0-B000E178E857 GFX 20:31:37.025 ==================================================================================================== GFX 20:31:37.024 DXGI: Available GFX 20:31:37.035 VRAM Override Variables: Dedicated [0MB] Shared [0MB] GFX 20:31:37.147 Adapter "NVIDIA GeForce GTX 1050 Ti" Vendor 0x4318 Device 0x4318 GFX 20:31:37.147 Adapter "Microsoft Basic Render Driver" Vendor 0x5140 Device 0x5140 GFX 20:31:37.147 Skipped adapter "Microsoft Basic Render Driver" because no ouputs GFX 20:31:37.147 Attempting D3D11 device creation on "NVIDIA GeForce GTX 1050 Ti" GFX 20:31:37.449 Device creation success. GFX 20:31:37.450 VRAM Override Variables: Dedicated [0MB] Shared [0MB] GFX 20:31:37.450 VRAM Override Variables: Dedicated [0MB] Shared [0MB] GFX 20:31:37.450 Initialized D3D11 GraphicsDevice: NVIDIA GeForce GTX 1050 Ti (Driver Version: 0.38205.0.0, VRAM: 4050MB, SVMEM: 8141MB). GFX 20:31:37.450 Setting up swap chain. GFX 20:31:37.455 Found matching display mode width: 1920 height: 1080 RRN: 59940 RRD: 1000 GFX 20:31:37.456 Resizing D3D11 swap chain (1920x1080) GFX 20:31:37.457 Hardware Depth Sampling: Available GFX 20:31:37.481 Resource Cache Override Variable: 0MB GFX 20:31:37.481 Resource Cache: 2048MB Win64 (16283MB Physical, 13611MB Process Virtual) GFX 20:31:37.481 Resource Cache Sound: 204MB GFX 20:31:37.481 Resource Cache Common: 450MB GFX 20:31:37.481 Resource Cache Texture Max: 1500MB GFX 20:31:40.527 PerfNotifiers initialized GFX 20:31:40.548 Focus Event. Changing to fullscreen. GFX 20:31:41.229 Resource Cache Texture: 950MB GFX 20:31:41.229 Resource Cache Texture Used: 0MB GFX 20:32:21.000 Focus Event. Changing to fullscreen. GFX 20:32:26.918 Focus Event. Changing to windowed.bmonk3y3 11h
11h Lunar Rooster Mount missing Hi, After the launch of HOTS 2.0, my lunar rooster mount is missing from the game? IS it a bug or some issue going on?MooMooWoo5 11h
11h Connection Lost at End of Every Match, Losing XP for no reason! This evening 80-90% of my matches, after winning or losing, go to "reconnecting to the game." As a consequence, I am not getting an XP. Enjoying the games, but sorta frustrating losing XP while I try to level Kerrigan.wwvuillemot7 11h
11h Disconnect when it's over, loose xp and get defeat Mac user, loosing exp and moreover even when we won the game I get defeat and PENALTY without being able to play ranked!!! This is outrageous. What the hell Blizzard? I demand to return my xp, to return my wins and lift penalties I got for ''being a leaver''.Trollmarine2 11h
11h Disconnect/Reconnect at end of game 0 gold/xp Hello, For the past two weeks, I have been disconnecting at the end of my winning games, causing me to lose experience/gold. The system counts the games as having been played, but I haven't been able to reap my rewards. I read an old forum post which mentioned this as a bug that occurred two years ago. It is affecting me now, and I want to know if this is an issue on the client side or on the server side. I have tried reinstalling and resetting my modem/router, with no change. What can I do to fix this problem? Is there a solution you guys can provide? Thank you!Ragnorok3 11h
11h Mouse Issues So, just got back from deployment, after the update I can't use my mouse in game. Everything else seems perfect. I can use it on everything except HOTS. How can i fix it?ewell2 11h
12h Disconnect after finished a game I always get disconnection after finished a game. There is no connection lost, no lagging, etc during the game. I could play it smoothly but after a core is demolished whether victory or defeat, it will show 'reconnecting' and my hero won't get any exp after game. it's happened many times lately and so frustrating :( (more than 5 games for just today) could you please kindly check and any suggestion? Thank youAimeTPGM2 12h
12h Frequent disconnecting at the end of a game This bug has been present since the introduction of the new patch -- frequently, at the end of a game (at the MVP screen), the game disconnects me. For a while, it would force me to quit the game entirely; now, I am eventually reconnected to the game, but I gain no gold or XP from the match at all. I know I'm not the only one experiencing this, as I've seen quite a few posts about it dating weeks back. Very frustrating indeed!jiltedjohn2 12h
12h Zero experience as an MVP Hi, I got zero experience in my last game. Anyway to fix it? I hope my stimpack purchase is worth for every time i'm playing. ThanksCaptDC1 12h
14h My account reset to level 1 with no heroes (correct region) I even made sure to check that I was in the right region but my account is level 1 with a valid match history but no exp, what happened? Lost my mega hero bundle characters too.Muse1 14h
15h Cannot Change Hot Keys And Lost Custom Default I went to Gen Con this weekend and while there played HOTS. I changed hot keys for those games to what I"m used to then played. Today I sat back down at home and all my hotkeys have been reset to default on my computer. When I try to change them it says "Standard is an official Blizzard Profile and cannot be changed. You will need to create a new profile or discard changes." But I don't want to create a new profile and be forced to start over! I'm not sure why it is glitching like this. I tried restarting the game, the blizzard platform, and logging out then logging back in, but it still does this. The only thing I can think of is that while at Gen Con I was playing in a ranked game and ran out of computer-rental time (I seriously tried my hardest to have them extend it but they wouldn't). So I got disconnected mid-game. But I don't see how that would have glitched my entire profile. Please help!KingOvermind0 15h
15h Battlenet rapidly disconnecting Disconnecting regularly since yesterday. Game and bnet will load up and the will frequently "Battlenet connection lost" It gains connection quickly, but then loses it just as frequently. I haven't noticed any issues with my internet or any other non blizzard games.Beaubinski0 15h
17h Corsair Utility Engine (CUE) Causes maps to not load...? Okay, so this is SUPER weird. After the windows 10 update, I've been running into some problems (kill me). Anyways, my CUE has been causing my maps to not load when i play a match. I have to kill the hots.exe, and have to restart the game. How do I know its this specific program? Well, about 20 minutes ago, I did a little experiment. I didn't launch CUE before launching hots. I started playing a match and noticed my CUE wasn't activated. When I went into my desktop and launched CUE, i my map immediately disappeared, just a black screen with some character models, forts, keeps, and highlights. Nothing else. Now I understand this may be a CUE thing alone on its own. I mean, it's been having problems ever since i installed updates for windows 10x64. I've been getting error messages "0x0000020" specifically speaking. Each time I turn on my computer, I get this error message, uninstall and reinstall the program. (that's another story on its own). is there anything I can do to take preventative measures or any fixes I can attempt?Sully3 17h
17h Someone logged into my account error During HL draft several minutes ago I got this error. I checked my email and there was no suspicious activity email received. However, there was a troll banner on the team. I was trying to talk some sense into him, but he remained quiet. He didn't do a second troll ban and didn't ban the 2nd time. During this time it may have been possible he used some kind of method to kick me from the draft. Is it possible somebody in game has a hack or exploit to disconnect you during draft if he has access to your battle.net name/profile? Lost a huge amount of rank points from this incident. Changed my password just in case, but my password is very unique so I doubt that was the problem. Now I have to participate in leaver games.Veganazi0 17h
17h 27.1 Patch Introduced 500ms Ping Spiking I was playing HotS yesterday morning on 27.0 absolutely flawlessly. I get 12ms latency to US Central and the game plays smooth as butter. I went to a few work meetings, came back, patched to 27.1, and the game is absolutely completely unplayable on my same PC, due to 500ms incessant ping spiking in the game. Nothing - absolutely nothing, not even a Windows update or defender definition - changed on this computer with the exception of the 27.1 patch. This is the second patch since 2.0 that Blizzard has shipped that has rendered the game I've given Blizzard hundreds of dollars for completely unplayable and to be blunt, is infuriating how often there are latency issues _only_ with this game. U.S. Central has the same inbound IP for SC2 and Overwatch as well, and both of those games play at 12-15ms constantly and solidly for hours without a single hiccup. Only Heroes has an issue. I have: Ran windows update Updated my network card drivers Reset the in-game options Deleted the "versions" folder Re-installed HotS My PC is a 4790k at 4.8ghz with a 1080ti and Fiber Internet. I play with all the optimizations (CPU stuff off, reverb off, sound low) and 100% will guarantee it's not my PC or my network. I've posted the same issue a patch after 2.0 dropped, which was miraculously resolved exclusively via a patch despite insistence it was my network. Blizzard, there are multiple other posts about this. Like last time, I'm willing to do anything besides copying and pasting winmtr, being told it's my network when any game by any vendor including your own plays fine except for this one title, and then having it fixed later. This forum-based system is super ineffective. Let your users help you via other means, please.false23 17h
17h Lost My Twitch prime Lootcrate I logged into HoTS to open my free amazon prime Lootcrate and a windows security window popped up in the background I tabbed over to it okayed the security and my mouse was able to freely navigate the UI in HoTS however my graphics got blown-up to a different resolution I placed my courser over the settings button and it highlighted I clicked on the lootcrate floating box's "x" and it responded so I closed out of HoTS and restarted my PC to fix the resolution and when I logged back in to the game my twitch prime rewards window has not shown up since and I haven't claimed any rewards on my account and I haven't received an email that are linked to my prime and battle.net about having receiving any exclusive items yet.Gotcha2 17h
19h 200+ ping on SOME matches from start to finish Seriously, it's been like this for many months now and until now I've been HOPING it fixes itself after the recent patches. It didn't. And since Blizzard expects us to rely on other fellow (mostly) clueless players to fix our problems and doesn't allow support tickets anymore, here I am. So...anyone else experiencing this? It's like a gamble every game: am I gonna get the "lag" or not? It's exasperating. It tried speedtesting whilst in-game when I get the "lag" and there's nothing out of the ordinary. And yes I already tried dns flushing and all the other !@#$e listed before posting here. Pls halp it's killing my will to play. PS: my normal ping is around 80-100.MotherPig20 19h
20h Blizzard Error - Unable to install I'm currently unable to install Hero's of the Storm on my mac. Every time I try to I get a blizzard error that doesn't give me an error code. It just says, "The application encountered an unexpected error." It then says "to help identify a problem, describe what I was doing" but I can't type anything in there. I've deleted every battlenet file and blizzard game from my mac and I'm still getting that. Any ideas why that's happening?GarryOwen830 20h
21h Fix your servers please... Could you please finally do something about this constant lagging and reconnecting? Today I wanted to play ranked, but in about half of the game I lost connection and saw only reconnecting screen. Before you ask, my internet connection is fine. What I don't understand the most is when someone from my team could whisper me "You useless piece of !@#$" and "Reported". How come I can't connect to my game but see these offences when I can litteraly do nothing about this disconnection? I tried to wait, but then I was dropped, and could do even less. Only exit the game. Of course there was a warning, that if I leave too many games, there will be some penalties. So seriously tell me, what the hell can I do with this? And I'm not the only one who has problems with lagging and constat recconecting...aeliren0 21h
21h Replays When you go back to rewatch something the game crashes. I feel like this bug has been in for over a year. Will the replay system or reconnect system for that matter ever be addressed? Both are atrocious.Herolisk0 21h
21h Lag with 2 people playing on the same network If my roommate and I play heroes at the same time we both lag. This does not happen in any other games that we play. We are both LAN connected and we have a very good internet connection. Does anyone else have this problem?Molv0 21h
22h crash unspect ocure let me out and 2 games penalty.Why,is not my fault.please repair this.thx today 20 aug 2017 at 18 57Albert1 22h
22h crash unspect occure take 2 games from my carrirer. Why? is not my fault.today 20 aug 2017 at 18 57.please repair this.Albert0 22h
23h Desync! I was playing TL in a team of 3, we were winning and suddently all three of us got Desync notification and i was the only one not to get back to the game. I tried to get back in game several times but it didin't help. Friends told me that we won the game, so i left the game and went to see if i got a victory too. Guess what, game was marked as a defeat and i lost my points and got 2 game leaver penalty. This really sucks and i hope you can resolve this issue so that i would get my points and get rid of that penalty.Finnmaniac0 23h
1d Weird Stuttering Lag? My game feels very clunky and stuttery even though my pings is <20 and my fps hitting the 120. I don't understand what causes it, but most other games I play do not suffer from this issue (e.g. League Of Legends I have everything on ultra and it runs smooth). Is it something with my Nvidea drivers? They usually have a lot of settings available and maybe that is causing it? Any help is appreciated! Thanks!Dainank129 1d
1d Random CTDs Hi, My computer randomly crashes to desktop almost every game with different error codes. This is the latest one: DB8F51E4-2965-44FD-A52D-C878DAADE5E5 This has been an issue for a couple of weeks now. I even did a clean install of win10 yesterday, but it persists. I can post specs if requested. I would also like to suggest not to penalize players that didn't disconnect of their own accord. I must have been penalized 5 times or so this past month for leaving games I didn't intend to leave, it's getting ridiculous. Cheers and thanks in advance :)Papapow0 1d
1d Extremely long queue times I am getting consistently long queue times for Hero League. It is always around 10 minutes to get into a game, no matter what time of the day it is. What's up with that?XPEHBAM2 1d
1d Account reset Hi all, I recently had to uninstall and reinstall heroes to get to install the last patch. It kept failing to install. After getting it running again, I found that I had reset to lvl1 and lost all the characters I had unlocked. Anyone have any ideas on what to, as i can't seem to contact blizzard about this, it just directs me to here.buddahak2 1d
1d How to Open a Ticket How do I Open a Ticket, for help from Tech at Blizzard. ThanksLightStorm0 1d
1d Hero League Draft Crash Hi Blizzard! I entered a draft for hero league, then i noticed draft chat is not responding after which the game showed some prepicks, but then everything stopped respponding. The ban countdown went to 0, stayed there, after some time the game lobby kicked me and immediately opened a next draft on the same map (dragon shire) without restoring me to game selection. This second draft displayed 'waiting for other players' (that usual message when loading), but did nothing else, i could not pick, chat etc. After some time i got pushed from it, the game subtracted an equivalent of 2 games of rank points and i received leaver status. Any solutions for future reference? I guess i cannot regain the points lost due to this glitch. Should i close HOTS after this crash occurs? This happened to me once before and after alt-f4 i lost rank points as well. Respectfully, Remain IndoorsRemainIndoor9 1d
1d Black Battleground No matter what game i load into the battle ground is always black i can see my minimap, hero port, and healthbars but every thing else is all black My specs: GTX 970, Corsair 16 Gigs of ram, intel I7, 1920 x 1080 60HzCrass0 1d
1d Monitor loses signal at startup Hi Tech Support, Both my monitors are losing signal and cannot display anything after the authenticating screen upon starting up the game. This did not happen until today. What could be causing this issue? I just updated the graphics drivers because I thought the old drivers were causing this issue but the issue still persists. ThanksAoedin0 1d
1d Dissconnected 3 times during draft I was playing HL and everything went fine till it was my turn to pick a hero the countdown just froze at 0 and i was dissconnected loosing points and getting leaver status. Happened 2 times in row, after 2 times i was already demoted from plat 2 almost promo to plat 3, then i tried again 1 game went fine and after that game it happened againCheese0 1d
1d FPS Hello. So, I started playing this game yesterday and I was just so happy that I had such a good performance (70-90 fps constantly) with things like chrome opened, but today I played a match and I had between 30-50 fps even by closing the stuff that yesterday were opened while playing. Any idea how this happened and how I'm able to play on the same fps again? If it matters, yesterday I played the tutorials before the full download was completed and then one Versus AI once it was completed. The options too were the same as today. And today again I played Versus AI but there was just this big difference in performance that makes it annoying. Thank youZess1 1d
1d Major latency spikes while playing HotS. I recently moved and got a new ISP. Now, when playing HotS, I consistently experience recurring periods of major latency spikes throughout the game. Speedtest.net reports ping of 15. Here's my traceroute and pathping: Tracing route to 24.105.30.129 over a maximum of 30 hops 1 8 ms 8 ms 9 ms 192.168.0.1 2 18 ms 29 ms 29 ms 10.57.64.1 3 24 ms 30 ms 40 ms 10.200.1.21 4 27 ms 29 ms 19 ms hostpool3-62.miracopa.orbitelcom.com [216.9.177.62] 5 17 ms 30 ms 29 ms 208-95-94-253.gilanet.net [208.95.94.253] 6 1042 ms 45 ms 20 ms 6-2-11.bear2.Phoenix1.Level3.net [4.28.83.101] 7 39 ms 39 ms 39 ms 4.69.153.121 8 37 ms 36 ms 32 ms BLIZZARD-EN.edge2.LosAngeles9.Level3.net [4.53.230.238] 9 1033 ms 40 ms 30 ms 37.244.0.35 10 36 ms 39 ms 49 ms 37.244.0.103 11 35 ms 46 ms 39 ms 24.105.30.129 Trace complete. Tracing route to 24.105.30.129 over a maximum of 30 hops 0 DESKTOP-QK0G2LJ [192.168.0.10] 1 192.168.0.1 2 10.57.64.1 3 10.200.1.21 4 hostpool3-62.miracopa.orbitelcom.com [216.9.177.62] 5 208-95-94-253.gilanet.net [208.95.94.253] 6 6-2-11.bear2.Phoenix1.Level3.net [4.28.83.101] 7 4.69.153.121 8 BLIZZARD-EN.edge2.LosAngeles9.Level3.net [4.53.230.238] 9 37.244.0.35 10 37.244.0.103 11 24.105.30.129 Computing statistics for 275 seconds...Khras3 1d
1d CRASHING ALMOST EVERY MATCH NOW CRASHING AT THE END OF MY MATCH FN UP MY XP AND EVERYTHING GETTING FN RIDICULOUSIron1 1d