very high latency

Mac Support
I have a macbook pro, the latency 3/4 of the time is unplayable. I have the latest osx update. It may have something to do with the router, it is a new router, Dlink 2760U.
Please advise.
Thanks
Carmel, if you bypass the router and directly wire into the modem, does the issue go away?
______________________________
Technical Support: Sunday-Thursday, 12pm - 9pm Pacific Time
How am I doing? || Support Agent Feedback ||
It is a router and a modem (Dlink 2706) I don't know if it is possible and how to do it, furthermore, it is a macbook pro, it doesn't have a dsl cable connection slot, I use wifi to play the game.
Carmel, can you tell me a bit more about the Macbook?

    1. Click on the Apple Menu while holding down the Option key and select System Profiler (10.6.8) / System Information (10.7 and later).
    2. Copy the information from the following sections and paste them into your post. Please copy in the following order: Hardware Overview, Graphics, and Software. Do not include any serial numbers, hardware UUIDs, or account/login names or information in your post.


Additionally, do you have other computers on the network? Are they able to run Heroes without issue, or do they suffer the same latency issues?
______________________________
Technical Support: Sunday-Thursday, 12pm - 9pm Pacific Time
How am I doing? || Support Agent Feedback ||
Currently I don't have other computers, but I will probably get a pc soon.
Btw, while playing and having a bad latency, I've run an internet speed test, and the ping was fine , 15ms.
This is the info you've requested:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP101.00EE.B05
SMC Version (system): 2.3f32

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Displays:
Color LCD:
Display Type: Retina LCD
Resolution: 2880 x 1800 Retina
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: OS X 10.10.1 (14B25)
Kernel Version: Darwin 14.0.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
Time since boot: 5 days 2:52
If you lower your settings in-game (Texture, Graphics, and/or both) do you notice any measurable improvement? We currently have an issue with multi-GPU systems where texture quality will severely degrade video performance, which can simulate as network spikes.
______________________________
Technical Support: Sunday-Thursday, 12pm - 9pm Pacific Time
How am I doing? || Support Agent Feedback ||
Hello I am currently having similar issues more often only when playing on sky temple. Game runs smooths during older maps but since the release of sky temeple game lags when there are more the 3 hero on my screen and gives a good 2-4 second frame rate pause causing whole fight to be over and me dead. have not won any sky temple games due to this please help with the game. i have don't the following.

lowered game settings,
higher game settings
direct router wire
wireless
straight into modem

i do not have any issues with other games such as diablo, LOL or even this game on other levels as bad. Temple storm is unplayable for me

I am currently using the Latest IMAC 5k, with 32gb ram and best graphic card capable i usually run game on ultra settings other levels and have no issue at all. please fix this issue for me or make it so sky temple is not in ranked 5/6 times lol!
Tried lowering the settings, didn't help. I have the icon on the top left corner saying I have latency issues. I do experience it in other maps as well.

Join the Conversation

Return to Forum