Cant download additional content in game.

Technical Support
I am having a strange issue. When I click play ingame it shows a download status bar near the top right corner. After 2-5 secs it stops and says connection to battle.net lost and gets cancelled.

When I try to access my internet after this issue, for some reason I cant open any site. Not sure what is the problem. Would love if someone can shed some light on this.

PS: It might be better to keep all downloading on the blizzard client so that we dont have to download additional content ingame.
Experiencing the same issue here, started yesterday and still can't play because of that bug. Up.
Experiencing same issue here at the moment.
I already had this issue on april fool's day (while downloading big heads I guess) and the day after (to remove them).
Restarting the launcher and the game over and over again allowed me to finally complete the additional in-game download.

Since I don't have a high speed connection, it took hours with this process for the download to finish.
Restore default settings for HoTS in battle.net app (Battle.net logo in top left corner -> Settings -> Game Settings -> Restore in game settings) then ask a friend to invite you in a party with a different game mode than you have currently active, if game hungs up with 100% processor load when pressing play in main menu.

If that doesn't help you can also try reinstalling the game, deleting cache folder in C:\ProgramData\Blizzard Entertainment\Battle.net and/or deleting Variables.txt file in C:\Users\{Your_username}\Documents\Heroes of the Storm folder. Sometimes launching battle.net client from administrator also helps. That's about all most common steps to fight with bugs I managed to find.

That is what worked for me at least.
Wish you luck.
Hello, thanks for your reply Tiger.

First of all, I'd like to apologize whether my wording is confusing but english is not my native language.

Last time I managed to complete the download by retarting the game over and over again.

Today I met the same issue again and tried to delete my battle.net cache. The download only crashed after the download was half completed.
So I decided to install a network analyser (Wireshark) to figure out what happens.

The result is I get a lot of duplicate ACK and "spurious retransmission" which means - if I properly understood this link: https://blog.packet-foo.com/2013/06/spurious-retransmissions/ - that the sender (Battle.net server) never receives my ACK and sends over and over again the same packets.
So I guess my connection must be really bad since it ends up by the sender closing the connection (RST).

At this point, I have no idea how to configure my OS/Battle.net launcher/Heroes of the Storm .exe so that the Battle.net server is aware of my poor bandwidth.
Hey Sheratan, are you connecting through a router? If you are, would you be able to connect straight to the modem, as a test?

Also, are you wired or wireless?
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

"They say the oaks are just too lofty
And they grab up all the light."
Hi Velnrak, my PC is wired to my internet box.

I had a look to the web admin interface and my internet access provider forums and there is no way to disable the router feature on the box.

So, instead I tried to disable the DHCP and set my PC IP with a DMZ I have defined on the box in order that all internet traffic to be routed to my PC but I keep getting the same behavior.

Then I disabled my wired network interface and try to connect to internet using my phone as an access point through wifi but the signal was too poor to even authenticate on Battle.net.

Since I can't get rid off either the router nor the firewall features on my internet box, is there any configuration (like allowing a range in firewall) worth trying?

Join the Conversation

Return to Forum