Patch 28.3 stuck on Finalizing...

Technical Support
I left the Battle.net client open by hours but the patch 28.3 installation is stuck on "Finalizing..."

I tried closing the Battle.net client, and reopen it. Also, I tried "Scan and Repair". The installation status remained as "Finalizing..."

I can play because it is already on "Optimal" status.

It just bugs me that the installation never ends. :)
Okay, so it's not just me then. I even tried deleting the cache to see if it worked and it didn't. It stays stuck on "Finalizing" for me as well.
Same here
Yup, same here.
Same here. Stuck on "Finalizing..."
Try reinstalling.
mine's stuck too
yeah same
Add me to the list. It has been stuck at the end ever since it started pre-downloading last week.

And I don't know if it is related but the game has been crashing a ton ever since that started as well.
Same here, stuck on finalizing even after restarting Battle.net, logging on to a different account, etc.
Same issue here
Same here.
It is also stuck on 'Finalizing' for me too on Win 7 Ultimate x64.

I also had this earlier on PTR client but there it finalized after pausing and resuming the update once or twice. Same trick seemingly does not help regarding live version.

--
Edit: ran 'Scan and Repair'. After it finished it continued patching. This time patching stuck on Finalizing too. Game is still playable.
Is there any fix for this?
Yea it is doing it here too.
same here
Same here, but, then i tried to scan and repair, it got stuck. So i closed and reopened client, and then the button only says " update" when i clicked it, it says that something is broken and can't update.

Right now im reinstalling, hope it works.

:/
i will note that although it is stuck i can still play
* stuck on finalizing
* did have the pending background download for a few days prior
* game launches and plays
* beta blizzard client

Windows 10 x64

Deleting C:\ProgramData~ did not resolve
Restarting client and OS did not resolve

Throwing my notes in the ring as well just in case.
Hi there friends!

It looks like there may be two issues going on in this thread.

First, the app is stuck in Optimal and Finalizing, but you can press the Play button. This is a problem we are looking in to and hope will be resolved soon.

The second is some of you are unable to click Play, if this is the case starting with clearing the app cache then scan and repair may help.

If you are in the latter group, please post back here saying that these steps did not help, or if you find a workaround, please post it here.

/Nathardrick

Join the Conversation

Return to Forum