Quest TAKING BACK THE TOWN bugged

Bug Report
My "Taking back the town" quest is bugged for me, I cannot get it completed no matter which mode (QM/HL etc) i am playing and win ofcourse
I'm having the same problem, I have tried to do this in multiple game modes and I can't get credit for the quest. Sky Temple, Hanamura and Cursed Hollow doesn't seem to matter if I start the game search selected on it or switch quests mid draft.
i got the same problem, i got stuck at 2 tower
I got 3 towers in a WINNING game and it never counted it, it was on cursed hollows which is apparently the right map as well.... god damn friggin infuriating - fix it BLIZZARD!!!

Whoever invented this quest can rot, and whoever let the bug through testing can equally rot!
Happening to me too.
I assume this is the watchtower quest? Just making sure everybody knows that that is the vision "watchtowers"
Was about to post this same issue. "Watch Towers" (map text) ≠ "Watchtowers" (event quest text). The only things that has counted for me are the new vision camps on Hanamura. But you have to get that map, and the camp has to be claimed in your name, and you have to win -- RNG³.
GLad I am not the ONLY ONE :) I was expecting a Blizzard response until now to be honest but alas...
i tried to complete the quest on cursed hollow. i captured 6 watchtowers and won but i got no quest progress
also happened to me-the quest "50K basic attack damage" is bugged
Just an update, i ve got it completed on a HL Cursed Hollow game where i was chasing to cap watch towers alone after several attempts/wins (qm/hl/unranked) . Dont know if that matters. Still no blizzard response
Mine's bugged too. Stuck at 2/4 despite wins/caps on Sky Temple and Cursed Hollow.
I've completed this 3 times now and never got credit. I lucked out and got Cursed Hallow 2x in a row, but that didn't seem to matter.

Things I've tried that didn't work:
    restarted the game

    Switched missions and came back to it

    Sacrificed a chicken


Is it just bugged? I've seen some weirdness in other missions (like take 3 merc camps in a match, not having them show. Then taking 1 in the following match and having 4 completed). They eventually just resolved themselves, but this one isn't.
Having same issue, got 4 watchtowers on sky temple, counted them outloud with my discord, was alone on them when i captured, won the game, and have no progress toward goal. plz do the fixings

Join the Conversation

Return to Forum