Fixing the lag spikes

Technical Support
So I promised myself I would share when I fixed the lag spikes.

First, read this and port forward the windows firewall.
https://us.battle.net/support/en/article/300479

Second, if you're not familiar with how to port forward your wireless router, go to the link below.
http://portforward.com/english/routers/port_forwarding/
you posted on my thread earlier!

This truly fixes it? Characters no longer lag for 1 second and then show up somewhere else the next?
05/24/2016 11:15 AMPosted by Araplay
you posted on my thread earlier!

This truly fixes it? Characters no longer lag for 1 second and then show up somewhere else the next?


Fixed it for me.
05/24/2016 11:15 AMPosted by Araplay
you posted on my thread earlier!

This truly fixes it? Characters no longer lag for 1 second and then show up somewhere else the next?


Fixed it for me.
bump because I see a lot of people having this issue.
Doesn't work
FYI...I am on a straight modem and I get the lag. My frame rate while playing with people sometimes drops to 8 or 9 fps. Only way to fix is to quit out and come back in again. It really messes up your game.

Also if it has something to do with the firewall. Blizz can put (fix) that in a patch.
Worked for me. Thanks so much for sharing this, ping immediately dropped from 200ms to below 50ms
Didn't work for me.
The port forwarding didn't work for me.

But, I'm running Overwatch on an ASUS laptop with ROG Gaming Center, and I disabled the Game First III network enhancer.

The next multiplayer matches I played in worked just fine!!
05/24/2016 07:28 PMPosted by Kian
Worked for me. Thanks so much for sharing this, ping immediately dropped from 200ms to below 50ms


Glad I could help. This fix won't work for everyone, but it def worked for me. You def need to open the ports on your router correctly.
05/24/2016 07:05 PMPosted by Glasseye67
FYI...I am on a straight modem and I get the lag. My frame rate while playing with people sometimes drops to 8 or 9 fps. Only way to fix is to quit out and come back in again. It really messes up your game.

Also if it has something to do with the firewall. Blizz can put (fix) that in a patch.


Sounds like you're having hardware issues.
Just an update.

The firewall Blizzard listed here at the top did not work for me. I still drop my fps to 8 or 9 randomly.
i have this problem and its so bad the game is 100% unplayable
Well I believe that this certainly helped. I allowed both of the ports listed for wow, overwatch, and diablo and my lag spikes have reduced in frequency according to my task manager. However they still occur and are just as severe - there is another cause which is distracting from the solution.
The port forwarding as described here did not help the problem but disabling the QoS service of my modem did the trick. I still get the "lightning bolt" connection icon periodically, but I have not had the packet loss icon appear nor had the strange 2-3 second freeze-ups occur since.

Here is the thread in which I found the reference to a possible known issue with QoS settings: http://eu.battle.net/forums/en/overwatch/topic/17611601594#post-9

QoS settings will differ with your router, but with my Ubee router from Time Warner, I went into the settings menu and did Wireless > Multimedia > turn WMM "Off"
06/05/2016 11:08 AMPosted by Remember
The port forwarding as described here did not help the problem but disabling the QoS service of my modem did the trick. I still get the "lightning bolt" connection icon periodically, but I have not had the packet loss icon appear nor had the strange 2-3 second freeze-ups occur since.

Here is the thread in which I found the reference to a possible known issue with QoS settings: http://eu.battle.net/forums/en/overwatch/topic/17611601594#post-9

QoS settings will differ with your router, but with my Ubee router from Time Warner, I went into the settings menu and did Wireless > Multimedia > turn WMM "Off"


Can you send us your step-by-step direction? that'll be really cool :D
Turning WMM off will stop prioritize youtube over the game traffic , in your home.

Most spike lag are due to other programs that suddenly want to update, because auto update is trending (windows, java, chrome, some steam stuff, battle.net launcher).

Nevertheless Overwatch should mark the traffic with <low latency> QOS class on the server and on the client, and then we ll just have to hope internets router do the job correctly.

Maybe they did it , i did not check.
05/24/2016 08:43 PMPosted by Araplay
The port forwarding didn't work for me.

But, I'm running Overwatch on an ASUS laptop with ROG Gaming Center, and I disabled the Game First III network enhancer.

The next multiplayer matches I played in worked just fine!!

I'm using the same type of laptop, how do you disable it?
The thing that ended up working for me was switching from wireless connectivity to wired- didn't seem to speed up my internet, so I can't say I know why it worked, but maybe it will for others as well. :p

Join the Conversation

Return to Forum