Still have voice chat problems!

Bug Report
Prev 1 11 12 13 20 Next
05/25/2016 11:24 AMPosted by Araxom
Hi all, thanks for hanging in there. We're continuing to investigate this and it'll be helpful for us to have the following information from you:
  • Are your settings currently the default settings? (If you are unsure, you can access the Options menu from the main menu > Controls pane > select Restore Defaults from the bottom of the screen.)
  • Are you seeing a 'Joining channel' message in chat?
  • Do you hear a 'chirp' when you press the PTT (Press-to-talk) key? (Default: ` - generally to the left of your number 1, above the alpha keys)
  • Do you see your own name in the upper-left corner of the screen when you speak?

Much appreciated!


Just to give it another bump, I'll chip in and say I have similar issues here. Beta, voice communications worked near the end, but now it's on a permanent mute, unable to unmute.
I have restored defaults a couple of times and everything.

I think it's worth noting that I'm playing from the UAE. I don't know why, but most of the matches I've played, people farther away from EU seemed to have this issue more prominently.

Good luck. ♥
*bump*

Interestingly our problem is not even listed under 'Known Bugs'.
If there's no blue post until tomorrow we should open up a new thread. Maybe we'll get some new attention that way.
There are already several threads about this and still nothing to fix it. :(
I've tried about everything too and I think I'll just give up to be honest.
Considering the problem has been around for months already apparently.

I've never been able to see I joined a voice channel at all. It just can't connect for some reason. It works fine in any other game and on programs such as skype etc. It's not blocked in my country either, since it works for other people here. I have no idea..
I was having a lot of voice chat issues, part of the reason was the confusion on which chat lobby to join or which I was actually in.

The bigger problem, is that every time I log on the settings for default microphone is set on default communications device. Which is fine, except when you hover over it, it says "no device". This is fixed when i simply scroll through the other options, land back on "default communication device", my mic now appears under the device listing. Super simple work around, but an annoying glitch to say the least.

So for those having issues, this might be worth a try, as it now works for me.(I do have to adjust it every log on though).
Same here. Logitech G35, mic works for a while after launch then nada. Use it in every other game i play without issue.
Hi guys, i have it for ps4 and same problem, never has worked since launch, my toggle mic will not toggle ever!
The mute button while in game in the overwatch menu has a check mark next to mute all the time and no way to remove it.
I opened a ticket and follow all these instructions - In the Overwatch Options menu, go to the Sound tab.
- Change the voice chat from push to talk to open mic.
--> See if your mic works now. See if you can click on it to mute/unmute it.
- Change the voice chat back from open mic to push to talk.
--> See if it works normally now.

2. Check to ensure the latest software for your audio device has been installed. There are several Logitech headsets, for example, that won't work in Overwatch on older drivers. The most current software for your audio device can typically be found on the website of the manufacturer of the device.

3. Verify that the ports needed for Overwatch and for voice are open. A complete list is available below:

Ports 1119, 3724, 6113 - TCP - for Overwatch
Ports 26503-36503 and 3724 - UDP - for Overwatch
Ports 6052, 5062 and 5060 - UDP - for voice control signals
Ports 12000-32000 - UDP - for voice media
Ports 80 and 443 - TCP - for Web server
Ports 3478 and 3479 - UDP - to aid in setting up voice

We have instructions for configuring these ports here: (https://us.battle.net/support/en/article/300479). Just select your Windows OS version from the drop-down. Please note that Blizzard does not directly support proxies, firewalls, or routers. For assistance configuring your router or firewall, please contact your ISP or hardware manufacturer.

4. Disable any firewall(s) (if present) entirely.

5. Check to make sure the router has the latest firmware installed.

6. Use Google DNS: (https://developers.google.com/speed/public-dns/docs/using)

7. Consider testing with a VPN (virtual proxy network). While this is not something we can directly support, this may be a helpful troubleshooting step.

They closed the ticket with the status resolved??

Wish a real person could help not a pre-set response.

This has to be a game issue as all my party chat and other ingame chats work fine.
Have the same issues too! Haven't been able to use my mic at all since I started playing. The voice chat thing pops up on the lower left. It always says 0/(players in chat). Can't hear anyone either. But chatting with others works fine. And my mic works fine with all other voice applications too.
My voice comms worked fine since release but yesterday suddenly my mic got muted in game and couldn't unmute it, also I cant change the mic volume in sound options since its "greyed out". I can hear everyone else in the team chat but I just can't talk. I can even hear the push to talk "tsirp" sound. My mic works fine in every other game and voip program(ts3, skype etc) so the problem has to be game related. Its also weird that it just suddenly happened without any patches or me changing hardware. Tried everything and nothing works. Blizzard pls look into this.
I have the same issue too.

I can see the green text that I have joined the channel. When I get in the party chat my first glance shows my microphone available to use. However, the first click automatically turns my mic symbol on mute. I do hear the chirp when I press the talk key. No one can hear me speak.

I have tried all the suggestions that have been listed here but none have worked. This is extremely frustration. especially when running challenge modes. No one seems to believe me when I say my voice chat is bugged.
My issue is that PTT does not show my name in upper left corner for anywhere from 1 to 10 seconds after pushing it (and holding it down). I do not hear a chime either, and I have no clue if my teammates are hearing me.

Everything else seems normal -- join channel text, hearing other people, etc. The only thing I've changed since when I last know that it worked is the PTT keybinding.
I've found a solution for the sound and mic problem that might help you.

Go to battle.net, Account Settings > Settings > Parental Controls > Manage Parental Controls > Make sure that the Voice Chat is on Listen and Speak

Have a great day :)
@emyziacsgo
08/01/2016 02:47 PMPosted by Emyzia
I've found a solution for the sound and mic problem that might help you.

Go to battle.net, Account Settings > Settings > Parental Controls > Manage Parental Controls > Make sure that the Voice Chat is on Listen and Speak

Have a great day :)
@emyziacsgo


This has probably done by other in this thread. I did this and nothing happened.
Been searching for a solution for months for this and I still can't find anything. It seems like blizzard has abandoned this thread, but in case they haven't I would like to throw my name on the pile. Also this is not a port issue for me, I'm tired of all the tickets I submit coming back with that same answer.
Yup, still an issue. Pressing PTT button results in audio cue (that is almost too quiet for me to hear), but 9 out of 10 times does not have the accompanying visual cue. Switching to open mic appears to fix things in that the visual cue is continuously present, but that is not an acceptable solution to me.
I have a similar issue. Audio cuts in and out and my voice chat doesn't work at all as far as i can tell

*restored to default but it didn't help
*hear chirp
*no name in top corner
*not seeing "joined chat channel" when i start a game.

Worked great up until the patch before the Ana release. Then nothing. No changes to my system and no problems outside of overwatch.
Doesnt work on PS4 at all for me or any of my friends. Please release a hotfix
This should be a sticky...

99% of the time this is the reason why you guys are having problems. (I've told this to so many people and they had a eureka moment.) It's because the interface isn't intuitive to everyone's brain. Not all of our brains would've checked Auto Join, or checked only one Auto Join, or etcetera.

1) Check to see that you have changed team chat from ON to AUTO JOIN. And turn set Group to ON, not AUTO JOIN. (See #2 for reasons.)

https://s32.postimg.org/o17pi805h/select_auto_join.png

If you don't do that, then you won't join the channel and thus not do anything. The ON means that you have team channel enabled. It doesn't literally put you in the channel. (Or maybe it's a bug?)

Okay now you're in the channel. Now you want to talk. But somehow you can't.

2) If you have both Group chat and Team chat set to auto join, I believe it will pick group first. Therefore click the headphone icon next to Team chat to make sure it has a filled circle. This indicates you want to talk in Team.

https://s31.postimg.org/ymx0nitt7/change_icon.png

See this confusing information for details:

https://us.battle.net/support/en/article/7635

3) Thirdly don't mute yourself in the team. (You can mute yourself by clicking the Speaker icon, by pressing your Toggle Mute Mic key, or by switching to a different channel).
my voice chat finally is fixed I got it from this step in League of legend
and I got this link from this forum

http://us.battle.net/forums/en/overwatch/topic/20744354389?page=26

https://support.riotgames.com/hc/en-us/articles/201761944#wq7

after I changed the SSL into TLS I can connect to voice chat
hey guys i finally managed to fix my problem......Make sure u go to sound and turn group voice chat to just "ON" and team voice chat to "Auto Join."

Join the Conversation

Return to Forum