Update stuck at 0 B/s

Technical Support
Prev 1 6 7 8
I'm having the same problem but it doesn't seem to be an Overwatch-exclusive issue, other games on my computer consistently get stuck, and if I completely restart the download it goes back up then continues a few mb at a time, then gets stuck again.
My best guess is (for those with this same issue) somehow updates are getting stuck on RAM before being written to the main drive. I have no idea how to fix it, but that's just my best guess on what it is.
i have 150 mpb/s download im trying to reinstall overwatch on a new PC (has a perfect write speed not the issue) But it gets stuck at 0 and never downloads at all... let it go for a few hours still no luck, I've done everything listed in the forum and nothing seems to work :x
07/24/2016 06:20 AMPosted by ActualDuck
I have the solution folks! Yes sir, free of charge (looking at you name change fees -.-).

If you click the little cog symbol for option in the bottom right (or press on the blizzard app symbol then setting in the upper left) then go to "Game Install/Update" scroll down until you see Network Bandwidth. Regardless of what you have it set to, change the numbers and hit done. You generally want these high if you have decent internet. This will get it unstuck.

From what I've seen, it is defaulting those numbers to 1 kbps causing it to look like it is freezing. It acts this way even though sometimes it has numbers you may have saved in there before. No firewall changes necessary.
thanks man it worked; +rep
I had the same Problem. Try to check if you´re Proxy Server might be down or something and just reinstall Blizzard App. I did both.
At first i couldnt reinstall the Blizzard App. There was just no progress. Then i removed my Proxy Server and everything worked fine. I hope i helped someone with that. By the way, i am using wireless internet connection.
07/24/2016 06:20 AMPosted by ActualDuck
I have the solution folks! Yes sir, free of charge (looking at you name change fees -.-).

If you click the little cog symbol for option in the bottom right (or press on the blizzard app symbol then setting in the upper left) then go to "Game Install/Update" scroll down until you see Network Bandwidth. Regardless of what you have it set to, change the numbers and hit done. You generally want these high if you have decent internet. This will get it unstuck.

From what I've seen, it is defaulting those numbers to 1 kbps causing it to look like it is freezing. It acts this way even though sometimes it has numbers you may have saved in there before. No firewall changes necessary.


This one definitely worked for me. For the ones who couldn't see any results after doing this, try a VPN app like TunnelBear or hide.me then open the Blizzard app. Recheck if the download speeds are okay, then start download.
having this issue, I have tried every fix in this forum but no luck. imso close to the end of the download, less than a GB left but it just wont patch the last 500 kb. It just j\keeps says 0kb/s and then giving me the error message. I know its not my connection because everything is working perfectly and I have a 90mb/s download speed. there is no reason it should be acting this way.
BTW once clearing your cache folder your download limits maybe reset, mine was reset to 20kb/s just remove that and place a 0, also the 0 B/s is just a visual glitch just leave it for a while and it should start updating. Using WIFI if that helps with anything
This just happened to me but i think its a UI error, after a few minutes it just instantly went to finished after being 5 mb in.
https://us.battle.net/forums/en/bnet/topic/20748815398#1

Follow the steps on this page and you got yourself a solution!!
07/27/2017 07:23 PMPosted by SUNDER
07/24/2016 06:20 AMPosted by ActualDuck
I have the solution folks! Yes sir, free of charge (looking at you name change fees -.-).

If you click the little cog symbol for option in the bottom right (or press on the blizzard app symbol then setting in the upper left) then go to "Game Install/Update" scroll down until you see Network Bandwidth. Regardless of what you have it set to, change the numbers and hit done. You generally want these high if you have decent internet. This will get it unstuck.

From what I've seen, it is defaulting those numbers to 1 kbps causing it to look like it is freezing. It acts this way even though sometimes it has numbers you may have saved in there before. No firewall changes necessary.
thanks man it worked; +rep
Same issue (now months later).. but the solution worked... just set the bandwidth limit to something.

Blizzard Support... easy now that you know where the issue is.

Thanks for the post
I have tried everything in every board. I am having every problem with the battle.net app. It started the second I clicked on the button for the "free Starcraft 2: Heart of the Swarm for players who own Wings of Liberty". Everything was running perfectly fine before. Now it won't stay connected, it says that its waiting on another download, it says 0b/s. None of the troubleshooting is doing anything.
I have uninstalled/reinstalled everything. I have deleted the "blizzard entertainment" folder. I have the download speed set. I am running in administrator mode. Everything is cleared through firewall. Computer is connected. Cache is cleared.
This is why games need to go back to simple offline solo campaigns. This is bullshiiz
it's a UI error from the bnet client. It happens to me all the time with WoW patches... The patch starts downloading and the UI tells you it stops at X amount of data left when in reality it is still downloading. Just leave it there for a good while and see if it finishes patching or if there is a extra problem.
hey I found a fix if you have a graphics card go and update your drivers for they can cause that.
Same problem happening after the New Luna update.
1st day the game was running fine.
Quick question to all involved...

Do you have hw game installed to the default location, or did you change it when you did? Default is "C:\Program Files (x86)".

Under Settings, select where you actually did.

Join the Conversation

Return to Forum