Performance Problems with Razer Mamba Chroma

Technical Support
Hello all!

I noticed a lot of people were reporting issues with the mouse staying connected or the chroma support not working, but this is different

When I use the Mamba, the response I get in Overwatch is reeeally jumpy if that makes sense? Like if I move the mouse slowly left to right it jumps bit by bit instead of doing so fluidly. I can use the Mamba fine with Evolve Stage 2 with the same settings, so I can only assume it's a problem with the game, somehow...

Other mouses I have used with Overwatch with no issues are the Deathadder Chroma and the special edition Overwatch Deathadder, as well as the Naga.

Any help would be appreciated!!
well the Mamba is a laser mouse and the deathadder is an optical mouse. Optical tends to be better for fps slightly but it shouldnt be this noticeable unless you are running it in wireless mode?

So before we assume its a problem with the mouse first off is it wireless? If yes does it have the same issue in wired mode? If no move dongle close to your mouse you have a connection problem.

What surface are you playing on? Try a different mouse pad or get a mouse pad if you dont have one. Some sensors dont like some surfaces and will spin out or skip because of this.

What DPI is your mouse set at? If its at default it shouldnt be the problem but if you have it cranked up try turning down the dpi to 800-2400 range and test again. The 16k dpi is a marketing BS that people will never use in real work cases.

The fact that the game works fine with out wired mice tells us its not the game at fault and its a problem with what i listed above or the mouse it self. Overwatch uses raw input.
It's wired, DPI I was at was 6000, and I don't use acceleration(of course) but it was still jittery at lower DPI (I started at 1800 and have slowly been working up to improve my response time). Changing the polling rate didn't do anything either

I use a generic wrist support mouse pad, but the problem persists when I used it directly on my desk

Like I said though the problem only existed in Overwatch, that I could see... I started playing Evolve a lot more mainly BECAUSE the problem wasn't happening in it. Unless I've just been imagining things, idk

it's all very frustrating x_x
Try using 800 dpi and 4.5 sensivite in game. 6000 is too high!
Buy a Razer Goliathus mouse pad for you.

ps: polling rate higher is better
Just for shiggles I'm gonna set it to that and see how many times I have to lift my mouse to make a full 360 degree turn

Edit: TWELVE TIMES
steel series qck are great mouse pads for thing type of thing since they are all black no designs etc. Anyways i would contact razer support and ask them for a firmware update. That might also be the problem.
08/21/2016 09:02 PMPosted by Marina
Hello all!

I noticed a lot of people were reporting issues with the mouse staying connected or the chroma support not working, but this is different

When I use the Mamba, the response I get in Overwatch is reeeally jumpy if that makes sense? Like if I move the mouse slowly left to right it jumps bit by bit instead of doing so fluidly. I can use the Mamba fine with Evolve Stage 2 with the same settings, so I can only assume it's a problem with the game, somehow...

Other mouses I have used with Overwatch with no issues are the Deathadder Chroma and the special edition Overwatch Deathadder, as well as the Naga.

Any help would be appreciated!!


On a tangent, does the Overwatch Chroma effect work in wireless mode with the Mamba or does it have to be wired?
08/22/2016 01:37 PMPosted by Aramus
08/21/2016 09:02 PMPosted by Marina
Hello all!

I noticed a lot of people were reporting issues with the mouse staying connected or the chroma support not working, but this is different

When I use the Mamba, the response I get in Overwatch is reeeally jumpy if that makes sense? Like if I move the mouse slowly left to right it jumps bit by bit instead of doing so fluidly. I can use the Mamba fine with Evolve Stage 2 with the same settings, so I can only assume it's a problem with the game, somehow...

Other mouses I have used with Overwatch with no issues are the Deathadder Chroma and the special edition Overwatch Deathadder, as well as the Naga.

Any help would be appreciated!!


On a tangent, does the Overwatch Chroma effect work in wireless mode with the Mamba or does it have to be wired?

I don't have a model that can become wireless, so I dunno, sorry
I have the exact same problem and will be buying a new mouse as soon as I can...
if you're having any problems with the Mamba chroma Wireless or TE edition one remedy that I found to work is to recalibrate the mouse to your mouse pad I did this after a while of me having issues and it fixed it immediately.
08/22/2016 05:19 AMPosted by SpaghettiMan
Try using 800 dpi and 4.5 sensivite in game. 6000 is too high!
Buy a Razer Goliathus mouse pad for you.

ps: polling rate higher is better
Higher DPI + lower in game sens makes more sense for me, takes away pixel skipping :D

Join the Conversation

Return to Forum