Game Crashes with Chrome Open, anyone else?

Technical Support
I would like to thank all the GM's that have tried to help me with this. Blizzard Support has been great in trying to help me figure out this problem.

Build on PCPartPicker
https://pcpartpicker.com/b/m3hqqs

I was told by a GM to go ahead and move this topic to the forum since we have been working on getting my game to not crash while Google Chrome is opened.

I'll have a long list of what we have attempted to do, but I think the reason for this new topic to be posted is to see if anyone else is having the same issues I am.

----The game only crashes, about 2 matches or less in, when I have Chrome opened on my second screen. I have successfully played for over and hour twice with Chrome closed.

I've only been playing for 4 days now and I couldn't figure out why the game keeps crashing. I was told to do alot of things to try and fix this. Here is a long list of what we have done. Each communications with a GM will be separated with bold text.

THE FINAL POST FROM GM. 9-12-16 0600
Thats a really interesting angle to the problem you have discovered there.
We're not aware of any specific interactions between Overwatch and Chrome, and given how many people use this browser we would likely be seeing huge amounts of issues if they'd turn out to be incompatible on some fundamental level - which (so far, at least) isn't the case.

So, all I can offer here is a bit of educated speculation. Fair warning: conjecture ahead. :)

1.) Chrome creates a set of virtual machines for its browser tabs. VMs *can* bind system resources that the game might need to tap into, so a conflict is theoretically possible (we haven't yet seen that happen tho). Your crash logs do not show evidence of this either but as Chromes VMs are self-contained they'd not necessarily show up in the first place. Means: absence of evidence isn't evidence of absence here.

2.) Your crash seems to be audio-related, so I cannot help but wonder if Chrome is accidentally blocking your audio driver in some fashion. It would certainly *access* the driver if streaming audio/video in the background, but this again is something players commonly do and don't have trouble with - and we haven't been able to reproduce the crash in this way, either. The access as such should therefore not be the problem, but it may be related.

Adding things up, I'd like you to try this:

- Open your windows Control Panel
- Change to Large Icon or Small Icon view [if not on this already, the 'view by:' should be on the top-right]
- Click on "Sound"
- Right-click on the first Playback Device and click on Properties
- Switch to the advanced tab
- Click to uncheck "Allow Applications to take exclusive control of this device."
- Click on the Apply button, then the OK button.
- Repeat this process for each Playback Device, until all of the Playback Devices with "Audio exclusive control" settings have this setting disabled.
- Back in the Sound window, click on the Recording tab.
- do the above steps to all of the devices in the Recording tab too.

9-09-16

1. There are 3 programs I see running that potentially could be interfering and causing this crash and I'd like to have you uninstall all 3 of them for the sake of troubleshooting. Those programs are raptr, plays.tv and the Eset Security anti virus. Raptr and plays.tv can usually be uninstalled through the control panel. Anti virus is not always as easy, so if you don't see it in the control panel > uninstall a program, then I suggest checking this site for an uninstaller tool: http://support.eset.com/kb146/?&page=content&id=SOLN146

2. Disable the streaming feature on the bnet app and then set the app to close when a game is launched. We'll start with setting the app to exit when a game is launched:
- click the bnet logo in the top left hand corner of the app
- go to 'Settings'
- in the general tab change the 'When I launch a game' dropdown to 'Exit Battle.net completely'
- click down to the streaming tab
- uncheck the 'Enable Streaming' box
- click done to save the changes

9-11-16 1000

• Please make sure that the Overwatch game files are not damaged. Please run the repair tool as this will find and fix any damaged game files. https://us.battle.net/support/en/article/6572

• Open the My Documents folder in Windows. In the My Documents folder there will be a Overwatch game folder. Rename the Overwatch folder. We may need the error reports stored in this folder later, please do not delete it.

• It is possible that another program may be affecting our games. To test is this is the case, please run your computer in a selective startup mode. https://us.battle.net/support/en/article/200483

• The files do not tell us if Windows is up to date. Please make sure Windows is updated. You will most likely need to install the optional updates too. After you install any an updates make sure you restart the computer and check to see if there are more updates. Windows does not give you all the updates at once. http://www.update.microsoft.com/

• • Disable the Battle.net Streaming
1) On the Battle.net App click on Options and then Game Settings.
2) Click on Streaming.
3) Under Streaming Options uncheck Enable Streaming and then press Done.
• Let's set the Battle.net App to close when a game is running.
1) On the Battle.net App click on the big Battle.net icon in the upper left corner.
2) Then click on Settings from the dropdown menu that opens up.
3) In the General preference tab, under the When I launch a game field, select Exit battle.net completely.
4) Click on done and launch the Overwatch

• The files do show a lot of errors with the AMD video drivers. Let's remove the drivers via a program called DDU (Display Driver Uninstaller) and them reinstall them.
1) Install DDU from here: http://www.guru3d.com/files-get/display-driver-uninstaller-download,20.html
2) Once that's installed, go ahead and run the program.You will be asked if you want to reboot into safe mode, click on "No".
3) Select "AMD" from the "Select Graphic Driver" drop down menu.
4) Click on the "Clean and restart" button.
5) Once it restarts the PC you'll want to go to: http://support.amd.com/en-us/download/desktop?os=Windows%2010%20-%2064
6) Once installed, run the program and follow the on-screen install steps.

9-11-16 2200

Took a look over the most recent crash logs and we're seeing xaudio2_9.DLL pop up. For that please go through steps 4-8 here:

http://us.battle.net/forums/en/overwatch/topic/20744175764#post-12

If you don't see a [Sound.3] section then go ahead and add it to the bottom of the settings file!
Hi iTzNick90!

Thanks for the detailed post! Chrome uses a good amount of system resources, particularly if there are a lot of tabs open and/or if the websites that are open are complex ones. That can, in turn, cause problems when used in conjunction with Overwatch.

The primary resource that's a concern here is VRAM. By default, Chrome uses a large amount of VRAM. So does Overwatch. Used together, it can max out and cause a GPU reset (and hence, a crash).

Typically the easiest way to combat this is to turn off hardware acceleration in Chrome:
    Open Google Chrome.
    Click Customize and Control Google Chrome > Settings.
    Click on Show advanced settings and scroll to the System section.
    Uncheck Use hardware acceleration when available and restart Google Chrome.

Alternatively, lowering in-game settings would also help alleviate VRAM usage: reducing texture detail to low, lowering the resolution, lowering the render scale, etc.

Thanks again for the information, iTzNick90, and I'm glad to hear you've had such a great experience with Support!
I did some tests with other browsers and they all do the same thing. I will do this and see if it makes a difference. It may not be till tomorrow night though. Thanks for the extra info.

PC parts list has been added to OP.

09/12/2016 01:01 PMPosted by Jagowoshi
Hi iTzNick90!

Thanks for the detailed post! Chrome uses a good amount of system resources, particularly if there are a lot of tabs open and/or if the websites that are open are complex ones. That can, in turn, cause problems when used in conjunction with Overwatch.

The primary resource that's a concern here is VRAM. By default, Chrome uses a large amount of VRAM. So does Overwatch. Used together, it can max out and cause a GPU reset (and hence, a crash).

Typically the easiest way to combat this is to turn off hardware acceleration in Chrome:
    Open Google Chrome.
    Click Customize and Control Google Chrome > Settings.
    Click on Show advanced settings and scroll to the System section.
    Uncheck Use hardware acceleration when available and restart Google Chrome.

Alternatively, lowering in-game settings would also help alleviate VRAM usage: reducing texture detail to low, lowering the resolution, lowering the render scale, etc.

Thanks again for the information, iTzNick90, and I'm glad to hear you've had such a great experience with Support!
I keep having this same crash every few games even with hardware acceleration turned off in Chrome.
I had the same issue. My PC Specs are an i7 5820k @ 4.0gHz, 2x R9 390s by Sapphire, 32gb Mushkin Blackline DDR4 RAM, 1.5TBs of SSDs, 7TBs of HDDs. I updated my AMD drivers with 16.11.2 released on 11/3/16. That solved my issue, hopefully it'll do the same for you guys!

-Partycat
How about more of an instep how to get to customize because my google chrome has no such god damn thing.
Hate when blizz gives out information to help. Its always near impossible to understand what the hell they mean, when literally you go into everything and it doesnt have what they say. How about how do you let people know where and or how to get to this customize page.
11/23/2016 12:42 PMPosted by Insane4SY7UM
Hate when blizz gives out information to help. Its always near impossible to understand what the hell they mean, when literally you go into everything and it doesnt have what they say. How about how do you let people know where and or how to get to this customize page.


I managed to do it, and so can you. You literally just click the three dots in the top right corner to open the menu, click Settings, then click Show Advanced Settings, then scroll down to System and uncheck it. I don't see the problem?

Join the Conversation

Return to Forum