Microphone suddenly stopped working.

Technical Support
My mic was working fine in Overwatch, but after this update it suddenly stopped working. It works fine in other games, Discord, Skype etc. And the strangest thing is: when I go to settings in the Battle.net app and go to Voice Chat and there click test microphone it works there too. But in Overwatch when I push my 'push to talk' button I can hear the sound that it makes when you push it but when I talk the icon doesn't appear in the top left corner. And people can't hear me.
Same for me, just made a post too, before i saw yours.
This has happened to me as well, since the patch.
Hey all,

I am sorry to see there has been any issue with the voice chat after the last patch. Please do try these steps to get the voice chat working again.

• Please double check the Sound setting in Overwatch.
-Voice Chat volume and Voice Chat Mic Volume are set to max volume for now.
-Group Voice Chat and Team Voice Chat are set to Auto Join
-Voice Chat Device: try the different options to see if there is a change.

• Remove the ability for applications to take exclusive control over an audio device.
    1) Right click on Window's volume icon in the system tray
    2) Open Playback devices
    3) Select the device you want to use in game
    4) Open the Properties for this device
    5) Click on the Advanced tab
    6) Remove the check box for "Allow applications to take exclusive control of this device"
    7) Repeat the process for Recording devices (step #2 above).


• To be on the safe side let's make sure that in Windows that the headphones and the microphone are set as the default devices.
    1) Right click on the Sound icon on the right side of the Task Bar.
    2) Select Playback Devices.
    3) Right click on the Headphones you are using and select Set as Default Device
    4) Click on the Recording tab
    5) Click on the microphone you are using and select Set as Default Device.
    6) Click OK and test the headphones and microphone in-game.


• Make sure the Firewall in the computer and router is set up correctly.

• Run the computer in a selective startup mode.
01/30/2017 12:20 PMPosted by Eloemaz
Hey all,

I am sorry to see there has been any issue with the voice chat after the last patch. Please do try these steps to get the voice chat working again.

• Please double check the Sound setting in Overwatch.
-Voice Chat volume and Voice Chat Mic Volume are set to max volume for now.
-Group Voice Chat and Team Voice Chat are set to Auto Join
-Voice Chat Device: try the different options to see if there is a change.

• Remove the ability for applications to take exclusive control over an audio device.
    1) Right click on Window's volume icon in the system tray
    2) Open Playback devices
    3) Select the device you want to use in game
    4) Open the Properties for this device
    5) Click on the Advanced tab
    6) Remove the check box for "Allow applications to take exclusive control of this device"
    7) Repeat the process for Recording devices (step #2 above).


• To be on the safe side let's make sure that in Windows that the headphones and the microphone are set as the default devices.
    1) Right click on the Sound icon on the right side of the Task Bar.
    2) Select Playback Devices.
    3) Right click on the Headphones you are using and select Set as Default Device
    4) Click on the Recording tab
    5) Click on the microphone you are using and select Set as Default Device.
    6) Click OK and test the headphones and microphone in-game.


• Make sure the [url="http://us.battle.net/support/article/300479?utm_source=internal-TechForum&utm_medium=posting&utm_campaign=BlizzardCS&utm_content=solution"]Firewall in the computer and router is set up correctly. [/url]

• Run the computer in a [url="https://us.battle.net/support/en/article/200483?utm_source=internal-TechForum&utm_medium=posting&utm_campaign=BlizzardCS&utm_content=solution"]selective startup mode[/url].


Done all of this (it's the same as it was before), but this is actually a deeper issue. It's a bug that happened with the update, and it's not related to any windows or OW settings that were changed.

The mic test works fine with Default Device in Battle.net but it no longer works in game in either push to talk or Open Mic.
tried all of this too. wont work for me. still cant talk to team
Having the exact same issue with an At2020 hooked up to an audio interface. Microphone works in all other programs but I get nothing in Overwatch. I've tried everything above while also reinstalling the game but still nothing works.

Haven't played in a while because I don't want to play competitive without a mic :/
Having the same issues since the update. I have not been able to communicate with my team and that's been frustrating so I took a break from the game. No matter what I do (including Eloemaz instructions) I can't get my microphone to work in game. Yet it works fine for skype, discord, teamspeak anything else.
Are you trying to use Discord and Overwatch at the same time?

Also, when you look at your devices, there is a section that allows "Exclusive mode" for programs using audio. Always make sure that's unchecked otherwise that might be causing your issues as well
02/03/2017 06:55 AMPosted by pearlpixel
Are you trying to use Discord and Overwatch at the same time?

Also, when you look at your devices, there is a section that allows "Exclusive mode" for programs using audio. Always make sure that's unchecked otherwise that might be causing your issues as well

I have also done this already, in fact I've started my PC with nothing but Overwatch launched asides from windows. I can hear people talk in game but I cannot use my mic. It's like it doesn't register the mic even though it's default. Yet every single game / program other than OW does just fine. Discord, TS, CSGO, Skype.
Same issue.

All settings are correct.

It seems like it's an issue with external audio interfaces? I am running a mic into a Scarlet Solo USB interface.

Was working fine before the patch, now I get the same issue as everyone else here.

If I switch the windows default input to my rubbish webcam mic, then it actually works in the game.

Definitely something to do with the patch.
Same issue happened to me on 2.14 the V day. But the difference is I even can't hear what my teammates are talking and my mic didn't work for both Battle net client and Overwatch. But it works for everything else.

It is the problem of the patch
Same issue here :/ . Blizz pls fix.
Having the same issue as well. Bump for a fix.
Same thing happened to me and my friends after the update. Mics just stopped working and we did all recommend steps but the mics still don't work. Has to be a bug
same here. i get "error 10028" and its not only me, 7 of my friends have this problem starting yesterday
I didn't even get an error yesterday, but my mic wasn't working and I couldn't hear any voices in game.

Two of my friends got the error and had the same issue, and one plays comp.
I am experiencing the same problem
I tried reinstalling the game and checking all ports, etc. When in a game its showing I'm in team chat, but my mic is not registering when talking.
Experiencing the same issue, enabled the ports, but mic is still saying its muted. Bumping this to raise awareness.
Try clicking to join a competitive game, see if the queue is blocked for you - have you been silenced due to reports from other players?

Join the Conversation

Return to Forum