Voice chat 'visual signal' and mic capture not working

Technical Support
My son and I play together on two PCs since game launch. Today he told me his mic was no longer working.

So I did some tests
- tested the mic on Windows 10, working.
- tested it on Discord, working.
- tested it on Battlenet, working.

I can't find out why it is not working only on Overwatch. I tried setting the game to Push to Talk and Open Mic, none worked. I tried changing the keybinding for the Push to Talk, didn't work. I checked windows firewall and there is no block regarding Overwatch or Battlenet (remember, the voice chat is working on Battlenet).

Then we both joined a Custom Game (and yes we were in a group/party). When I press ' on my PC he can hear me and we both see the visual signal that indicates someone in the group is talking. When he presses the same key, he hears the sound to confirm he pressed it, but none of us can see the visual signal, nor I can hear his voice.

Oh, I even tried running Overwatch as Admin (read about that on some posts regarding mic issues). That didn't work too.

So, since other programs (battlenet included) get and transmit what his mic captures, it's not an issue with the mic or soundcard, right?

Any ideas on how to fix this? Just remember, everything worked just fine since game launch until last friday (1/27/2017).
This has happened to me as well, since the most recent patch.
01/30/2017 11:36 AMPosted by Khamele0n
This has happened to me as well, since the most recent patch.


Did you fix the problem in any way?
01/30/2017 01:02 PMPosted by Kenjiro
01/30/2017 11:36 AMPosted by Khamele0n
This has happened to me as well, since the most recent patch.


Did you fix the problem in any way?

Nope. Still waiting for Tech Support to reply to the thread, but so far they've just been recommending the default course of actions (like setting Default audio Devices in Windows, and checking your router ports).

Hopefully soon they'll be able to gather that this is actually a bug and not a case of having things set incorrectly in the OS (which is why the mic still works in all other apps including the Battle.net client).

Everything worked smoothly until the Year of the Rooster update last week.
I'm really hoping they fix this soon. Mic works in every other program and have confirmed that Overwatch is set to use the right mic (by hovering over the sound devices option).
Hate to say this but there are numerous posts from way back into 2016 on this and similar issues with voice chat.
I can normally go 2-3 matches being able to communicate. Sometimes it happens mid match and goes out.
Then start a new match and when I use my push to talk I only hear the initial key press sound. No voice communication at all. I have tried everything. 3 different mics, reformatting, new and old drivers etc....
Once my voice chat goes out even if I exit to my desktop and use task manager to shut the game down then restart battle net it still thinks the game is running. No amount of time letting it sit there will allow me to hit play. I have to restart my entire system.
I hit P and sometimes everything looks good sometimes it shows my mic is muted when it's not.
The only answer you will get from blizzard is the generic cut and paste try these 6 steps. Of course it does not work.
Funny our mics and voice chat work with every other game and applications. Heck it even works fine within battle net.
After every patch people come here with the same issues about voice chat. There was a thread posted in early December wanting game logs posted trying to figure it out. No reply from blizzard since.
I just wish they would admit it is an issue on their side. This is gets old really fast.
Mic works fine for discord, skype, teamspeak but when I want to talk in the game with people I don't know it won't work anymore since the update. If I can't communicate with my team I can't play this game.
02/01/2017 06:41 AMPosted by Variare
Mic works fine for discord, skype, teamspeak but when I want to talk in the game with people I don't know it won't work anymore since the update. If I can't communicate with my team I can't play this game.

Yeah, along with the lag bug, this has made Competitive mode unplayable for me. Even when the rubberbanding issue is fixed (hopefully) I'll be hesitant to play Comp without microphone support.
Hey guys! Let me ask some questions to help troubleshoot:

Okay, so did voice stop working after an update?
Has he or you changed the mic recently?
What kind of mic are you using?
Is the computer user running as an admin?
02/02/2017 08:07 AMPosted by pearlpixel
Hey guys! Let me ask some questions to help troubleshoot:

Okay, so did voice stop working after an update?
Has he or you changed the mic recently?
What kind of mic are you using?
Is the computer user running as an admin?


1- There was an update before the problem showed up, but I don't remember when the update happened.
2- No, the mic is the very same since the beginning
3- It's a regular headset connected to the soundcard (onboard) jack
4- he uses the only user the PC has, so yes, the user has some admin powers. But, as I said, we even tried running Overwatch as admin, which didn't solve the problem.

And remember, the mic works just fine on Battlenet (when you create those groups to chat), Discord, etc. It's not working ONLY on Overwatch.
So... today we got a new patch/update but... the mic issue hasn't been solved.

Way to go, Blizzard :(
If I scream into the mic I get the visual cue for voice chat but not otherwise. It seems to be a problem with the voice detection inside Overwatch. I've tried both continuous voice chat and push-to-talk and it's the same thing with both of them.

Join the Conversation

Return to Forum