GUIDE: Maximizing System Performance for Overwatch (PC)

Technical Support
hi i wonder why i keep disconecting from my serve .
|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| 192.168.0.1 - 2 | 175 | 172 | 1 | 2 | 50 | 1 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

pls reply blizzard
Something is seriously wrong with the game servers as I cant even play for more than 5 minutes without getting disconnected. My internet is working perfectly fine. Can't be my PC as I just built it - brand new everything . played others games with zero issues . help me
|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| 192.168.0.1 - 2 | 175 | 172 | 1 | 2 | 50 | 1 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 38 | 0 | 0 | 0 | 0 | 0 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

pls reply blizzard
Installation Tips & Type of Storage
To minimize issues with Overwatch running properly on your system, I strongly recommend making sure that Overwatch and Blizzard App Launcher is installed in the same storage drive as your Windows® Operating System. I have found many players often have performance issues, if not crashes, when Overwatch and the Blizzard App Launcher is installed on a secondary storage drive. Furthermore, if you really want to get an edge in speed performance during key events such as the Hero Selection Screen, consider using a solid-state drive as your primary storage drive. A solid-state drive (SSD) is a storage device that uses integrated circuit assemblies to store data persistently, and uses no mechanical components unlike a traditional magnetic disc Hard Disk Drive. Data transfers quickly and fluently this way so loading screens run faster.

Where do you find the storage that Windows Operating Storage is?
I need help, my pc has a gtx 1080 ti and 32 gb ram and I cant run overwatch with good graphics and fps, I tried putting all my settings on low and my render scale to 100 or 75 but my frames drop to 20-30 fps, this problem is only on overwatch and all my other games run on 120-150 fps. When I put my render scale on automatic its on 33% which makes the graphics really bad. Thanks
Thanks for the tips ! Very useful guide.
I have a question .... I am thinking of buying overwatch for christmas and but my GPU is nvidia geforce 930MX and I think thats below the needed... I really wanna play the game, do you think I can run it?
Hello. I am confused on the requirements for the GPU. I checked the page and the supported video cards list on that page, but I am still unsure if my video card (2GB AMD Radeon 530) will run the game. Can I get clarification on that?
(I cannot create a topic myself for some reason so I am replying to help posts)
These are my pc specs, i cant run overwatch properly with good graphics and fps, my render scale is on 33% automatically and because of that my graphics are bad, i can run other games properly but i only have a problem with overwatch.(Does a curved monitor have to do anything with this?)
Alienware Aurora R7
Intel®️ Core™️ i7 8700 (6-Core, 12MB Cache, up to 4.6GHz with Intel®️ Turbo Boost Technology)
Windows 10 Home 64-bit English
Alienware™️ 850 Watt Multi-GPU Approved Power Supply
NVIDIA®️ GeForce®️ GTX 1080 Ti with 11GB GDDR5X
32GB Dual Channel DDR4 at 2666MHz; up to 64GB (additional memory sold separately)
256GB M.2 PCIe NVMe SSD (Boot) + 2TB 7200RPM SATA 6Gb/s (Storage)
CD ROM/DVD ROM
Tray Load DVD-RW Drive (Reads and Writes to DVD/CD)
Windows 10 Home 64-bit English
12/30/2017 10:19 AMPosted by Excau
These are my pc specs, i cant run overwatch properly with good graphics and fps, my render scale is on 33% automatically and because of that my graphics are bad, i can run other games properly but i only have a problem with overwatch.(Does a curved monitor have to do anything with this?)
Alienware Aurora R7
Intel®️ Core™️ i7 8700 (6-Core, 12MB Cache, up to 4.6GHz with Intel®️ Turbo Boost Technology)
Windows 10 Home 64-bit English
Alienware™️ 850 Watt Multi-GPU Approved Power Supply
NVIDIA®️ GeForce®️ GTX 1080 Ti with 11GB GDDR5X
32GB Dual Channel DDR4 at 2666MHz; up to 64GB (additional memory sold separately)
256GB M.2 PCIe NVMe SSD (Boot) + 2TB 7200RPM SATA 6Gb/s (Storage)
CD ROM/DVD ROM
Tray Load DVD-RW Drive (Reads and Writes to DVD/CD)
Windows 10 Home 64-bit English

dude how rich are you lmao thats a great setup.
To change your render scale, click render scale then set it to what you want.
it's an excellent post, but I am having issues with the part about being on the same hard drive as the OS.

I've just moved it off that hard drive because of issues I was getting with overwatch

i9-7940x, 32gig quad channel RAM, 1080 Ti , OS SSD M.2 500 gig, Games drive SSD 256gig.

its only tiny issues that I had, like Profiles were taking ages to load... and couldn't work out if it was server side/ISP/or Hardware. Was also getting sporadic Bluescreens when exiting Overwatch (as soon as i close overwatch with in a minute the machine would bluescreen, only occurs in overwatch as well ) . I attributed this it being a i9 Processor and there still being a lot of things being "worked" out by Microsoft,Intel and Mobo Manufacturers. But did what I could myself.

Knock on wood. OW now runs a bit better and im bug free on a seperate hard drive to the OS.
does keeping services and on startup apps trimmed in msconfig make a difference?
I am not sure what is happening to my game, I have had this issue since the last update (the january one for Blizz World) and my game had crashed after working perfectly fine! After I restarted the game started to lag so bad from graphics to controls and all my other games have been working perfectly fine so I know its not likely it is my computer! I just really hope I can find a way to resolve this, I truly love this game1
Here's another tip you should add to the guide: if you're using Windows 10, press WIN + G to open the game bar. Press settings and then check the box next to "Use Game Mode for this game". It actually does help to keep the game and mouse input running smooth, I highly recommend having it on
01/27/2018 01:47 PMPosted by whatBEARsalt
Here's another tip you should add to the guide: if you're using Windows 10, press WIN + G to open the game bar. Press settings and then check the box next to "Use Game Mode for this game". It actually does help to keep the game and mouse input running smooth, I highly recommend having it on


Not working..
Very helpful thanks for sharing this m8
Can you help me please. I've been playing OverWatch sense launch and every day before the free weekend and all through the free week end my ping hits 140 and dosent change. Can someone help??
[b]Hello everybody i have a problem with start up of overwatch the problem is 0xE0070160 please help me to fix this problem thanks.

Join the Conversation

Return to Forum