Razer Chroma not working?

Technical Support
I just recently purchased a Blackwidow Chroma v2. On the date of purchase, the lighting for Overwatch was working fine, but after Windows updated to the Fall Creators Update two days after, the lighting in game quit, on both my keyboard and my Deathadder Elite! It remained in Chroma Apps, but now has somehow managed to disappear. I've contacted Razer support multiple times, and they are unfortunately no help whatsoever. I've also uninstalled and re-installed Synapse a number of times to no avail. Does anyone know a way to fix this? It's incredibly annoying, and I love having my lighting change in the hero select mode, and when playing different heroes!
My Razer Blackwidow Chroma is not working neither.
First make sure Razer Synapse is fully up-to-date, the base install of Synapse may not function correctly with Overwatch.

1. Open Razer Synapse.
2. Click the "gear" icon in the menu bar of the window.
3. Select Check for Updates.

Last I saw on my Blackwidow, Deathadder, and Kraken, everything was working fine. I am AFK from my primary gaming rig so I can't verify immediately if there is a widespread issue or not.
Hey guys, I had the same problem where the keyboard and mouse were working perfectly fine but the lights were just completely shut off. What fixed it for me is opening Synapse, clicking on "Chroma Apps" and toggling it off and then back on. If that doesn't fix it, there are possibly a couple of other things you can do. Try unplugging and re-plugging your keyboard/mouse, possibly into different USB slots. Also try creating a new profile under "keyboard > customize" and see if the lights come on when toggling through profiles. As a last resort, you can possibly try deleting any/all profiles you have and start fresh to see if the lights come on.
Still not fully working:

the keyboard doesn't go Overwatch-orange on startup, my driver lighting only changes when I arrive on the character select screen.

no ripple effect on character select screen, it simply changes the color when I switch characters.

no ripple effect on ult activation
Jep it's still broken. Please fix please. I wanna try the Philips Hue integration when the Synapse 3 leaves beta.
https://insider.razerzone.com/index.php?threads/razer-chroma-for-overwatch-isnt-what-it-looks-like-on-pictures-on-blackwidow-chroma-v2.29945/#post-413636

See here for more information
I have a razer mamba TE and the lighting effect i chose is not working while in overwatch. It instead stays a muted yellow color and was wondering if it was relevant to what is happening with the other problems in this post.
Are you already on Synapse 3?
The latest OW update made made the effects work again for me.

Join the Conversation

Return to Forum