Keyboard randomly stops working in game

Bug Report
Very rare that this happens, but sometimes I'll be playing and my keyboard will suddenly stop allowing me to type, but I can still play the game and use abilities.

If I leave the game, I can't type in other programs either until I reboot, but it's weird because I can still play the game just fine as long as I don't type.

Any ideas how to fix? It's really frustrating when it happens in a match.
I don't have a fix, I just wanted to stop in to say this happens to me too. Actually it happens with all my games that use the Blizzard app. Or at least with Destiny and Overwatch.

I will say a simpler work-around is to log off instead of reboot, as it seems to correct the bug faster then a full reset, but it is still only a work around.
Hey there Sk3wlbus/SirSeffry,

We've actually gotten a couple reports of this recently. To the best of our knowledge it seems to happen due to the Discord Overlay Lock function. Either disabling the overlay or setting the Overlay Lock to a key you never push accidentally should fix you up. (I use numpad minus because it's waaaaay over there.)

    1. Go to your Discord Settings (Cogwheel in the bottom left)
    2. Click the Overlay option from the left hand menu
    3. Either turn the Enable in-game overlay option to off (gray) or change the hotkey for Toggle Overlay Lock.


If this works for you, let us know!
Even when I have the overlay set to a key i don't use (I tried setting it to alt backslash) it still did this for me. Best to just disable it.
01/08/2018 08:34 PMPosted by Drakuloth
Hey there Sk3wlbus/SirSeffry,

We've actually gotten a couple reports of this recently. To the best of our knowledge it seems to happen due to the Discord Overlay Lock function. Either disabling the overlay or setting the Overlay Lock to a key you never push accidentally should fix you up. (I use numpad minus because it's waaaaay over there.)

    1. Go to your Discord Settings (Cogwheel in the bottom left)
    2. Click the Overlay option from the left hand menu
    3. Either turn the Enable in-game overlay option to off (gray) or change the hotkey for Toggle Overlay Lock.


If this works for you, let us know!


Thank you very much for posting this. I just implemented this fix and plan to try it later on. I'll let people know how it went.
Sadly it didn't seem to work. I do have another work around though. The browser version of Discord has no such issues. Eventually I plan to do a fresh install of Discord to see if that fixes the problem. In the meantime I can still use Discord for communication while playing Blizzard App games.

I hope somewhere between Blizzard and Discord this error gets fixed. Discord is too good of a voice/chat client not to use.
01/09/2018 09:22 PMPosted by SirSeffry
Sadly it didn't seem to work. I do have another work around though. The browser version of Discord has no such issues. Eventually I plan to do a fresh install of Discord to see if that fixes the problem. In the meantime I can still use Discord for communication while playing Blizzard App games.

I hope somewhere between Blizzard and Discord this error gets fixed. Discord is too good of a voice/chat client not to use.


I hope multiposting is not against the rules and regulations of this support site, but I have new information and it's now a couple days in the future so I feel updating my old post would cause it to go overlooked.

After more extensive testing the bug still remains even when not running the Discord client. At this point I feel back at square one with regards to troubleshooting this issue. I don't have an updated work-around to add with this post, but I wanted anyone who maybe hunts this thread out to know that it seems this isn't necessarily the solution. It DID seem like it was going for longer without the bug occurring, but that may have been due to any number of factors, and could simply have been a case of "correlation does not imply causation."
SirSeffy,

That's interesting. Sorry to hear you're still having trouble. Is the Discord App still installed on your machine? If so, can you try uninstalling that and see if the issue disappears? It's possible a module related to that overlay is still loaded while you're playing.

Thanks for posting those updates. Going forward, posting again is perfect, it makes sure we see the posts.
01/12/2018 10:04 AMPosted by Drakuloth
SirSeffy,

That's interesting. Sorry to hear you're still having trouble. Is the Discord App still installed on your machine? If so, can you try uninstalling that and see if the issue disappears? It's possible a module related to that overlay is still loaded while you're playing.

Thanks for posting those updates. Going forward, posting again is perfect, it makes sure we see the posts.


Sorry for the large lapse in time. Been a hectic work week and I haven't had a lot of time to do more testing.

At the time of my last post discord was still installed, I had made sure to check my processes for any instances of the program running though.

I did try another possible solution provided by another tech specialist responding to my ticket on this issue. Nvidia Geforce Experience also has it's own in-game overlay which can be disabled in settings. I have since disabled that as well. I haven't thoroughly tested since disabling this, but I did have one two hour session without the error being present.

Not quite enough time for me to be fully convinced, but I thought it was enough to update this post for those seeking a solution. I'm hoping to have some time to test this solution more thoroughly this weekend, and if I do I'll make an update post with my results.
So I've tried just running the game without Discord even open and it still happens. I'm leaning more to think it has something to do with Nvidia/Shadowplay and their overlay rather than Discord. I'll try playing without either open and see if it happens again.

Again the bug is so rare that it may be a couple months before I even see it again.

Join the Conversation

Return to Forum