Crash on Launch..

Technical Support
Overwatch crashes after pressing play, a black screen flashes and then overwatch closes without any error message.
The log file in Documents/Overwatch only shows the following:

[4440] [NRM] [Game] [External(0)] [External()] [2018-02-11T22:20:01.181Z]: #= VoiceClient: ============================Startup============================
[4440] [NRM] [Game] [External(0)] [External()] [2018-02-11T22:20:01.182Z]: #= VoiceClient: State -> INITIALISED


What I've tried:
- Setting Nvidia GPU as the prefered graphics processor in the Nvidia control panel
- Running ow with the Intel integrated graphics
- Windowed mode (through Settings_v0.ini)
- FullscreenWindowed mode(through Settings_v0.ini)
- Running ow in compatibility mode.
- Uninstalling everything that has to do with ow (Using Revo) and reinstalling.
- Reinstalling Nvidia graphics. (Used DDU)
- Closing all overlay apps.
- Add exclusions to windows defender.
- Disable firewall and windows defender.

It worked before the latest update.. so I have no idea what to do now.
All my other games work just fine and reinstalling windows for ow is something I would hate doing.

I have a gaming laptop with the following specs:
Intel Core i7-7700HQ
NVIDIA GeForce GTX 1050 (4GB GDDR5)
16GB DDR4

Send help..
same deal all of the sudden, my log says:

[7728] [NRM] [Game] [External(0)] [External()] [2018-02-12T00:13:56.165Z]: #= VoiceClient: ============================Startup============================
[7728] [NRM] [Game] [External(0)] [External()] [2018-02-12T00:13:56.172Z]: #= VoiceClient: State -> INITIALISED

tried uninstalling/reinstalling battle.net launcher app.
updating graphics card
scan and repair option from battle.net
manually launching OW.exe
I have the identical problem and have tried all of the above, problem persists
Tried every fix I've read on the forums it feels like
Hey folks,

We've actually started getting a number of reports on this recently. Specifically for crashes at startup with no error message, it seems like a lot of them are due to Razer Software fighting with the game.

Can you folks try temporarily uninstalling any Razer software you're running and see if it clears it up? We've had some players try disabling it, but it hasn't been working for most people. It's probably the Chroma Software Development Kit, but we'd like some more information to try to figure out which piece it is if it works.
im not gonna lie, i had this happen to me like two nights ago until i gave up and hard reset my pc, then backed everything up, and yes i do believe it has to do with Razer software, since i tried to fix the lighting issues with my deathadder chroma, whcih wasnt changing color with its respective hero, also i was an idiot and thought linking ow to my razer synapse would help
I've Uninstalled all Razer software and tried using a different mouse(my only razer device is a mouse) to no success. Would like to know progress on a potential fix for this issue, I wanna get Dem lootboxes
Updated all my Razer software and it seemed to have fixed the problem. this includes the hue update. I have no Hue bulbs, but it did not work until i updated this portion of the app as well.
As an update on this thread, Razer's aware of the problem. You can try updating or reinstalling your Razer software as Plumpbuddha mentioned - it's possible the problem was with an older version of the drivers.

If that doesn't work, for now the best and most consistent thing we've found is fully uninstalling the razer software. If we hear anything else, I'll let you all know!
I am having a similar issue, but have no Razer components. Tried the scan and repair utility as well as updating drivers. Neither seemed to work.

Join the Conversation

Return to Forum