Mac Technical Support

Mar 12, 2013 Welcome to Mac Technical Support Welcome to the Mac Technical Support forum for StarCraft II! This forum exists to provide StarCraft II customers with a place to discuss technical issues with each other and Blizzard Tech Support staff members. While Blizzard Tech Support staff regularly monitors and replies to this forum (between 8am-5pm Pacific, 5 days a week), it is not meant as a place to resolve complex issues, because of the nature of forums. If you cannot resolve your issue through the forum, we recommend checking our Knowledge Center for resolutions and workarounds for common issues: If you wish to contact our Support team directly, you may do so through the following channels: Online Ticket - You can keep track of all your communication with Customer Support through your Blizzard account. Phone Support - You can schedule a callback from us from 10am - 6pm Pacific time, 5 days a week. Please keep all posts on topic. This means technical issues, advice, and discussion of technical issues. Bug reports should be directed to the bug report forums. Game discussions, criticism, or commentary should be posted in the appropriate gameplay forums. When requesting assistance with or discussing an issue, please create your own thread unless a topic for the issue already exists. Do not hijack threads with your new topic. Posting an issue which is similar but different from the original topic means that your request may be missed or the original request ignored. Please post a subject with a clear summary of your issue. Starting posts with "I need help!" or "Can't play no matter what" only serves to make your issue harder to resolve. We understand that emotions can run high while dealing with technical issues, but posting in an abusive or disparaging manner will not be tolerated, and does not advance our goal of providing assistance to the widest audience of customers in this forum. Please do not post direct contact info for other companies. It is acceptable to post links to websites where contact info can be found, but posting the information here on the forum is not permitted. To provide feedback on a ticket or customer support response you have received, please utilize the survey system built in-game or on the online ticket. We hope that this forum can continue to be a place where users can find quick resolutions to their issues. To help do this we ask that the forum guidelines be observed at all times when contributing to discussions.Machkhan0 Mar 12, 2013
Mar 12, 2013 Common Technical Issues and Solutions Hello friends! Below, you will find frequently posted technical issues with relevant support articles that may help resolve your issues. Low frame rates and performance during gameplay Lockups, crashes, black screens during gameplay Lockups, crashes, black screens on game launch This is a living document, so please check back from time to time for updated common issues. Thanks!Machkhan0 Mar 12, 2013
Jul 1, 2017 Common Connection and Latency Issues Greetings all, We've been working to improve some of the available troubleshooting resources for our games. Since connectivity problems are a common problem in gaming, we wanted to provide some information on what causes connection problems and what to do to resolve issues when you're having them. Table of Contents 1. Connection Troubleshooting Resources 2. FAQs 3. What to do if you need more helpDrakuloth4 Jul 1, 2017
2d Mouse/Trackpad not working Anyone else having an issue where your mouse or trackpad won't work after installation of the latest patch? I played yesterday, but just logged in and my cursor won't move. The keyboard works since I hit the escape key the menu pops up, but I can't select anything. I plugged a mouse into my laptop and it doesn't help. I restarted my laptop and still no joy. The button works. I was curious how to get the game to quit so I windowed out of SCII moved my mouse manually to where the "exit game" button is in game. windowed back into SCII and clicked the mousepad and the game exited. Mac OS 10.14 MojaveBerith59 2d
4d mouse not working in game I have a Mac book pro and for some reason my mouse is not working in game no like I can't even start a matchAntonio91 4d
Feb 8 Cannot move mouse since 4.7 when fullscreened As the title says, the mouse or trackpad cannot move while the SC2 screen is active and full screen. I recently upgraded to Mojave, but it was not an issue on 4.6, as I could still play fullscreened. The mouse still works just fine on any window that isn't SC2, and command-tabbing out of SC2 lets me move the mouse again. But once I pull SC2 up again, the mouse is stuck in place. I can still freely click buttons, but cannot move the cursor around. After multiple tab outs and tab in to position the mouse, I was able to switch to windowed, and the mouse now responds properly in game. The mouse also responds properly in windowed (fullscreen). I would prefer not to play windowed though, so any help would be appreciated.Rasera5 Feb 8
Jan 30 Game crashes during Scythe of Amon load. Hello all, Every time I go to play coop I have to hope I don't get put into a Scythe of Amon game, since my game will always crash during the load. I've erased the game and redownloaded, but that hasn't solved the issue. I've submitted several troubleshooting reports to blizzard, but this has been going on for well over a month or more. Any thoughts, or ideas? Thanks!Drpwnsauce3 Jan 30
Jan 28 Cant launch SC2 since latest patch original report reappeared, this is no longer needed, ignoreAsh0 Jan 28
Jan 28 Can't launch SC2 since latest patch I have not run SC2 on my mac for a couple of weeks. On attempting to play today I got an un expected fatal error has occurred message when launching (sometimes I see the screen go black then get it, sometimes I see a flash of loading screen, sometimes I see a tiny wee window appear then it happens) I wondered if this was because I was on High Sierra so took the plunge and updated to Mojave but this has not helped. About this mac: System Software Overview: System Version: macOS 10.14.3 (18D42) Kernel Version: Darwin 18.2.0 Boot Volume: Macintosh HD Boot Mode: Normal Hardware Overview: Model Name: MacBook Pro Model Identifier: MacBookPro11,1 Processor Name: Intel Core i5 Processor Speed: 2.6 GHz Number of Processors: 1 Total Number of Cores: 2 L2 Cache (per Core): 256 KB L3 Cache: 3 MB Memory: 16 GB Latest crash report: ==================================================================================================== StarCraft II (B71663) Executable /Applications/StarCraft II/Versions/Base71663/ <Parameters> -sso=1 -launch -uid s2_engb Parent Executable /sbin/launchd Grandparent Executable /sbin/launchd LocalTime 2019-01-28 15:11:52.8064 <ComputerUser> dave <ComputerName> David’s MacBook Pro <Exe.Architecture> x86_64 <Version> <DataBuild> B71663 <CodeBranch> branches/SC2.2019Season1 <CodeRevision> 578821 <Locale.Assets> enUS <Locale.Data> enUS <Locale.Install> enUS <AccountCountry> GBR <AgentVersion> <Jira.JiraProjectKey> SC2 <Exception.ProjectId> 3 <BlizzardError.IssueType>Exception <BlizzardError.BuildNumber>B71663 (SC2.2019Season1) <BlizzardError.Branch> branches/SC2.2019Season1 <BlizzardError.Platform>Mac <Exception.Field2> SC2 Bug Staging <BlizzardError.Priority>2 - High <BlizzardError.Summary> SIGABRT Abort trap <ErrorType> SIGABRT <Application> StarCraft II <InstanceID> 0 ==================================================================================================== <BlizzardError.Assertion:> SIGABRT Abort trap Thread ID:0 0 0x0000000000000000 <:BlizzardError.Assertion> ==================================================================================================== <BlizzardError.HashBlock:> SIGABRT ================================================================================ 0 0x0000000000000000 <:BlizzardError.HashBlock> ==================================================================================================== DBG-OPTIONS<Inline> ---------------------------------------- Manual Stack Trace (ID:0 Stack:0x0000000000000000 + 0) ---------------------------------------- 0 0x0000000000000000 # Truncated for character limit Any help much appreciated! I've tried reinstalling and repairing with no joy. I've disabled anti-virus (CyLance) for testing and no change.Ash0 Jan 28
Jan 27 Marauder Keyboard no custom lights I have the Marauder Keyboard and the Razer software that lets you customize the display LED's and I've noticed since I updated to Mojave that it no longer works the way it used to - the software won't acknowledge the keyboard exists. Does anybody have any idea why? I've had to response from Razer, there is no update to the software, and Google only seems to know of people with mouse issues.SoulPosessed0 Jan 27
Jan 26 Editor crashing when resizing window Good evening, On all three of my OS X devices, the StarCraft II Editor crashes when I try to make the train editor window larger by clicking and dragging in the lower right hand corner. First, the train editor window becomes black, and the cursor becomes the spinning beachball rainbow. Then, Mac OS X appends "(not responding)" after the application name in the activity monitor. Finally, switching to another application and then cmd + tabbing back to the editor has no effect. The application fully hangs and must be force quit/restarted. The editor also becomes fully unresponsive and crashes if you click the green "full screen" circle button in the upper left hand corner of the editor's train editor window. This is constant across three different Mac systems so I figured I would report it here so we could maybe get this fixed. I would love to work with the train editor in full screen. Tested and crashing on: MacBook Pro Retina display 15 inch running OS X v 10.11 editor v4.1.4 MacBook Air 11 inch running OS X v10.13.13 editor v4.1.4 and a Hackintosh w/ Nvidia 1080ti running OS X v10.13.13 editor v4.2.0 It would be really nice to work on a full screen map editor on Mac... Thank you for reading! MatthewStrategySix12 Jan 26
Jan 25 Mouse sensitivity periodically drops I've been having an issue since recent SC2 updates wherein my mouse sensitivity periodically gets reduced, resulting in an extremely sluggish cursor. I launch the game fine, my mouse sensitivity is normal in menus. I enter a loading screen, mouse sensitivity still normal. As soon as the game starts, sensitivity will plummet such that moving the cursor from one side of my command center to the other requires more than one full traverse of my mousepad, whereas normally I'd need to move only half an inch. I've noticed that mouse sensitivity can be temporarily restored be tabbing out of Starcraft and back in. However, after a bit of time passes (a few seconds to a few minutes) the sensitivity will again plummet without warning or any apparent trigger. After reading other threads about mouse issues, my experiments running in Windowed-mode proper also seem to resolve the sensitivity problem, but as others have noted I then run into problems with cursor containment and (of course) I'm no longer playing the game in a desirable manner. Similarly, I have attempted the solutions found in the other mouse-issue threads, such as ensuring that SC2 is enabled under System Prefs > Security & Privacy > Accessibility, up to and including removing the SC2 entry in that location and re-enabling it. I even tried disabling OS keyboard shortcuts as one poster suggested. I have not been foolish enough to forget to unlock the preferences in the corner. Furthermore, my OS is freshly installed on a blank drive as of just two days ago, and thus naturally SC2 is also freshly installed. I am playing in "Full Screen - Windowed". MacOS 10.13.6 Logitech G600 gaming mouse (I am NOT mistakenly hitting the button to change profiles), and results are the same independent of the Logitech Gaming Software being installed or not (I've wiped my drive and reinstalled a few times over the last few weeks, issue is always present). [Edit] Also, intermittently when experiencing reduced sensitivity, the cursor will display a distinct preference for moving up and left, with reasonable sensitivity, but have near-zero sensitivity for moving down and right. [/edit]UEAdmiral0 Jan 25
Jan 26 PLEASE fix the SC2 Galaxy Editor for Mac?!? Everytime I try to resize the window it crashes. And that's just ONE of the many other bugs that apparently have been plauge the SC2 Editor for YEARS. This is unacceptable Blizzard!Durzan1 Jan 26
Jan 8 Drop in War Chest Menu FPS (since 1st) Continuation of issue, as per Blizzard Support Rep's instructions to repost it - Issue: This issue has been ongoing since the start of the first War Chest. >> The issue has already been confirmed by a Blue post. ... Videos of the Lag can be found here: War Chest 2 - War Chest 3 - Basic troubleshooting to isolate the issue: - SC2 is the only app running. - All software / OS updates have been completed. - I am running on the lowest graphic settings all my settings are at the lowest. - Every other menu is okay except for the War Chest menu, which even causes the lag to appear if I were to open another app / window (e.g. a browser) as long as the War Chest menu is selected. If I do not select the War Chest menu (e.g. I select the Versus menu), it will be fine. - Prior to War Chest being released, I never had such an issue with SC2. - I have confirmed that it has nothing to do with the loading of sprites (as seen in War Chest 3 video above... even if the sprites are loaded but hidden... I have tried loading the sprites before checking on the lag, the drop in FPS is still there...). - I have tried reinstalling the entire Battle.Net app and SC2 (which should presumable fix any corrupted files). I really do hope to get some updates regarding this issue, especially since it has been a long standing issue confirmed by a Blue post, and also that it is something that involves cash. :) Thanks in advance.Kyrie0 Jan 8
Jan 7 Initialisation errors I'm not able to launch any campaigns 1 v1 or team games. I've seen windows fixes, any Mac fixes?Terranse0 Jan 7
Jan 1 Mouse freeze SCII Mouse freeze SCII v4.8.0.71061 MAC OS v10.14.2 Mouse icon doesn't move I tried with trackpad and external mouse Help Please!!!IronBlade2 Jan 1
Jan 1 Starcraft II won't launch on MacOS Mojave Hi all. I'm running my SC2 on MacBook Air OS Mojave. Couple of weeks ago, during the loading of a game I tried to go to my desktop by pressing the "command"+"M" button, which worked. However, since then the game wouldn't launch, no matter if I uninstalled it and reinstalled it. When I click on "play", the game would seem like it's running and after about 10 seconds it shows on the dock that the application is not responding. I'm not 100% sure that it's called by me quitting to my desktop using the command + M button but I suspect that's the cause. Anyone can help? Greatly appreciated. ShingoukiexShingoukiex1 Jan 1
Dec 30 Mouse Jitters Like Crazy Mac OS Mojave Hi all, I've been having a really annoying problem lately. My mouse will frequently become nearly unresponsive. When I try to move it around (particularly in the menus) it just jitters around in one spot. Sometimes it will work, but moves VERY slowly. This only happens in SC2, and happens with every mouse I've tried. Frustratingly, I threw away one mouse, thinking it was the problem. I've seen a few threads from 2017 reporting this issue in High Sierra, but none of the steps recommended fixed my problem. Anyone else having trouble with that anymore? Any word on an official fix from Blizzard?bobthunicorn5 Dec 30
Dec 25 Mouse pointer does not move in game? I tried to play sc2 after a long time today but my mouse is not working. It works fine outside the game and also in broodwar but not in sc2. i can click stuff and access menus, it is just the pointer that doesn't work. I'm running the latest software update both for the game and for my mac. any ideas why this is so? (yes i have tries rebooting the computer, game and battlenet app) thx and happy holidaysPiO1 Dec 25
Dec 23 Sound and graphics ok the issue with my graphics is minor but for some reason when i change the settings to be as low as possible, when i restart the game, it goes back to the highest setting. i want my game graphics to stop going back to default but it does stay low so long as i dont hit "restart now". now my issue with my sound it i want all my sound to be higher than 9% but when i change it, it goes back to 9% i need master volume at a higher setting.sajj1 Dec 23
Dec 23 Metal API (beta) When is Blizzard going to finish the Metal API beta for Macs, also is the final version going to be similar to the beta or maybe a bump in performance?VoidSham2 Dec 23
Dec 23 Running HOTS puts display/mac to sleep I played WOL about a month ago (the free version) and liked it, no real issues there, so I purchased the battle chest, but HOTS will continually just put my iMac to sleep. First it was happening during the opening cinematic, which i skipped (still haven't seen it in full). It played the bit where Raynor goes to the research station fine... but then the crash issue happens again once it loads up the HUD with kerrigan. I have checked to see if all is up to date and seems so, but the game is completely unplayable at the moment.llirik2 Dec 23
Dec 22 Mac OSX after update to SC 4.8.0 and mouse cursor won't move I'm on Mac OSX Mojave 10.14.2 and updated to SC II 4.8.0 on 12/21/18 Mouse control works normally outside of the game, but after launching SC II, mouse cursor stays stuck at the bottom of the screen and won't movemisterdood3 Dec 22
Dec 20 Drop in War Chest Menu FPS Continuation of issue, as per Blizzard Support Rep's instructions to repost it - Issue: This issue has been ongoing since the start of the first War Chest. >> The issue has already been confirmed by a Blue post. ... Videos of the Lag can be found here: War Chest 2 - War Chest 3 - Basic troubleshooting to isolate the issue: - SC2 is the only app running. - All software / OS updates have been completed. - I am running on the lowest graphic settings all my settings are at the lowest. - Every other menu is okay except for the War Chest menu, which even causes the lag to appear if I were to open another app / window (e.g. a browser) as long as the War Chest menu is selected. If I do not select the War Chest menu (e.g. I select the Versus menu), it will be fine. - Prior to War Chest being released, I never had such an issue with SC2. - I have confirmed that it has nothing to do with the loading of sprites (as seen in War Chest 3 video above... even if the sprites are loaded but hidden... I have tried loading the sprites before checking on the lag, the drop in FPS is still there...). - I have tried reinstalling the entire Battle.Net app and SC2 (which should presumable fix any corrupted files). I really do hope to get some updates regarding this issue, especially since it has been a long standing issue confirmed by a Blue post, and also that it is something that involves cash. :) Thanks in advance.Kyrie3 Dec 20
Dec 16 My mouse cursor does not work inside SC Hello, my mouse cursor does not move when im in sc. im using a Imac and is the first time this happens to me. plese help :DEliteXnoss6 Dec 16
Dec 7 I can't type anything I was playing a round of special forces elite 4, in which I make hotkeys for several things like units, I went to make a new hotkey and all of the sudden they all disappeared and when I left clicked it would ping instead of selecting, and when I pressed enter to type a message it would give me a message in chat that said I can't toggle the mode while in fullscreen, well I looked it up and other forums said to press alt so I did and that fixed those problems, however now when I press escape, it takes me to the Windows screen as if I pressed the Windows button, also I press enter to type a message and it comes up with the message bar like normal, but when I try to type nothing happens the only key it lets me type is the spacebar, both of these latter issues are the same when I'm just on the main Starcraft 2 screenBigMac0 Dec 7
Dec 5 Mouse issue after drag scroll on High Sierra I've made the initial post here but since most of the posts were related to vsync or mouse lag issue, I think mine is slightly different. My mouse doesn't track on the down + right direction anymore after drag scrolling with middle mouse button. All small & fine movements are not registered. Only restarting will fix this until the next time it's triggerred. I'm on High Sierra 10.13.1PureXtreme11 Dec 5
Nov 28 Insufficient Disk Space... Sierra & LotV Hi, My available disk space reads at 46.81 GB on my main hard drive. Blizzard client tells me that 30 GB is required for installation of SC2... client also tells me I have insufficient space on my disk to install, besides system info telling me different. Help?foolmanchoo4 Nov 28
Nov 23 Trackball doesn't respond in full screen. For days now my trackball won't respond in full screen mode. It only works after exiting full screen via command+M. Anyone else experiencing this?terranet1 Nov 23
Nov 23 SC2 goes to black screen once game is found SC2 goes to black screen once game is found. It does not load the map screen, it goes to a black screen where only the mouse cursor can be seen. Is this something to do with screen resolution? If so, how can it be fixed? It happens about 1 in 5 games, though it is impossible to predict when it will happen. I've tried different monitors. Running OS 10.11.6TinyTina1 Nov 23
Nov 17 Cannot update to 4.7.0 on MacOS My current version is 4.6.2. SC2 cannot auto-update to 4.7.0. Even I manually checked for update. It told me I have updated game. However, when I tried to launch the game, it told me the version is incorrect. I have run check and repair but it doesn't work. Anyone has any idea how to deal with this problem? Thanks in advance!LakeCarrot1 Nov 17
Nov 16 Mouse trouble since High Sierra Updated to MacOS 10.13 High Sierra and getting major mouse issues in game. The curser tracking is off, tracks normally for a moment, then curser speed drops suddenly. It’s quite erratic and makes competitive play impossible (my poor MMR :( ) Enabling “reduce mouse lag” seems to help, but my FPS drops from 60 to 20-30 which also impacts negatively on competitive play. I tried dropping graphics settings quite a bit lower but still can’t get the frame rate back up. Anyone else experiencing similar? I’m using a 2012 iMac 27” with nvidia GTX 680MX and a Logitech g303 mouse. Setup worked perfectly before the update.zidan69 Nov 16
Nov 16 Mouse problems Mac Mouse problems Mac. Hi All- My mouse works fine during the game except when I use my keyboard. If I am using the keyboard for a comand my mouse starts getting jumpy. Has anyone else had this problem? ThanksHellrazorX5 Nov 16
Nov 16 Mouse stuck in SC2 home screen Hello, I play SC2 on my MacBook Pro 15' running Mac OS Mojave. I was playing a few weeks ago and it ran like a dream. I just updated to the latest patch and now whenever I launch the game the mouse is just stuck. Won't move with my trackpad, wont move with my bluetooth mouse. If I hit escape the menu comes up and if i hit it again the menu goes away, so its not frozen. How can I fix this? It is very frustrating.EPICMOUSE11 Nov 16
Nov 15 V sync issue (again) Hi, I've just upgraded my macOS to High Sierra GM (EDIT: now to official macOS High Sierra 10.13 17A365) and old issue with V sync came back. Usually I have around 160-180 fps. Now it's 58-59fps. Last time we've all waited for a new patch because problem appeared after a new SC2 patch. Now it's caused by new macOS version. I found some "solution". I need to go to Menu->Options->Graphic and tick V sync ON, then back to game, then (again) go to Options and tick V sync OFF. This is the only way to unblock my regular FPS. And I have to do it in every game. Always first ON then OFF. macOS High Sierra 10.13 17A365 Macbook Pro 15-inch (mid 2012) Intel Core i7 2,3 Ghz 16 GB 1600 Mhz DDR3 RAM NVIDIA GeForce GT 650M + Intel HD Graphics 4000 1536 MBKJP18 Nov 15
Nov 13 Frozen Mouse Frozen Mouse: So idk how to explain this but I will try as best I can. Ever since this new patch came out I have had a problem with my mouse and it being frozen on the (campaign, co-op, etc) selection screen. It's a bluetooth mouse. I have unplugged the adapter from the computer, turned it on and off. My mouse works just fine with anything on my computer. I even uninstalled and re installed the game completely. Can someone please hell me out here or point me in the right direction on how to fix this odd problem!!! Thank you.Brock22 Nov 13
Nov 13 SC2 on the new iMac Pro Will SC2 become unplayable?MOTHER2 Nov 13
Nov 8 SC2 problem after wake laptop from sleep I noticed that my laptop, HP Omen, gtx 1050ti, usually have a 170 fps while playing the starcraft 2 at the high quality frame. If my laptop when to sleep mode, and after I wake the computer, the starcraft 2 is going to stuck and locked at 60 fps. If you restart the laptop again, it will go back to 170 fps. Only happenes to starcraft2, dota2, gta5, cs:go, other games dont have this issue.kkiiiokk0 Nov 8
Nov 8 Game won't install. Been trying to re install the game. But its stuck at Fetching CDN configuration. Has anyone else have this issue?HulkCrash10 Nov 8
Nov 7 Less than 40 FPS on latest MacBook Pro 15'' I just got a fancy MacBook Pro 15'' with i7 and a Radeon Pro 555 and I found to my surprise that in game the FPS don't go above 40 with EVERYTHING LOW, it even drops below 20 some times. I think there must be something going on in StarCraft II. Is this known? Any ETA where this would work? I guess my best solution is to boot to Windows? Thanks!ReoS4 Nov 7
Nov 7 Installation Loop I have re-installed sc2 by - airdropping working sc2 files to this MacBook air - Downloaded new app and hit the install button. - Hit the uninstall button the app then hit the install button. -I have tried deleting the blizzard files in the shared user files. -I have tried deleting all files related to sc2. -I have tried deleting the cache. -I tried 5 times to contact support and obtain a ticket but it conveniently says " there was an error on our end please try again." They all have failed to work and I'm about to conclude that sc2 can no longer be installed on MacBook Air 13-inch 2017 model. The error that keeps appearing is, Unable to run StarCraft II. Required files are missing. Please re-install StarCraft II.Hapicat1 Nov 7
Nov 7 SC2 not launching correctly on Mac OS X I've got OSX High Sierra (10.13). SC2 was working fine a few days ago. Today I can't launch it for some reason. When I press the "Play" button in the app, SC2 appears in the dock at the bottom of the screen, as well as in Cmd+Tab list of apps, but there is no windowed or fullscreen SC2 UI that appears. I've tried clearing cache files under /Users/Shared/ and /User/MyName/ That didn't change anything.ChronoCube5 Nov 7
Nov 4 Mac users - just use Bootcamp Dear Mac Users, After experiencing ongoing performance issues in SC2 for literally years on OS X, I finally bit the bullet and now play under Windows in bootcamp. I play on a MacBook Pro 13 inch 2011 with an integrated graphics card. I now get 30 - 40 FPS on low settings (all I need) with no drops during big battles. The game is super smooth and I’m enjoying MUCH improved mouse control. (Even with mouse acceleration disabled there is some weird input lag or filtering going on in OS X). I feel like I can finally relax into the game and my APM and play has improved a lot at the diamond/master level. No more shall I experience the endless mouse stutter/lag, vsync issues, and FPS drops that have dogged my enjoyment of this game for so long!! This includes a recent patch which rendered the game unplayable on OS X for some time. Whether or not the issues are with OS X or the Mac client is not my concern. As a bonus my razer peripherals don’t break every synapse patch too. Bootcamp setup was painless and it took me around an hour to get my first game up and running. If you care about your in-game execution then please do yourself a favour and try it out! You’ll need at least an 80gig partition for Windows and SC2, don’t skimp on less than that as Windows uses a paging file that requires some free disk space. I hope this friendly advice is of use to my Mac buddies!orlandus4 Nov 4
Nov 1 Drag Scroll Bug In Windowed Mode Since patch 3.6 there's a bug with drag scrolling in windowed mode. When you let go of the middle mouse button, your mouse cursor re-appears vertically offset from its starting position — higher if the window is closer to the bottom edge of the screen, lower if the window is closer to the top edge. Depending on the size of the window and the positioning on the screen, the mouse cursor can appear outside of the SC2 window, causing the camera to scroll undesirably. Video: It's particularly problematic when testing maps from the editor. System: Mac OS X (10.9.5) Screen resolution: 1920 x 1200 Window size: 1024 x 790hawk4 Nov 1
Oct 30 cant find my published custom map ive been working with the editor for the first time and put together a little map and i published it but cant find it anywhere in the game how do i play it besides just doing the test document?Billy0 Oct 30
Oct 30 Cursor moves/disappears when drag-scrolling With Patch 3.6, the cursor doesn't stay in its place when the scroll-wheel-button for drag-scrolling is clicked. When I click and immediately release the scroll wheel button on the 3D world (terrain, units, or buildings), the cursor reappears closer to the top-left corner of the screen. Both the new X and Y positions appear to be about 2/3 of their original values. Repeated clicking will move the cursor closer to the top-left in smaller and smaller increments. This behavior also occurs during actual drag-scrolling. The 3D world scrolls as expected, but the mouse cursor reappears closer to the top-left of the screen. If the cursor started out very close to the top-left of the screen, it will sometimes remain invisible after the scroll-wheel-button is released. I can still use the mouse to select units and buildings, or even click the command card, but the cursor is invisible. The cursor will only reappear if I move the mouse and then middle-click on the 3D world. When the cursor is invisible, drag-scrolling can sometimes result in abrupt, unexpected changes in camera location. This latter behavior is intermittent and difficult to reproduce. The above behavior occurs in both Fullscreen and Windowed-Fullscreen. In Windowed mode, the mouse cursor moves vertically (not diagonally) when the scroll-wheel-button is clicked. Sometimes it moves up, sometimes it moves down. Tested in-game on Versus A.I. and Ranked, drag scroll speed at 65%, inverted. Observed with mouse scroll and mouse sensitivity turned both on and off. Observed with Logitech MX500, G400s and G5 mice. MacBook Pro (15-inch, Late 2011) 2.5 GHz Intel Core i7 8 GB 1600 MHz DDR3 Mac OS X Yosemite (10.10.5) Thanks! Hope someone can figure out this bug soon.Philip7 Oct 30
Oct 24 Is a 64-bit version coming? On launch the program produces the "not optimized for your Mac" in High Sierra 10.13.6 meaning that when the MacOS stops supporting 32-bit (likely 10.15 as 10.14.x is supposed to still support it) the program will not run. Any plans to update it for MacOS or come 10.15 are we SoL?Maximara6 Oct 24
Oct 22 Black screening on custom map I'm playing Nexus Wars One Lane and near the end of the game when there are lots of units on the map, the game sometimes will end up black screening and freezing, but the sound is still there. After waiting like at least 30 seconds, I regain control of the game and it will all happen again if I have my screen is scrolled to the big mass of units. I set my render engine to Metal(beta) since OpenGL is very laggy. Playing on iMac 2017 base modelwww1 Oct 22
Oct 9 SC2 crushes on macOS 10.14.1 Beta (18B50c) hi, since I updated macOS to the newest beta version 10.14.1 Beta (18B50c), SC2 doesn't start. is OK, but 1 sec after clicking "PLAY", SC2 crushes macbook pro 15 (mid 2012) 2,3 GHz i7 16 GB RAM NVIDIA GeForce GT 650M 512 MB Process: SC2 [1980] Path: /Applications/StarCraft II/*/ Identifier: com.blizzard.starcraft2 Version: 4.6.1 [68195] (68195) Code Type: X86-64 (Native) Parent Process: ??? [1] Responsible: SC2 [1980] User ID: 501 Date/Time: 2018-10-04 11:00:05.940 +0200 OS Version: Mac OS X 10.14.1 (18B50c) Report Version: 12KJP11 Oct 9
Oct 7 Crash Upon Opening So, I recently re-downloaded SC2 on my Mac Laptop which is running Mac OS Sierra version 10.12.6. Every time I try to open SC2, I get a crash screen that says: "SC2 quit unexpectedly. Click Reopen to open the application again. Click Report to see more detailed information and send a report to Apple." I have sent a few reports to Apple, and have also tried to Scan and Repair my SC2 files from the menu screen, but I am still having this problem every single time I try to run it, and am unable to open the program. Any tips/tricks/pointers? I would really appreciate some help, since I am so excited to play this game again!Aumaya5 Oct 7