Mac Technical Support

Nov 19, 2010 patch 1.1.3 Okay lately when I try to play Starcraft 2 the downloader trys to redownload patch 1.1.3 and this cycle continues. Is there any solution at all to this or do I have to do an OS reinstall ? If I have to do an OS reinstall I doubt I'll continue to play Blizzard games. This is a bit ridiculous if you ask me.bigfah1 Nov 19, 2010
Nov 19, 2010 Battlenet Menu LAG Ever since the new patch the menu takes forever to load up my account information. Sometimes it takes forever to log me in, other times it takes forever to load up all my achievement information and match history ladder etc. Dont know what to do and would like to know if anyone else is having the same problem.Slater2 Nov 19, 2010
Nov 18, 2010 Digital Downloader Does Not Work On Mac when i do a digital download it opens up to the downloader but the bar doesnt move and it stays at 0.00 bytes of 6.99 gb. im using a comp that has Mac OS X 10.5.8. Anybody know the Solution? Firewall is set to allow all incoming conections. thats all it says in info. DSMarine16 Nov 18, 2010
Nov 17, 2010 Strange Disconnect Problem Strange problem I'm having with battle.net. I've power cycled my router, tried port forwarding, etc. Cannot figure it out! Essentially, during a multiplayer game, the net connection starts out fine. Then, 2-3 minutes in, the connection is dropped, then reset, and then dropped by battle.net. Any help would be greatly appreciated! Starcraft is the only application this happens to. This issue began happening post patch 1.1.3. It's so epically weird, I did a screen capture vid (it's fast, about 1minute+) and demonstrates the issue. http://www.youtube.com/watch?v=jjEcp6C0Yjw Thanks!!Reginald1 Nov 17, 2010
Nov 17, 2010 Constant skip lag after patch I have a macbook pro and up till this patch i had been playing just fine on low settings, but after the patch i now lag every 3 - 5 seconds on battle.net games and by lag i mean the game basically freezes for half a second and it makes decent micro or macro impossible. I tried playing offline as a guest against the computer and it ran fine (like it did before the patch) and so did the campaign so its just a battle.net problem. what do???Enjoi3 Nov 17, 2010
Nov 17, 2010 ATI 5870 card finally available for shipping So... Anyone else gonna take the chance? I sure hope this resolves my sudden fps drops after games (drops down to 12-1 which is ridiculous on an 8 core mac) And maybe I'll finally be able to play on high settings. (currently on very low)verklighet3 Nov 17, 2010
Nov 16, 2010 Blocked from Online play When i tried to play online after just loading sc2 onto my mac (the game worked fine on my pc) it will no longer allow me to play online, saying "error reaching other player". HELP!!! Thanks in advance. EDIT: For get it, I tried sending a post to blizz, looked for 1 hour to find the necessary information, and just before i sent the request for help, the stupid mac backed me out of the screen, I am done with this stupid computer.Fabio0 Nov 16, 2010
Nov 16, 2010 10.6.5 results So, I was playing a little around different worlds which I noticed before a big performance hit, like smash and grab mission, dunno why but thats one of the missions that performs the worst about 15 fps. I have an iMac 27'' i7 2010, with 5750 ATI Graphics gard. The verdict... I saw a 3-5 fps overall improvement with the old same settings (following Frost guide) prior the update, modifying the settings to something higher, send back to hell the fps. My question is, does 3-5 fps is really an improvement? I was expecting something like 10-15 fps, so if in that mission I was getting 22 fps, I would be really happy if I would have got 30-35. SO I think I have the answer to get better FPS.. I shall get a Windows computer and get over with this nightmare.. thanks Blizzard thanks Apple, I had my hopes on you both, now who is gonna blame who? GustavPicora16 Nov 16, 2010
Nov 16, 2010 profile not updating? I have been playing starcraft for a while and ingame it shows my updated rankings and stuff but when I look at my profile on the SC website it shows that I have done nothing? How do i fix this problem?Travman0 Nov 16, 2010
Nov 16, 2010 .tga and .dds files unable to import on GE Nuff said - heard this was a mac specific issue, is that the case? Editor see's the files when I try to import, but does not recognize them as editor documents in the least. I see that several others have mentioned this on the web but have been unable to find a solution... any ideas?Malpheus0 Nov 16, 2010
Nov 15, 2010 kernal panicking.... just bought the game and was playing through some of the campaign and i'm on the first missions ("Outbreak") and my computer keeps crashing...here's the report, I hope someone can decipher this for me QQ lemme know if there's any additional info you need =\ ...alpha16 Nov 15, 2010
Nov 14, 2010 Not showing correct single player results In the single player mission archives it is showing that I have completed 16/26 when I've completed 22/26. It is showing that I have not completed many of those 16 on hard or normal although I have. Logged in earlier today and everything was correct. Now the information seems to be old, although my achievements are correct. Also, when I leave the mission archives to the bridge where Horner and Raynor are standing there are large black circles where the characters should be. Not sure what this is or how to fix it. Thanks in advance for any suggestions.Tom4 Nov 14, 2010
Nov 14, 2010 Sound issues. Exactly what it says in the title. After starting SC2 today, the sound does not work at all for some reason. I did reboot my computer, before anyone asks. I am running SC2 on a older iMac, purchased in '08, and everything has worked fine up until now. I can play it on other computers, but it runs best on this one. Anyone have any tips on what I can do?skork1 Nov 14, 2010
Nov 14, 2010 performance in 10.6.5 For those of you who have updated, how has starcraft been performing (FPS, etc)? For me, I have a Mid 2010 15" i5 Macbook Pro with 256MB nVidia GT330M Graphics Card. Since updating to 10.6.5 I have finally been able to return to these settings and have Starcraft be playable: ----- Texture Quality: High Graphics Quality: Custom Shaders: Medium Lighting: Low Shadows: High Terrain: High Reflections: On Effects: High Post-Processing: Medium Physics: High Models: High Unit Portraits: 3D Movies: High Definition ----- However, if there is water on the map (like "Twilight Fortress") then my FPS can be as low as 20-30 if there is any water in my field of view. Lowering the "Terrain: High" setting improves FPS on these maps.goodDay3 Nov 14, 2010
Nov 14, 2010 Replays I have saved 4replays before from a friend of mine pre 1.1patch and am not able to find my replays folder yet... I have googled and found to go to HD>Users>Blizzard>starcraft II> etc. etc. etc. but when I get to the Starcraft folder still no dice....Winner3 Nov 14, 2010
Nov 14, 2010 Change the Camera Turn Left Hotkey. OS X does not have an insert key equivlent/fn command. The Camera Turn Left hokey should not require it. Derailed0 Nov 14, 2010
Nov 14, 2010 Custom map versions not updating Maps I've published are appearing with the correct version when I view them through Multiplayer, but not Versus A.I. The Versus AI version is at least 3 versions behind. What can I do to force the game to let me play my own map's latest version? PS: This entire mandatory-publishing system has caused me nothing but headaches. Can we please get a /Maps folder sometime?Entropy0 Nov 14, 2010
Nov 14, 2010 Not-so-scientific testing of 10.6.5 Ok so i wanted to see what difference if any there would be in my SC2 performance after the patch. I was running on 10.6.4 and a quick snapshot of my machine is this.. Mac Pro, 2.8Ghz Quad-Core Xeon 4Gb ram Nvidia GeForce 8800Gt Short Version of this post: The update was good. Didn't blow my mind but it was good and with what i've seen so far (related to this game) is worth getting. Long Version: I was only concerned with my FPS so i did a little detective work on it. Video settings were put on what Blizz deemed to be the Default for my machine. At 1680x1050 it put everything on high and turned reflections off. I tested my frame rates on 2 different maps with both the Zerg and the Toss since i figured they would need the most muscle from my machine with creep/pylons. The maps were Agria Valley and Lava Flow. I wrote down FPS at the start of the map and then i noticed a changing FPS as i moved the screen around and looked at different parts of the map. I could look at something in the fog of war on the screen, move away, come back to the original spot and the FPS would be the same as the first time i looked at it. Some parts on different map were more taxing then others. With the Toss every mac player knows that when you click on A pylon and the grid shows up it's like a punch in the kidney to your system (or at least it can be like that to mine). Agria Valley: Zerg- Starting FPS (as soon as the game starts, not moving any units): 49-52 Highest FPS while scanning the map: Found a spot where i got 76 FPS Lowest FPS: 44 Toss- Starting FPS: 53 Built 3 pylons and had all probes back to starting position: 45 Pylon Grid of 3 pylons being displayed: 27 High/Low FPS spots: pretty much the same (3-5) difference Lava Flow Zerg- Starting FPS (made sure starting spot had some portion of lava visible): 37 Highest: 60 Lowest 37 Toss- Starting FPS: 64 3 Pylons built but no grid showing: 64 Grid showing: 49 So these were the results BEFORE the patch. I tried it twice and got the same results both times within about 3-4 FPS (not-so-scientific [not about to run 20 tests]). I didn't want to run a bunch of tests now that i have the patch installed but i will say this. I went back to all the same maps with the same races and did the same thing with the toss that i did before and looked at the 2 different spots on both maps that gave me the higher and lower FPS like before. In EVERY case the FPS were higher. Sometimes by less then 5 FPS and some times more then 15 FPS. So the new update seems at least at this point to be working. The only thing im curious about is the video card driver. I don't know that much about computers but i know the update mentioned something about better graphics for games but once i updated it i got a message from the Nvidia CUDA thingy saying i needed to update my graphic card drivers. I did a google search for 10.6.5. CUDA and i know im not alone. Will the graphics get better/game get smoother once the CUDA thingy can update my card drivers? I hope so. So there you have it. My not-so-scientific test of the new update. I'd get it if i were you.McNuggets3 Nov 14, 2010
Nov 13, 2010 Patch 1.1.3 Locking System Just like the title implies, when I boot up SC2 to get the patch, the download will get to 75% (every time) and then the system will lock up. I have tried this with absolutely nothing running in the background as well as doing this off of a fresh install of the game and I run into the same issue. It has to be the patch cause before it was implemented today, I was playing the game with no problems this morning. I have a 24" iMac, 3.06 GHz Intel Core 2 Duo, 2 GB 800 MHz DDR2 SDRAM, NVIDIA GeForce 8800 GS with 512 MB. All of this on OSX 10.6.4 Shads3 Nov 13, 2010
Nov 13, 2010 Windowed Mode How do you confine the mouse when you are playing in windowed mode. Unfortunately the starcraft 2 in game option doesn't really work. It gets really annoying when your mouse cursor leaves the window. Emre5 Nov 13, 2010
Nov 13, 2010 Problems with b.net friends system In my friends list a while back, I had email friends (as opposed to character friends), facebook friends, and character friends. Just now when I checked my friends list in SC II, I only had the two character friends -- all of the other friends have simply disappeared. I went into my options screen and all of the options related to b.net friends and facebook friends were greyed out. When I went to try and re-add my friends, the options to add a facebook friend or add an email friend were greyed out as well. What is going on?! Please help.adamZero2 Nov 13, 2010
Nov 13, 2010 FPS question Ok when Sc2 first came out the files were split in to the applications folder and others were in the Documents folder. Back then i looked up how to limit my framerates and found the variable file in the Documents folder. I can't seem to find it for the life of me. I have my framerates capped at 30 right now and i want to undo that before i install the new update so i can see what i max out at then i'll install the update and see what (if any) changes there are in my fps. Can someone help me out here? How do you limit FPS on this game? I've done it and need to undo it. GratziMcNuggets2 Nov 13, 2010
Nov 13, 2010 10.6.5 is live! Yes, the update is live. - People with Nvidia systems running the 320m/330m should not run into the FPS slowdown that forces you to change your display mode. - The ATI R800 Black Terrain issue in the Editor should be fixed. - Overall performance should be a little better than 10.6.4 across SC2's supported GPU's. LolsoLolso10 Nov 13, 2010
Nov 13, 2010 10.6.5 Today? http://news.softpedia.com/news/Mac-OS-X-10-6-5-to-Arrive-Alongside-iTunes-10-1-Today-Report-165752.shtml I haven't been keeping up on this as much as everyone else. Is it going to fix things or at least improve SC2's performance with OSX?Wittman12 Nov 13, 2010
Nov 13, 2010 iMac 27" i7 Mid-2010 Kernel Panic Post 10.6.5 I've had two kernel panics since updating to 10.6.5 and playing SC2. By looking at the panic log, in both cases the crash was traced to the following: Kernel Extensions in backtrace (with dependencies): com.apple.ATIRadeonX3000(6.2.4)@0x601e5000->0x603f1fff dependency: com.apple.iokit.IOPCIFamily(2.6)@0x55da6000 dependency: com.apple.iokit.IONDRVSupport(2.2)@0x5f59f000 dependency: com.apple.iokit.IOGraphicsFamily(2.2)@0x5f5b4000 BSD process name corresponding to current thread: SC2 Both of these crashes happened while I was playing "Colonial Line Wars". I've played a few 2v2 matches and both times there was no crash. It may just be a coincidence, but I don't feel like risking it by playing more. Anyone else experience any crashes on ATi 5xxx series video card post 10.6.5?Arhida3 Nov 13, 2010
Nov 13, 2010 Update your OS to 10.6.4 with Graphics Update In reviewing the crash logs from our Mac users, we are noticing that many of you are encountering a crash that is resolved in the latest version of Mac OS X 10.6.4 (With Graphics Update). I would encourage anyone running 10.6.3 or 10.6.4 without the Graphics Update to update to the latest version of the Operating System by following the steps below: 1. Click on the Apple Menu in the upper left portion of your screen 2. Select Software Update 3. Click Install Padim2 Nov 13, 2010
Nov 12, 2010 Problem with Match Results I've been having this problem since starting multiplayer modes back in August. Regardless of whether I'm favored to win the match or not, in matches that I win, on the score screen it says 'You were favored'. Any idea on how to fix this? I'm losing out on a ton of points!BrettEvans1 Nov 12, 2010
Nov 12, 2010 Keyboard problem I have a macbook pro with an i7. I use my arrow keys to navigate and lately I've noticed that when I press my arrow keys, it will randomly try to change the rally of my buildings or hatching eggs. Its quite irritating. Ideas?Sin0 Nov 12, 2010
Nov 12, 2010 Macbook Pro 15" i7 - High Settings = Stutter I'm running a Macbook Pro 15" i7 Core 2.66 GHZ processor with 4GB RAM and 512MB Ram on the nVidia GeForce GT 330m video card. I have updated to 10.6.4 My framerate at best on the default high settings was 30 FPS, but often stuttered down to 3 FPS for a brief second and then back to normal, where it would then resume to take another dump. Finally I turned it down to Medium graphics settings, and my FPS is now around 50. The SC2 Performance Guide states that at High Settings for my particular Macbook Pro I should expect 50 FPS. I bought this five days ago, I have no antivirus or protection installed and running in the background. What gives? Why does the guide say I should expect 50 FPS on high, but I can't play it there because it stutters way too much? Do I have a defective Computer? Should I be taking this thing back?Blackthourne5 Nov 12, 2010
Nov 12, 2010 Uploading Replay to YouTube with Mac I have a replay I would like to upload to youtube, though Fraps is not available for Mac. What do other Mac users use to upload their replays? ThanksKratos3 Nov 12, 2010
Nov 11, 2010 Waiting for Server Problems While playing a custom map, although I haven't tried any other maps, I'm getting the Waiting for Server screen while playing Storm of the Imperial Sanctum. Before recent patch update I've been able to play this game with no problem, or no lag. Now when I play I get the server screen and noticeable lag. I've forwarded my ports on my router, and I still seem to have this problem. Any help would be appreciated, Thanks.leet0 Nov 11, 2010
Nov 11, 2010 Latest MBP performance with SC2? Hey everyone, I am in the market to get a new mac book pro and I was just wondering if anyone is playing SC2 on the latest MBPs and how is the performance? Can you play with all graphical settings on high without stutter? Im looking at the 15in, 2.66ghz, Intel i7 with NVIDIA GeForce GT 330m with 512mb Thanks!Romeo6 Nov 11, 2010
Nov 11, 2010 Renamed my replay folder; HELP i renamed it from the numbers it gave me and now i can't acess them. Any body know how to fix this please?Marcos3 Nov 11, 2010
Nov 11, 2010 Mac OS X 10.6.5 Likely Next Month http://www.macrumors.com/2010/10/22/apple-accelerates-mac-os-x-10-6-5-developer-seeds-with-build-10h562/ According to the article, the release of 10.6.5 will likely coincide with the release of iOS's 4.2 update next month. Shouldn't be too much longer now, just keeping tabs for those who are interested. =)Severin8 Nov 11, 2010
Nov 11, 2010 Trouble getting FPS counter to display I'm running 10.6.4 on a '09 MBP. Quite simply, when I press control-option-F, the framerate counter doesn't show up. Just nothing. I'm hoping it's just something stupid I don't realize I'm doing. Any ideas?Gelenn1 Nov 11, 2010
Nov 11, 2010 Tell me your 320m problems As I've probably stated more times in these forums than anyone needs to hear, I'm saving up for a 13" MacBook Pro. They currently have the NVIDIA GeForce 320m IGP/Chipset combo. I've been to the Apple Stores, SC2 disc in hand, and I've played it on many a 13" MacBook Pro and from beta to version 1.1.2, it plays smoothly. That said, I've heard rumblings of many an NVIDIA graphics problem with SC2 (as well as all of the Steam games). Have many, if any of you found this to be the case with the 320m machines?Yebubbleman4 Nov 11, 2010
Nov 11, 2010 LowShader30-80FPS MediumShader10-20 FPS?Help! I have no other problems in Starcraft II, but for some strange reason when on medium shaders my Frames Per Second Drop to around 12. Why is this? I have an imac from 2007 or 2008 (don't remember when i got it) running the latest version of Snow Leopard. I normally play on lower settings but i know my computer should be able to run on at least Medium Shaders. I normally get 45-75 FPS on Low Shaders when playing online, unless its a bigger battle or the game has more players. I did test playing on higher terran/texture settings (both High) and Game Models/Movies (both High) and it runs fine. It obviously lowered my FPS but It was Higher than the Results on Medium Shaders. I even put Medium Shaders on with every other setting on Low and it only ran at 30FPS max. Can someone please reply and tell me if its my Computer or something Starcraft and Mac.Masternorc10 Nov 11, 2010
Nov 10, 2010 Installer : no installer data could be found When I try to run the installer I've got from the downloader All I get is a window that says : No installer data could be found. If this problem persists, please contact Blizzard Technical Support. Anyone ever had this problem. Any known fixes? Thanks for any helpMazenmor2 Nov 10, 2010
Nov 10, 2010 Game Streaming From Mac Hi guys, I have been looking all over the internet for a solution to this problem but so far (after trying multiple things) I have not been able to comeup with a decent solution. I have a 27" iMac (from 2010) and I have been trying to set up a Livestream of my games. Unfortunately I haven't been able to come up with a set of software products that allow me to properly stream my games to a site like LiveStream or UStream / etc. Has anyone else that is running Snow Leopard been able to get their iMac / Mac to stream live game footage to the net? Any assistance / support would be appreciated. Thanks in advance, GeorenGeoren0 Nov 10, 2010
Nov 10, 2010 Patch 1.1.3 not downloading Hello The patch is not downloading. The downloader doesn't even open. The game starts and freezes at the login screen, presumably because it tried to connect to battle.net with a client version 1.1.2. I have an iMac 2.8 GHz, Intel Core 2 Duo with 4 GB 667 MHz DDR2 SDRAM with Mac OS X 10.6.4 MaxPower1 Nov 10, 2010
Nov 10, 2010 1.1.3 16939 issues?? I just installed patch 1.1.3 16939 Nov 9th. 2010. Now it says battle net can't recongize my client? Help please, thank you blizz<3Dante5 Nov 10, 2010
Nov 9, 2010 Trouble for Mac Users? Seems like every little patch/update/maintenance, I continually run into problems when re-connecting and it isnt solved for another day or so and its never immediate....does anyone else have these problems? I have a brand new fully upgraded Macbook Pro...id post this on the Mac forum but GO FIGURE..it's down. Ha!xNeMeSiSx2 Nov 9, 2010
Nov 9, 2010 Little Snitch and Patches After every path I have to tell Little Snitch to allow B.net connections and by now there are at least 10 different preferences for SC2 (1 for each patch). I doubt this is Blizzards fault and hopefully it just has to do with settings on Little Snitch that can easily be changed. *crosses fingers* Any suggestions? edit: I always set it to allow any connection and always, so it's not that...TitaniumGame0 Nov 9, 2010
Nov 9, 2010 Help! How to UNDO "report player" My son clicked "report player" on my name while my significant other was AFK. Now we can't form a party together. We bought the game to play *together*. When we contacted support, they emailed back: "Unfortunately, my department is not able to help with gameplay-related questions. However, detailed information on StarCraft II can be found on the official web page" Does anyone know who CAN help? Has anyone else had this problem? Endori2 Nov 9, 2010
Nov 9, 2010 New Macbook airs? The new macbook airs just came out, does anyone know if these can run SC2? Assuming you get the larger screen, 4gb or ram, and the 2.3 ghz processor upgrade, is this enough to run the game? The 320m graphics chip is claimed to be able to run medium settings in the stickies.Zao11 Nov 9, 2010
Nov 9, 2010 And Still NOTHING On The FPS ISSUE?? Why is there nothing new form Blizzard about this? This is absolutely infuriating. The game was Running FINE before patch 1.1 Now I am getting 13 FPS on the lowest settings on a machine that was running it beautifully on medium with some things on high. It might be working fine for some of you now, and that's great, but what about the rest of us? They shut the game down for maintenance and yet the game still wont run properly for many Mac users. WHAT GIVES? ViTeksR21 Nov 9, 2010
Nov 9, 2010 Starcraft 2 causing computer shutdown. I have a 21.5 inch iMac ATI 3.06 GHz Inter Core 2 Duo ATI Radeon HD 4670 I assume the issue is that the GPU is reaching the 85 C temp limit. When I boot up after a shutdown the GPU temp is usually somewhere around 80 C. I've tried putting a fan directly on the back but it seems to make no difference. The issue is seemingly getting worse. I can only play 1 game before the GPU temp is around 80 C. I've heard of Nvidia cards having issues but not ATI. All my internal fans are working as well. So I'm wondering if this is a SC2 issue or a iMac issue. Thanks.Broseidon1 Nov 9, 2010
Nov 9, 2010 ATI Radeon X1600 vs. ATI Radeon HD 2600 I've googled this topic a bit already, but I want to check and see if what I've found also correlates to StarCraft II; basically, the HD 2600 as experienced on the third and fourth Revs of Intel iMac is only slightly better than the X1600 as experienced on the first and second Revs of Intel iMac. In terms of StarCraft II performance, this would enable me to run on lowest settings with a higher frame-rate, but would not yield me enough of a performance boost to warrant upping any of my settings from low to medium. Is this correct? I have a Core Duo (not Core 2) Intel iMac at present. I'm toying with the idea of replacing it with one from two generations newer (for more RAM and Hard Drive expansion), hence the question. Obviously, this computer purchase doesn't have SCII in mind, though I am curious as to what benefit, if any, that I'd be getting performance-wise from that upgrade. I'm already planning on buying a 13" MacBook Pro and a PC that I'm going to build, both of which will beat the crap out of either iMac anyway.Yebubbleman7 Nov 9, 2010
Nov 9, 2010 Unable to get to the login form This just cropped up today. I tried a reboot, etc without any changes. Whenever I start SC2 I get a window that shows the planet and battle cruiser entering from the top right then zooming off around the planet. No log-on form ever displays though. I just have that small video looping every few minutes. I've tried multiple times both in full screen and windowed mode. ESC doesn't do anything. Has anyone experienced this and found a workaround/fix? I'm on a mac pro 10.6.4.Xim0 Nov 9, 2010
Nov 9, 2010 Client closes after start-up 'LOADING' screen Hey, just wondering if anyone else is having the same issue at the moment. It could be just due to the maintenance on the SEA servers but, my sc2 client crashes or closes straight after the 'LOADING' screen at start up finishes. It doesn't even allow me to input my password or select which region i want to play in. Note that the game was fine until I tried to switch to the SEA server (where I usually play in), as I was playing on the North American server last night. If the reason this is happening is because the SEA server is on maintenance, then its cool. It just bothers me at the moment because I cant switch back to the NA server and play. Any advice on how I should go about fixing this will be appreciated. Thanks in advance! (also, im playing on a fully updated Macbook Pro 2010 model) And yeah its my fault for overlooking the small banner about the maintenance, i was just in so much hurry to play some sc2 CAPS2 Nov 9, 2010