Mac Technical Support

Jan 5, 2016 Can't enter the game."An unexpected fatal err Hey, does any Mac users can not enter the game like me? I just purchased the Legacy of Void, and tried to enter the game. The screen turned black for just a second and back to my desktop, then it shows "An unexpected fatal error occurred." The report ID is 6C67A6E8-E396-4AA7-9BF7-55A39E43D5A6 It's pretty wired because same issue also happened on Heroes of the Storm on my Mac before. I am using a late 2013 MacBook Pro. Additionally, I tried to Resetting Game Folder & File Permissions and repairs tool, my OS software is up to date.Joelkira3 Jan 5, 2016
Jan 5, 2016 ISIS recruitment in game. Got a strange request from someone asking me to join ISIS. We are a military family, I'm not sure if this is a joke or this is a matter of national security. I don't know who the hell that is. Screenshot below for you professionals to figure out the situation. [IMG]http://i66.tinypic.com/v5fpl2.png[/IMG]Chris0 Jan 5, 2016
Jan 5, 2016 Can't enter the game."An unexpected fatal error occurred." Hey, does any Mac users can not enter the game like me? I just purchased the Legacy of Void, and tried to enter the game. The screen turned black for just a second and back to my desktop, then it shows "An unexpected fatal error occurred." The report ID is 6C67A6E8-E396-4AA7-9BF7-55A39E43D5A6 It's pretty wired because same issue also happened on Heroes of the Storm on my Mac before.Joelkira0 Jan 5, 2016
Jan 4, 2016 SC2Data directory using 132 GB+ Hi I have a macbook pro running El Capitan (10.11.2) and the StarCrafII/SC2Data/data directory is using 132.4 GB. Some of the data.xxx files are taking 1GB +. What are these files for? Could I delete them?Efrain1 Jan 4, 2016
Jan 3, 2016 LOTV Update Crashes Macbook Pro 2010 Its obvious. Its not the OS X. Only thing that has changed is the latest SC2 client update. Since then, Macbook Pro 2010 (Nvidia GT330M GPU) crashes - flash of white light, followed by restart. Machine runs other CPU/GPU demanding games like Sim City 4 Deluxe FINE. Other than SC2, doing anything else on the machine does NOT result in any other anomalous behaviour. Please fix or refund both versions of SC2 that I've already purchased if there is no fix?seven0 Jan 3, 2016
Jan 3, 2016 Dual monitor trouble HI I've read through past articles on this forum about possible fixes for the use of sc2 with dual monitors. I've tried all the recommended terminal prompts, with no success. Is there anything left for me to try? Even turning off my second monitor leaves side scrolling to the right (the side where my second monitor is located) broken in sc2 and heroes, my two favorite games.Enda1 Jan 3, 2016
Jan 3, 2016 Mac Sound Issues I currently use a mac, and a recent problem has happened with the new patch. When I am alt tabbed from game, sound continues to play. My Menu -> Options -> Sound -> Play in Background is unchecked, yet it continues to play in background.DarKLinG3 Jan 3, 2016
Jan 2, 2016 What's the Deal Blizzard? Mac Problems Ever since patch 3.0 when the new UI was implemented, I have been having so many problems with the game. It first started out where it would forget my log in info at log in screen and tell me I couldn't connect to bnet. It wasn't bad at first one restart of the game usually authenticated me in and it was fine. However as time went on that got worse and worse. It's to the point now where it literally takes me 30 minutes just to log in. Sometimes when I start up the game it has serious FPS issues, and the game is literally unplayable. So I restart and I get the FPS issue over and over until finally it starts up with no FPS issue and I can log in offline. Then when I log in using offline mode I have to wait about 30 minutes to an hour and then I can hit the log in button in the main menu which then prompts me to enter my password, allowing me online access. That has been going on for months now and as much as it pissed me off, I could deal with it until it's patched. However now I am also dealing with mouse issues, which I have read is due to the retina display of my mac. When I am in Fullscreen mode I can't even play the game because my mouse is unresponsive and it teleports and flies all over the screen. So the solution to this is to play in windowed mode with confine mouse cursor set to off. While yes this does work it creates a number of problems in itself. When I am in windowed mode with my mouse unconfined I constantly click on other stuff on my screen, either completely minimizing my game or causing the mouse to start operating outside of the game and on my desktop which makes me not able to do anything in game. It cause me to go outside of the window and and bugs the game to where I can't scroll in game unless I click on the window a few times. This has happened numerous times in important moments of games and it's really aggravating. I understand there will always be issues and unseen bugs in new systems and games, but this is absolutely ridiculous. This isn't just some small bug like the leave league bug. This is a premier game not working on one of the biggest platforms in the world. It makes me wonder if you even tested it before release. Blizzard please fix this because I know so many Mac users that are having the same problem. It has rendered one of my favorite games unplayable and it's unacceptable. If this isn't fixed soon a huge part of your customer base is going to be VERY unhappy.ICE0 Jan 2, 2016
Jan 1, 2016 LOTV: Campaign Freezing (MacOSX) As I am accessing the archives to go achievement hunting I ran into some issues. I was replaying Temple of Unification, selected the army customization, and when I select the immortals or sentries will freeze my whole computer.Stonecutter1 Jan 1, 2016
Jan 1, 2016 Mac Download Issues! (LOTV) Quote "Something went wrong with a file. Were not sure what caused it so please try agian or click on the code" and ive tried everything with the code im getting a headache from trying everything lol. the code is BLZBNTAGT00000840 Please i want this update doneAlakatraz2 Jan 1, 2016
Dec 29, 2015 OS X El Capitan vs Windows 10 Gaming Performa Testing Heroes of the Storm, Starcraft 2 and Diablo 3 to determent whats the best way to be played on Mac, El Capitan or Bootcamp Windows 10. All games are running under the same video settings, i used for both starcraft and heroes of the storm the same replay and tested the same part of it on both platforms. Since diablo 3 doesn't have replays the best way to replicated benchmark was just to do a quick Azmodan run. https://youtu.be/SrVVCOLSY2Achukolna0 Dec 29, 2015
Dec 29, 2015 Mouse lag and mouse reset Hi there —  This seems to be a new issue for me since LOTV. I am running Mac OS X (10.11.1) with a Razer DeathAdder mouse. I have been experiencing mouse lag. To best explain this, when I move my mouse to an intended place, the transition to that point is not fluid. Sometimes the timing is correct, but a lot of the time, it's not. This issue makes managing things like blink micro very difficult as selecting units doesn't always work. Additionally, when I quit Starcraft, my mouse settings seem to reset completely, requiring me completely reboot my machine. Outside of Starcraft , I have no problems with my mouse settings. This seems to be something completely specific to the game. To clarify, I have not altered my mouse settings at all in game via options. I have also tried deleting my cache directories to no avail. :(GliTcH2 Dec 29, 2015
Dec 28, 2015 Anyone At Blizz. Still Maintains The Editor? Is there any Mac programmer at Blizzard still maintaining the editor? It seems like the editor has been abandoned and all of the new features are probably being auto-generated from some code-porting system that Blizzard uses. There are so many UI bugs it's quite painful trying to take a decent map from start to finish. It seems no one at Blizzard actually uses, tests or fixes bugs for the Mac editor anymore. I guess it will suffer the same fate as its old predecessor.hawk0 Dec 28, 2015
Dec 28, 2015 [Bug]Can't Connect to Battle.net I've had this bug for the past month or so. (So I think 2 or 3 patches ago) But essentially, after starting Starcraft 2 from the Battle.net launcher, the game tells me that I cannot connect to Battle.net and asks me if I want to play offline. This happens probably 75% of the times I start the game. Usually I can click 'Cancel' and 'Login' again and after a few tries, I can get to a Password menu and after that I can get in. However, today after 10-15 minutes I still cannot connect to Battle.net. For context, I am playing on a Mac and also playing on the NA server from Korea. I have tried to connect to other servers as well to no success. My internet connection is also fine. Please fix this as I cannot play the game right now.Gyalgatine6 Dec 28, 2015
Dec 28, 2015 FPS drop a lot in Windowed (Fullscreen) mode Hey. The game is running normally in Fullscreen and Windowed modes, but drops FPS significantly in the Windowed (Fullscreen). Game version: latest LotV. The issue didn't occur in HoTs several months ago, at least before the latest updates. Graphics settings: Medium, normal FPS 20-40. Displays: I have an external Thunderbolt monitor, which is my main display, connected to the laptop. The game is running on the monitor. OS: El Capitan 10.11.2. Basic specifications are at http://imgur.com/pdAzgcY. FPS screenshots: http://imgur.com/a/a9HPK. The first image shows Windowed (Fullscreen) mode, the second shows Fullscreen mode, the third shows Windowed mode.Partisan3 Dec 28, 2015
Dec 28, 2015 No 64-bit Client for OSX? Hello, Patch 3.0.0 says that SC2 now supports 64-bit, but the option is not there in my Mac. There is no 64-bit client for Mac OS X? There is any estimative on when we will see this on mac? The game usually goes to the 3GB limit on my mac, seeing this implemented would be great.Blau7 Dec 28, 2015
Dec 27, 2015 bnet connect problem; cant even download game I can't even complete the game data download. I'm down to about 10GB to go. It's been extremely slow this far, and now it can't even connect. My network is fine, I was just streaming HD videos on youtube before trying this again. I'm on a Macbook Pro, Yosemite 10.10.5, 2.3 GHz Intel Core i7, 8 GB 1600 MHz DDR3 memory, graphics Intel Iris Pro 1536 MB. I've tried flushing DNS cache, everything else I can find in tech support articles. Any suggestions?briforge0 Dec 27, 2015
Dec 27, 2015 Attempting to Reconnect Hey there, I've been in an arcade game and I'm stuck at the infamous "Attempting to reconnect" issue. I never DCed from battle net and I can talk to my battle list friends just fine. How can I make sure this doesn't happen again?Liaka1 Dec 27, 2015
Dec 25, 2015 Can't install - BLZBNTAGT00000327 "We couldn't find data required to install this game. If this happens again, please try installing StarCraft II as a digital download on Battle.net. BLZBNTAGT00000327" I'm now around 5 days of being unable to play Starcraft. On my fully functional SC2 install (which I've been playing all year on this computer), Battle.net noticed an update and tried to automatically install it. The install failed. Battle.net changed the 'Play' button to 'Update'. Click the "update" button, it tries for awhile, then gives the error. Uninstall the game through the Battle.net UI. Reinstall the game through the b.net UI. Before it becomes playable, same error. Uninstall game through b.net. Verify that all the files are actually gone from /Application and user/Library/Application Support. Reboot. Attempt install. B.net throws same error. Uninstall SC2. Attempt reinstall. Same error. Uninstall SC2. Uninstall Battle.net Verify that all the files are actually gone from /Application and myuser/Library/Application Support for SC2 and B.net. Reboot. Attempt to install SC2 from the downloader, which really just installs b.net and automatically kicks off the SC2 install. Same error. WoW, Hearthstone, HotS, Diablo 3, Diablo 3 PTR and SC2 Beta can all be installed and updated just fine. (note: I've uninstalled / deleted / rebooted / verified disk / repaired permissions literally over a dozen times at this point. And this is a Mac, so no I don't have any broken Norton A/V getting in the way)TacticaT10 Dec 25, 2015
Dec 24, 2015 Macbook keyboard stops working in game Hi! Recently I've had this annoying problem in sc2 where in the middle of the game some keys on my keyboard just stop working for like 5-20 seconds and then returns to normal. The strange thing is that it only affects keys T, Y. U, I and O). This happens only when sc2 is open, not in normal use. This all didn't happen at all before latest patch and my mac upgrade to El Capitan. I am using mid 2012 13 inch Macbook Pro and it's built in keyboard and I play on EU server.Mirzo0 Dec 24, 2015
Dec 24, 2015 Saved map locations on Mac I'm looking to see if anyone may know a different location of the files. I'm trying to transfer the map locations to a mother mac, which I'm going to play offline on only, I know in the Shared users has a maps folder but on the machine I have internet on. I download the maps and I'm not seeing anything pop into or be added into it. Which tells me when I bring that folder over it won't play on the offline mac I'll be using. Goal: I want to use a Mac that has internet and download the maps so I can transfer them to an mac that will be in offline, not connected to the internet, to play the game since I'll have the maps.ZERGonCREEP0 Dec 24, 2015
Dec 23, 2015 Performance Issue on my Mac. new legacy of Void. Just bought the new Legacy of the Void and Dl it. Started working ok then all of a sudden it slowed down. I feel its related to the 32/64 bit issue. Can anyone help me. Specs below. Model Name: iMac Model Identifier: iMac15,1 Processor Name: Intel Core i5 Processor Speed: 3.5 GHz Number of Processors: 1 Total Number of Cores: 4 L2 Cache (per Core): 256 KB L3 Cache: 6 MB Memory: 8 GB AMD Radeon R9 M290X: Chipset Model: AMD Radeon R9 M290X Type: GPU Bus: PCIe PCIe Lane Width: x16 VRAM (Total): 2048 MB Vendor: ATI (0x1002) Device ID: 0x6810 Revision ID: 0x0000 ROM Revision: 113-C408A0-729 EFI Driver Version: 01.00.729 Displays: iMac: Display Type: Retina LCD Resolution: 5120 x 2880 Retina Retina: Yes Pixel Depth: 30-Bit Color (ARGB2101010) Main Display: Yes Mirror: Off Online: Yes Built-In: YestheProdigal0 Dec 23, 2015
Dec 23, 2015 32-bit client on a Mac Hi, Since there's still no fix for the performance issues that started with patch 3.0, I'd like to know if there's anyway to launch a 32-bit version of Starcraft 2 on a Mac. Thanks.makizmaidrug2 Dec 23, 2015
Dec 22, 2015 BLZBNTAGT00000BB8 and a whole host of other problems. I don't know where to begin: I've followed all the troubleshooting guides, I've reinstalled, etc. Scan and Repair not working, update game gives me BLZBNTAGT00000BB8, this is a 2014 macbook pro, there is nothing wrong with my computer. Before you ask,I've tried it, there must be a bug, and from what I'm seeing here, its screwing up on others computers too.Punisher7 Dec 22, 2015
Dec 19, 2015 More Metal stuff in the latest binary. ... Looks like it's well on its way. :D Forgot about this too: 0000000101c21708 0x0 _OBJC_CLASS_$_CAMetalLayerShadywack0 Dec 19, 2015
Dec 16, 2015 Can't quit SC2 without "Force quitting" Every time I quit SC2, the game crashes and gives me the "spinning beach ball of death". the ONLY way to get out of the game is to Force Quit it . . . . on a related note, I can't load ANY rated / unrated game . . . . I click the buttons to play, then it spins and spins and never loads the 1v1, 2v2, etc . . . options. Any advice, anyone????Sutton3 Dec 16, 2015
Dec 15, 2015 Multiple Mice going crazy with 3.0 This update causes my mouse to jerk and teleport around the screen like crazy on my MBP. Strangely enough, if I put the game into windowed mode it seemed to fix the problem. Something about the retina display? Also this update seems to randomly crash upon starting starcraft, as well as it crashed at a victory screen. All in all, kinda sad.zamzx24 Dec 15, 2015
Dec 12, 2015 Will not load Matchmaking HOTS will not load the matchmaking menus. I can load the training missions, but the "vs AI", "unranked" and "ranked" menus will not load. I click on them, and then I get the spinning progress wheel. Forever. I played the entire campaign, no problem, and I played matchmaking during the beta (except for when the beta didn't work on macs). Help? I didn't see this issue in any other posts. Running SC2 on OSX 10.7.5, on an older Mac Pro. 2 x 2.66 Dual-Core Xeon, 10GB ram, ATI Radeon X1900 XT.Danish36 Dec 12, 2015
Dec 9, 2015 Broken in-game models, audio and UI Date of capture: 26/11/2015 I originally posted this in the PC thread (I overlooked the MAC forum the first time). After starting the campaign of Legacy of the Void I've encountered issues regarding in-game models and UI elements not displaying right. Plus some audio issues. Here are the specs of my machine: Operative system: OS X Yosemite v10.10.5 Model: iMac (27 inch, Mid 2011). Processor: 3,1 GHz Intel Core i5. Memory: 4 GB 1333 MHz DDR3. Graphics: AMD Radeon HD 6970M 1024 MB I'm adding some screenshots showing the issues. 1. In-game models not showing properly (Plus a screen square in the mini-map): http://s20.postimg.org/9lygl1v25/game_models_issue.jpg 2. UI problems with the units. http://s20.postimg.org/75wn77czh/UI_issue.jpg 3. UI problems, teleport animation not showing well and blurred Character portrait. http://s20.postimg.org/ni6owxrb1/units_and_portraits_issue.jpg 4. Victory screen not showing properly. http://s20.postimg.org/gg8raqnp9/victory_screen.jpg Plus dialogue of characters doesn't work at all during missions (Sometimes). UPDATE Date of capture: 26/11/2015 After the first mission the issues disappeared ......... until the mission "Templars Return". All the other mission were fine until this point. 5. Templar's Return - UI and in-game models problems. http://s20.postimg.org/3n8pb33p9/Templar_s_Return_01.jpg 6. Templar's Return - UI and in-game models problems. http://s20.postimg.org/h5flndful/Templar_s_Return_02.jpgTheSpectator4 Dec 9, 2015
Dec 9, 2015 skipping issues during cinematics During cut scenes on the spear of adun, they are delayed or skip through. The first time I played the campaign it was fine, but I played the story over and now it is skipping through vital story scenes on the spear. Anyone having this issue?slick0 Dec 9, 2015
Dec 8, 2015 LOTV freezes upon start or quit LOTV freezed on black screen sometimes with sometimes without moving mouse cursor. Can't quit and have to restart the computer. I use 15" retina MBP late 2013 with nvidia. Tried to cmd+q and cmd+option+Esc to force quit but it doesn't work. The SC2 stays frozen until restart. Never happens on a freshly started launcher. But if the launcher has been resident for a few hours and days it almost always happens.llllllllllll2 Dec 8, 2015
Dec 8, 2015 [LotV] Freeze when Traveling to Ulnar Like the title says, I am playing through Legacy of the Void. I've finished all of the missions before traveling to Ulnar. Help would be welcome. The game usually freezes on the frames of the Spear traveling towards the rift. The video stops, and the audio continues until I suspect there is supposed to be a scene transition. After this transition is supposed to occur, the game freezes, including the mouse, everything. Pic below. http://imgur.com/Z3lATsP I've never had any trouble with SC2 at all before, and this has happened many times over the past few days. I can leave my computer on in this state for several hours, and it doesn't move an inch. - Graphics card drivers are up-to-date - I don't see this issue here on the forums (i just don't see it after a 10 minute search, doesn't mean it's not there) - Been using Avast, in all it's glory, for 5 years and never had any issues. - I am my own admin - Temp monitoring?? I don't think I can do...that... Specs: OSX Yosemite 10.10.5 MacBook Pro (mid 2009) - and I've read that El Cap is horrible for us older macbook users. Is this the issue? I hope its not the issue. - 2.26 GHz Intel Core 2 Duo - I have 8 GB of memory, and 76 GB free on my hard drive - NVIDIA GeForce 9400M 256 MBCorvus0 Dec 8, 2015
Dec 6, 2015 SC2using 90% of CPU during games 60% in menu HI, when I try to play Sc2 it hogs processing power. Not a computer whizz but I know SC2 shouldn't take 60% CPU usage in the menu screen. It's pretty much unplayable and has been for 8 months. EDIT: made a typoEnda0 Dec 6, 2015
Dec 5, 2015 Sudden Crashes in the campagain mode During the interlude, where you explore the Spear of Adun, there is this bug, where everytime I changed my units in the War Council, my game just suddenly crashes, like I can't switch between app and desktop, and to get my laptop working, I have to use the power button on my laptop to fully restart my laptop. The system I'm using is a Mac Book Pro using the latest operating system, which is the OS X El' Captain. My copy of the game is digital.I don't know if its only happen to me or Mac Users. So I'm asking if I'm the only who have this problem or its a problem that we can fix in the future.Maxdom6 Dec 5, 2015
Dec 4, 2015 Binding control to mouse button Hi everyone, I'm trying to bind my forward and backward buttons on my mouse to act as control and shift, so I can easily make control groups and add to them without breaking my left hand reaching down for the control button. I'm using logitech's software to remap the buttons, and it works on my desktop! However, when I try to make a control group in SC2 by holding forward (which has been remapped as control) and pressing 1, it doesn't work. I tried recreating the hotkey in the SC2 options, but it's only recognizing my input as control even though I'm technically holding control and pressing 1. Bit of info: I'm on OSX 10.9.2, using a logitech performance MX mouse tl:dr, I bound "control" to a mouse button, but SC2 does not recognize "control+1" or any other number if I try using this newly bound button. It only reads "control". Why!?!?! Are there any recommended keybinder programs out there for mac? thanks in advanceCptPuppet0 Dec 4, 2015
Dec 4, 2015 Can't launch the game I downloaded the game a few days go and was able to play the prologue missions. Then it froze between missions and I have not been able to log back in the game since. When I click on launch in the battleNet app, it either does nothing and the button switches back from «play» to «launch» or the screen switches to black with only the mouse arrow appearing. I then need to shut down the cpu to do anything else. I have a 2015 MacBook Pro and I recently installed El Capitan on it.Kubrick2 Dec 4, 2015
Dec 4, 2015 Insufficient Memory? I just got LotV and booted it up. Now Starcraft two is telling me I have insufficient memory to adjust my graphics quality. I have 12 GB of RAM and obviously a 64 bit OS as I'm running OSX. This was never problem before legacy of the void. Any advice?Magnus6 Dec 4, 2015
Dec 4, 2015 Game quit campaign when loading next mission Every time I try to load next mission the game suddenly quits campaign and goes to initial menu, then it is impossible to load anything again unless I restart the game. I've tried restart machine, re-installed battle.net nothing works. One thing that might be related is there is currently an update that can't finish download, it stops automatically showing erro BLZBNTAGT00000840, I've gone trough all the steps the support page suggests, didnt fix. Anyway the game status is optimal so should be working. Pls help (playing on mac)Felipe0 Dec 4, 2015
Dec 2, 2015 Hotkeys Crap Since Patch 3!!! Ever since Patch 3.0, my hotkeys are CRAP . . . . .I've played since SC1 was release, NEVER had this problem till now . . . . .they lose their settings, change, and or ALL empty . . . . often right in the middle of combat . . . .wtf!!!!!!!!!!! Anybody know what's going on or having this problem? The GAME IS UNPLAYABLE at Diamond level cause THEY DO NOT WORK!!!!!! HOTKEYS ALL STOPPED WORKING!!!!!!!!! Set them, they go away, reset them, they change . . . . .1 becomes 3, 2 becomes 5 and 6 through 10 are all GONEE!! WTF!!!!!!Sutton6 Dec 2, 2015
Dec 2, 2015 BLZBNTAGT00000327 11/29/15 Dear all, I tried installing Starcraft 2 on my Mac and I have followed the previous advice from this thread http://us.battle.net/sc2/en/forum/topic/17346427329 of deleting the shared user files of battle net and blizzard to no avail. the symptoms are at a certain point of installation the mac suddenly freezes and forces me to commit a hard reset in order to boot it back up again. Any help or advice on this matter?Estarrol1 Dec 2, 2015
Dec 1, 2015 LotV Campaign and Achievements Reset! The campaign reset with achievements along with all save files. Game was fine previously until sudden battlenet server shutdown at around 12pm (GMT +8). Any way to get the achievements and saves back? Running on MacBook Pro 2014 OS X Yosemite.Resvero1 Dec 1, 2015
Dec 1, 2015 Score screen not shown in LotV [OSX] Hello, score screen is randomly not shown after 1vs1 games. I checked my installation, it did not help. System: OSX 10.11 SC2 version: 3.0.5.39117ptarh0 Dec 1, 2015
Nov 30, 2015 [Bug] OS mouse tracking speed modified Quitting Starcraft appears to alter the Operating System's mouse tracking speed. Starcraft 3.0.3.38749 Mac OS 10.10.5 Using a Logitech M510 mouse Settings in starcraft: Mouse sensitivity slider at 50%, mouse sensitivity turned off. O.S. Settings: System Preferences / Mouse / Tracking Speed to 2 notches to the right of slow. Steps to reproduce: 1) Run starcraft via launcher 2) Quit starcraft 3) Mouse now tracks much faster than before, looking at System Preferences the tracking speed is now 6 notches to the right of slow. * This appears to happen when playing either full screen or windowed. * The tracking speed doesn't change until I quit starcraft (I checked System Preferences while SC was still running). * The tracking speed appears to be related to the position of the sensitivity slider. 100% on the slider results in max speed. 50% is 6 notches to the right. * The bug does't seem to happen during the session that I change the mouse sensitivity settings. It only happens when I start and quit SC without changing the settings. * The bug does not happen if mouse sensitivity is enabled in SC.Dave4 Nov 30, 2015
Nov 29, 2015 Assembly Panel in War Council chamber (crash) When I click the options in succession to see new available units the game sometimes crashes. I would go directly to a new available unit type, but there is no indication of which type has a new option. Selecting bottom to top in succession is what I am doing, but top to bottom may cause the crash as well. Only the mouse is curser is moveable. Clicks and keyboard input unresponsive. I am unable to leave full screen, and all I can do is force a shutdown. This app crash has only happened after at least an hour of continuous gameplay, but I have yet to browse the Assembly Panel before a mission. The could be due to a setting. However, this is the only thing I have found that crashes the game. Not knowing the cause, fidgeting with the graphics settings may be a wasted effort when I could just be saving the universe from a crazed god! Legacy of the Void, Mac OSX 10.11.x, Mid 2014 MacBook Pro 13", 2.6 GHz (Core i5), 8gb ram, Intel Iris 1536mbNPJH2 Nov 29, 2015
Nov 29, 2015 Cutscene desynch - first orbital bombardment In either the first Shakuras mission or the first Korhal mission in the LoTV campaign (whichever is done first), there is a cutscene for the first activation of the orbital bombardment systems. When this happens for me, the sound effect of the weapons firing goes off, then there is a period of complete silence as the weapons actually fire and the camera follows the shots down, with sound returning at impact. The silence period seems longer for the Shakuras version than the Korhal version. I have not noticed anything similar happening elsewhere, and at first I thought the silence was intentional, representing the lack of sound in space. Since there is a sound effect for the weapons firing, and it plays before the weapons actually fire, this is clearly a case of the video and audio not syncing properly in that cutscene. Reproduction? Every time playing the campaign, for me. Note that this cutscene will not play if the mission is done from the Master Archives, as the weapons systems are already unlocked in that case. I'm running Mac OS 10.10.5 on a 2015 MacBook Pro.jmerry0 Nov 29, 2015
Nov 28, 2015 Please help me download Heart of the Swarm So i bought a hard copy of the expansion HotS today, i put the disk into my Mac, everything seems to be going well. The startup asks me for my password because Star Craft is trying to change stuff, so i do that. The battlenet opens up and starts to initialize the game and I'm watching the download bar, and all of a sudden it disappears. this keeps happening even after I've turned off firewall and tried to manually open the game. I own a Macbook, currently playing StarCraft, and it worked fine when i downloaded it. So my issue is there is no initializing of the expansion, it doesn't download or do anything, please help.CaptainCrunk0 Nov 28, 2015
Nov 28, 2015 i want a refund [i][/i] i have doneloaded game 3 times still havenet even gotten to play this game. i have had my account on battle net for almost a decade. whenever i load up starcraft 2 legacy of the void i can only get to the login screen and then it tells me to login so i do then it cant connect at all been trying since i got legacy of the void. at this point i giving up and i want my money back. seriously why make a game if you wont let anyone get by the login screen. blizzard after this i will no longer buy , play or have anything to do with your company ever again. i hope your sales drop and your company goes bankrupt and one other thing your customer support number completely useless. Talos360@hotmail.comdaishi0 Nov 28, 2015
Nov 28, 2015 Can't Play--Loading Screen Kicks Me Out Good Morning, I bought Legacy of the Void, and used the Authentication Key to begin playing it. Your company crafted an impressive product, and I am very pleased with the game. I'm about 5 missions into the campaign, and the game doesn't really let me play it anymore. When a new mission begins to load, the loading bar stagnates, and I get kicked back to the main menu. I've tried resetting my computer, and it sometimes repeats, sometimes it doesn't, but I've arrived at a new mission that just won't load without kicking me back to the main menu. Other information that might be relevant: -I use a Mac (and yes, I'm quickly falling out of love with Apple for this and other reasons). -Since I used the Authentication Key for Legacy of the Void, the Battle.net app has been glitchy in general. Sometimes it will start up instantly, sometimes I get a dialogue box that says "Starting Battle.net", and it will freeze there (fixed by resetting the computer). -Updates won't load. The loading bar will get to about 72.70 MB remaining, and won't resume loading. Other times, it will start loading, then instantly stagnate and quit. -Battle.net won't close. It begins its shutdown process, then freezes, and I have to force quit it. Any help would be very appreciated. I'm not extremely computer-savvy, but as said earlier, the game is really engaging and I'd just like to be able to play it again.Grubenator3 Nov 28, 2015
Nov 28, 2015 Can't load anything I have the new 2015 Macbook Pro and I download Sc2 to the optimal section, yet when I try playing the campaign, the loading bar would get about half-way and then it would take me back to the main screen where I can select a campaign and what not. It's not just the campaign I'm having an issue with, I can't load into a regular match either, the loading bar would go half-way and take me back to the main screen. Please help!SteeLMuffin12 Nov 28, 2015
Nov 26, 2015 "Unable to download required assets" Hello Friends, My issue is closely similar to others involving the campaign. Post if anyone reading this has the same issue! So here it is (the first time it happened): After completing the first mission in the new Lotv campaign, I exited the game (for personal reasons) and came back to it later. When I clicked on the campaign tab at the home page in the actual Starcraft 2 game, I clicked on "episode 3, Legacy of the Void." After doing so I clicked on the "Main Story" option where it led me to a follow up screen and I clicked "continue." Now I am in the loading screen and when it seemingly finishes loading, it surprisingly takes me back to the screen where I originally clicked "continue." So, I reset the client and logged back in and the problem was fixed. However, after coming back to the game again a day later, the same problem occurred after I completed mission 6. I was able to complete missions 2-6 with no problems. I tried clicking "continue" repeatedly and occasionally an error would pop up (when it took me back to the screen where it says "continue") saying "Unable to download required assets." I am not a tech savvy person so I'm not quite sure what this means but this seems to be the primary issue. I read up on another post that described an almost identical issue as mine and followed the Blizzard Employee's steps to flush my DNS. Again, not the brightest person when it comes to tech so I did not really know exactly what I was doing, but nonetheless I followed the steps and now when I open the battle.net launcher that displays all the Blizzard games, a new error pops up saying, "Something went wrong with a file. We're not sure what caused it, so please try again or click the code below for more information. Sorry about that!" The code is BLZBNTAGT00000840. Not sure if this has anything to do with me being unable to play the campaign but I thought I would bring this up. *Update* I copied and pasted this from about 5 days ago and now the error described within the first paragraph "Unable to download required assets" does not seem to appear anymore after it takes me back to the screen where it says to "continue" campaign from the loading screen. The error might pop up again in the future but ever since I posted this issue on the other forum, the error no longer appears. -BrnaBrna3 Nov 26, 2015