Mac Technical Support

Nov 13, 2015 Missing bridge and war room LoTV campaign. So I am currently unable to do anything in the campaign because all of the models for the bridge and war room are absent. This is what I am seeing: http://imgur.com/2MvXIqK I am running OSX 10.10.5 Using NVIDIA GeForce GTX 980 with web drivers 346.02JimboSlice2 Nov 13, 2015
Nov 13, 2015 end mission cinematics always skip So whenever I complete a mission and one of those in-engine cinematics happens it skips it as if I were pressing esc key or something, which I'm not. Because these aren't the regular "cinematics" (the ones in high graphics) they aren't in the archive for replay. I end up missing a lot of the story because of this bug : (Scy0 Nov 13, 2015
Nov 13, 2015 LoTV campaign and Battle.net not right. Setup: OS X El Capitan Version 10.11.1 MacBook Pro (Retina, 15-inch, Mid 2014) 2.5 GHz Intel Core i7 16 GB 1600 MHz DDR3 NVIDIA GeForce GT 750M 2048 MB Firewall Settings: Mode: Allow all incoming connections Firewall Logging: Yes Stealth Mode: No Issue 1. Agent hangs / or conflicts on installation. Have downloaded as much of LoTV files as possible. Attempted all suggestions found on support threads for current and previous Battle.net versions. Attempted deleting and re-installing Battle.net and 'User' Agent files. Result = Battle.net Error pop-ups (More help: BLZBNTAGT00000840), Installation progress incomplete, paused, persists with 148mb - 152mb remaining. Issue 2. Playable portions of the game - Multiplayer (occasionally at best). Prologue missions - Only the first 2. Unplayable portion of game - Everything else. After campaign selected, mission preload starts then screen returns to campaign dashboard. Result = Unhappy H.E.L.P.Plethora0 Nov 13, 2015
Nov 13, 2015 mac book pro can't quit sc ii mac book pro can't quit sc ii just upgraded today. mac book pro can't quit sc iiGITZ0 Nov 13, 2015
Nov 13, 2015 Game Freeze during engine cinematic Playing on a Mac laptop, the game freezes during the campaign in the cinematic where the Spear of Adun flies towards the Altairan Rift. Cant esc out of cinematic, can only force the app to quit.Lightbringer5 Nov 13, 2015
Nov 13, 2015 Cutscene Bug I'm playing on a Mac OS X El Capitan. LotV Worked great up until a cutscene where the Spear of Adun is flying through hyperspace headed toward the Xel/naga home world. The cutscene freezes, but music continues to play. However, the music stops playing after about 20 seconds and my computer no longer responds to any commands. This has occurred three times in a row. If anyone knows of a way to fix this, please let me know.Brendan0 Nov 13, 2015
Nov 12, 2015 Game Freeze during Campaign. Game has frozen twice, both at the same location within the campaign. When I go to the War Council and switch between factions of a unit, the game will sometimes lock up. I'm on a mac.Corsair3 Nov 12, 2015
Nov 12, 2015 TOO MANY LAGS I CAN'T PLAY Hi. I bought Starcraft 2 Legacy of the Void and tried playing the campaign. There seem to be quite a lot of lags during gameplay and during cutscenes. In mission 9, it even kicks me out of the campaign. I am currently using: MacBook Pro (Retina, 13-inch, Early 2015) Processor: 2.9 GHz Intel Core i5 Memory: 8 GB 1867 MHz DDR3 Graphics: Intel Iris Graphics 6100 1536 MB Is there something wrong with the game, or is it just my mac? PLEASE HELP I CAN'T PLAY THE GAMECoolPolygons2 Nov 12, 2015
Nov 12, 2015 [Mac] Cursor is frozen for first second I have noticed this in the recent few patches (3.0 I believe), but for multiplayer, my cursor is frozen for the first second or so upon starting a game. Because this is not happening in the campaign, I am guessing this has something to do with the network. This is happening to me 100% of the time on multiplayer.Gyalgatine0 Nov 12, 2015
Nov 12, 2015 mBPr 2015 performance So I have the 13" mBPr with Intel Iris GPU. What's the fps I should expect?Bubblez3 Nov 12, 2015
Nov 12, 2015 game crash when viewing options for upgrades while playing wings of liberty i have had the game crash twice on me in 24 hours when viewing different unit/bass upgrade options in the laboratory or armory. it does not happen often, and only seems to happen if i have been in the screen for a while, switching back and forth between different options, while deciding where to allocate my limited resources, and viewing the little movies about them. i will click on an option that i have already viewed, and everything will freeze, and the only way to make anything happen is to force restart my computer! the computer itself seems to be largely unaffected by this crash, because even though sc2 is totally frozen, i can still activate mission control, but sc2 does not allow mission control to actually let you switch between applications, it only shows a black screen in this case (i just tested this and it happens this way even when the game is running fine). it also does not allow me to command tab out of the program while frozen, leaving my only option to go back to the frozen game and then force restart my computer. this has happened twice recently, and has been the only times i have had a full crash like this in years. i am running this on an iMac with OS 10.9.5KromeHWI0 Nov 12, 2015
Nov 12, 2015 Whoops looks like something broke.. I've been trying to update to legacy of the void and have encountered various problems, like the download 'waiting on another download' when there is none. After completing a file scan and repair which stated no repair was required, I started to get the 'whoops, looks like something broke' error as soon as I pressed the update button. Note, I've been able to update hearthstone without issue in this time, I've also tried deleting the battle net cache which hasn't helped either. I've got no idea what to try next!CitrusPisser3 Nov 12, 2015
Nov 11, 2015 Problems hooking up to TV with an HDMI I'm trying to set up sc2 Lotv on my tv so I could use a bigger screen. Everything is fine with the hdmi cable to show anything but when I switch to starcraft a grey screen comes up on the tv and starcraft runs on my laptop instead. Is this a problem with the specs of my Mac? I would just think it would work normally, like it did every other time I used it.Nekci5 Nov 11, 2015
Nov 11, 2015 Cinematics not displaying on external monitor Early into the new campaign, I found that pre-rendered cinematics do not run correctly on an external monitor (visuals and sound both stutter so badly that the cinematics are unwatchable). I only have one external monitor currently, so was not able to test on other displays, but a few points of interest: Pre-rendered cinematics seem to run as normal on the computer's built-in display Pre-rendered cinematics for past campaigns run as normal, even on the external monitor The stuttering problem does not seem to extend to in-game cutscenes, or any of the other content for that matterThanks for any time and effort. System specs follow: Model Name: MacBook Pro Model Identifier: MacBookPro6,2 Processor Name: Intel Core i7 Processor Speed: 2.66 GHz Number of Processors: 1 Total Number of Cores: 2 L2 Cache (per Core): 256 KB L3 Cache: 4 MB Memory: 8 GB Processor Interconnect Speed: 4.8 GT/s Boot ROM Version: MBP61.0057.B11 SMC Version (system): 1.58f17 Chipset Model: NVIDIA GeForce GT 330M Type: GPU Bus: PCIe PCIe Lane Width: x16 VRAM (Total): 512 MB Vendor: NVIDIA (0x10de) Device ID: 0x0a29 Revision ID: 0x00a2 ROM Revision: 3560 gMux Version: 1.9.21 Displays: Color LCD: Display Type: LCD Resolution: 1440 x 900 Pixel Depth: 32-Bit Color (ARGB8888) Mirror: Off Online: Yes Built-In: Yes LED Cinema Display: Display Type: LCD Resolution: 1920 x 1200 Pixel Depth: 32-Bit Color (ARGB8888) Main Display: Yes Mirror: Off Online: Yes Rotation: Supported Connection Type: DisplayPort System Version: OS X 10.11.1 (15B42) Kernel Version: Darwin 15.0.0 Boot Volume: Macintosh HD Boot Mode: Normal Secure Virtual Memory: EnabledCato1 Nov 11, 2015
Nov 11, 2015 Macbook Pro Trackpad/USB Mouse Somewhat Responsive In-Game My mouse clicks have no effect in game when no units are selected. I am unable to select units by dragging or clicking. However, I am able to control their movement if I press the hotkey for the units' grouping (left & right click both work). The mouse also works when I click the Menu button and I am able to click the buttons that pop up on the modal menu.Nemesis1 Nov 11, 2015
Nov 11, 2015 Mouse jumping around the area being pointed My mouse jumps around when I try to move the mouse in game only. If I slide it a little left right up or down or try to click on a button it jumps all over the place in a 1 inch radius. This is happening in AI games and Campaign. I have a Razor Naga mouse and a Apple bluetooth mouse. It reacts the same with both.Crusher0 Nov 11, 2015
Nov 11, 2015 loading screen issue on campaign I find that my loading screen bar in the campaign keeps slowing down then I get sent back to the spear of Adun screen. The first time this happened was after mission 3. The way it was fixed was to go back out of the game and download the rest of the files. Then the game had mostly downloaded. for some reason it stopped at 56mb left. I tried playing it again because it said it was optimal. I could play anther mission but now it has happened again. Overtime I try to play the second shakuras mission the loading screen drops out and I am back on the Spear of Adun. My game will not download any further.The game sent me to this page with an error. https://us.battle.net/support/en/article/cannot-access-or-modify-a-required-file-or-folder I have tried restarting the computer. I have tried deleting the battlement folder as well as sub folders as per https://us.battle.net/support/en/article/deleting-battlenet-files Nothing works so far. Very annoying as I cannot play the game. What else can I do?Mango1 Nov 11, 2015
Nov 11, 2015 LotV Mouse Control OSX I understand that there is an issue with mouse lag/control in OSX 10.10.x for most Blizzard games. Something to do with acceleration if I have read correctly. That said, LotV is unplayable in fullscreen even with VSync and mouse confine tweaks. The mouse lag makes it very difficult to even navigate menus outside of gameplay. Is this the same issue as experienced in other Blizzard titles? If so, when will this be addressed? 10.10 was released 8 months ago.Digger2 Nov 11, 2015
Nov 10, 2015 Microphone is running in background When I am in starcraft 2 and have the chat settings turned off for voice chat - I see that my microphone is still running. I exit the game and the microphone shuts off. I am running on os x mavericks with a u37 microphone.zaphinath0 Nov 10, 2015
Nov 10, 2015 Temperature What should by 2012 Macbook Pro temperature be while playing LotV? I'm at 75-78CSenator3 Nov 10, 2015
Nov 10, 2015 Movie audio goes faster than video. When I watch the second movie about Legacy of the void, ( the one about Zeratul warn Artanis on the ship) the voice goes faster than the video. Then the video becomes intermittent. I never experience that in the previous 2 campaigns (Wings of liberty and heart of swarm) . I am not sure what I should do. I am using a new Macbook Pro.Schottky0 Nov 10, 2015
Nov 10, 2015 Mouse Lag / Skipping after Patch My mouse keeps skipping after the latest 3.0 patch. I am no longer able to play the game.ICeSHaDE2 Nov 10, 2015
Nov 10, 2015 Mouse scroll causes black screen Hey guys, I'm playing Starcraft 2 on OSX El Capitan. I've noticed that sometimes when I pull my mouse in a certain direction too fast (like pulling it all the way to the right to view the opposite of the map), my screen will freeze for a second, go black, and then reappear again. This is super frustrating because it causes me to miss out on valuable gameplay and then when the screen comes back, my "pointer" now has a "text write line" (like in a text editor) that becomes super-imposed to my pointer. The only way around this is to close out everything, and relaunch the program. Does anybody know what's going on here? Thanks!blksheepwall2 Nov 10, 2015
Nov 10, 2015 I can't login and can't play offline the game takes a ridiculously long time to get to the login screen and then it does not connect to battle.net. i tried all 4 servers, and it doesn't connect to any of them. i just get the window that says: can't connect to battle.net, if it doesn't connect in a few moments, check my internet connection. my internet connection works fine. i even tried connecting with the editor and no luck. the load time for the editor was ridiculously long as well. the game will not let me play offline. it says i can't play offline with the starter edition. i own the standard edition. i'm on os x mavericks.TheHitman0 Nov 10, 2015
Nov 10, 2015 [Patch 3.0] Cannot download dependencies After patch 3.0, my editor can no longer download dependencies when opening maps (which makes it impossible to publish them). Here are the error messages: Warning: Document aliases could not be accessed: CLIENTSIDECACHE_READ_BAD_HASH Warning: Document aliases could not be accessed: There is a problem with the download cache. Please restart the game and try again. Warning: Document aliases could not be accessed: CLIENTSIDECACHE_LOAD_UNABLE_TO_OPEN_FILE Warning: Document aliases could not be accessed: CLIENTSIDECACHE_READ_CONNECTION_FAILED Clearing the battle.net cache did not solve the issue and neither did reinstalling the game. I am on OS X El capitan. This legitimately makes it impossible to edit. Any help?thomulf2 Nov 10, 2015
Nov 10, 2015 Patching error I spoke with Technical Support about the "Whoops! Looks like something broke. Give it another shot.​" patching error and we weren't able to come to a conclusion on how to fix it. Afterwords I tried some things and was able to successfully fix the error. The issue that was preventing the patch from working was probably an interruption to my internet that broke the patch process. I was able to resolve the patching issue on my Mac by going into "Applications>StarCraft II>SC2Data>data" and moving/deleting the data.000 file and then restarting Battle.net. After that, the patch continued where it left off and all is working. I really didn't want to have to download the whole game at 12 gb's again and who knows for all the patches, so I did these steps and only had to download the most recent patch that was 4 gb or so. Hopefully this helps anyone else having this same issue.Parabolical1 Nov 10, 2015
Nov 10, 2015 How do I uninstall SC2 on mac? I'd rather try my luck with boot camp, so I want to free up some space by uninstalling SC2. Is there an uninstall tool, or do I just delete the SC2 folders from the applications and documents folders?medyas21 Nov 10, 2015
Nov 9, 2015 Mouse cursor in wrong place When I have SC2 open the game thinks my mouse is about an inch or two higher than it actually is. That is the cursor must be an inch or two below an icon to click on that icon. This does not happen out of game. Because of this error I cannot scroll downward with the mouse, I cannot properly select or move units and generally am having trouble playign the game. I am running OSX 10.6.6, have 2.53 GHz intel i5 processor and 8 GM 1067 Mhz DDR3 ram. The game looks fine and seems to run fine but I'm not sure what to do about the mouse. The problem recurs with both the trackpad on my macbook pro and with an external USB mouse (razer naga) plugged in. I didn't see anything to address it in the settings in game. The odd thing is I ran the free trial download of the game that came with Cataclysm and did not have this problem. I then bought the full game, deleted the old files, reinstalled, launched, patched, and had the problem. Any advice?JCP5 Nov 9, 2015
Nov 6, 2015 need help asap!! downloaded sc. on my MAC why is the client so different then pc ? it looks disgusting it looks retarded almost, its not even the regular windowed client its the fullscreen choppy background laggy client how can i change this ??? [img]http://i.imgur.com/uwkxKTV.jpg[/img] http://imgur.com/uwkxKTV wtf is that^^Jay1 Nov 6, 2015
Nov 6, 2015 Lower right corner bug When I am playing a game (campaign, solo, multiplayer with others), and my arrow goes to the bottom right most corner, the view shoots to the bottom right corner of the map and mutes the audio of the game, only clicking the mouse will stop it and return the audio. The other corners have this issue. Tried with multiple mice, with no luck. Running Mac version of game.wildBcat0 Nov 6, 2015
Nov 5, 2015 Cant scroll on map with mouse since patch ??? Does anyone know how to fix this? i already tried windowed version and nothing im on a mac i also cant move the build grid on games! help!Komander0 Nov 5, 2015
Nov 4, 2015 Performance issue cause discovered! I discovered that using "Windowed (Fullscreen)" mode in the graphics settings causes a drastic loss of performance (from 100+ FPS to about 10 FPS). It doesn't seem to matter what graphics settings I have (Low ran at about 15 FPS) or what resolution I use (there was basically no difference between 1440x900 and 1920x1200) when this mode is selected. Changing the mode to "Windowed" or "Fullscreen" fixed the issue and everything was immediately smooth without changing anything else! I'm using OS X 10.11, I can't verify that this works on any other versions but before the 3.0 patch SC2 ran smooth as butter in Windowed Fullscreen. I like "Windowed (Fullscreen)" so I can more easily switch applications while the game is running, is it possible to fix this regression, Blizzard? <3kaydash3 Nov 4, 2015
Nov 3, 2015 Mac bug reports I've filed several bug reports that I wanted to collate here. Let me know if anyone else has experienced these: Add dependency takes forever: http://us.battle.net/sc2/en/forum/topic/19649324939 Corrupt map by editing data: http://us.battle.net/sc2/en/forum/topic/19650244931 Dark shading on half of creep: http://us.battle.net/sc2/en/forum/topic/19650244928 .ds_store causing save fail: http://us.battle.net/sc2/en/forum/topic/19648724927LucidIguana1 Nov 3, 2015
Nov 3, 2015 Performance problems even after 3.0.3 upgrade StarCraft 2 went from roughly 100FPS in-game pre-3.0.0 patch (and the LotV beta is still like this for me) to unplayably laggy (the game claims 40FPS but things stutter so badly it feels like 15FPS) after the 3.0.0 patch. I thought 3.0.3 might fix some performance issues but it's still just as laggy. Multiplayer and the campaign are essentially unplayable. Is this something Blizzard plans to address before the LotV release? Is this something Blizzard are even aware of on Mac?kaydash3 Nov 3, 2015
Nov 2, 2015 Graphics Lag I was using mountain lion and upgraded to OSX El Capitan , and the graphics start to lag even if I turn everything to low. When I was still using mountain lion, the graphics were smooth and even with large number of units on the map, there were no issues Now even when I play by myself with very little unit it lags, even the starting screen where the protoss jumps down lags (doesn't happen before upgrading) I even checked automatically switch graphics off in energy saver option and restarted my computer, but nothing solved the graphic lag My CUDA is already updated to the newest. Please help, starcraft2 is basically unplayable right now with the graphics lagSnowyWolf3 Nov 2, 2015
Oct 31, 2015 Blank screen [OSX El Capitan, 3.0 patch] Hi all, SC2 has become real unstable for me: - if I leave the mac idling with SC2 open, it'll blank the screen & I have to reset the computer because it won't get out of it [this happens whenever SC2 is the foreground app & the mac decides to blank the screen, it seems] - sometimes, just when starting, I also get a blank screen from which I cannot escape :( [this happens randomly] OSX 10.11, 2013 MBPR 15, GF 750 Anybody having similar problems? Any hint as to what's wrong? best,semantic3 Oct 31, 2015
Oct 29, 2015 Mac bug reports I've filed several bug reports that I wanted to collate here. Let me know if anyone else has experienced these: [Mac Editor] Add dependency takes forever: http://us.battle.net/sc2/en/forum/topic/19649324939 [Mac Editor] Corrupt map by editing data: http://us.battle.net/sc2/en/forum/topic/19650244931 [Mac Editor] Dark shading on half of creep: http://us.battle.net/sc2/en/forum/topic/19650244928LucidIguana0 Oct 29, 2015
Oct 29, 2015 [Mac Editor] Add dependency takes forever Clicking the "add other" button on the dependencies menu, I get a beachball that lasts for 2-3 minutes before the selection dialog actually comes up.LucidIguana0 Oct 29, 2015
Oct 29, 2015 [Mac Editor] Dark shading on half of creep Weird one here. Started after the release of 3.0 In the editor, sometimes all of creep in the top half of the screen gets shaded a darker color. Here are some screenshots of what I mean: http://op74.net/antioch/editor/shade1.jpg http://op74.net/antioch/editor/shade2.jpg http://op74.net/antioch/editor/shade3.jpg http://op74.net/antioch/editor/shade4.jpg I can make it go away by hiding and then showing the doodad layer, but that creates a weird shading on the right side of the editor (no matter the camera rotation). That shading covers more of the screen as you zoom out. http://op74.net/antioch/editor/shade5.jpg http://op74.net/antioch/editor/shade6.jpg http://op74.net/antioch/editor/shade7.jpg Here are my system specs: MacBook Pro (Retina, 15-inch, Mid 2014) Processor: 2.5 GHz Intel Core i7 Memory: 16 GB 1600 MHz DDR3 Graphics: NVIDIA GeForce GT 750M 2048 MBLucidIguana0 Oct 29, 2015
Oct 29, 2015 Battlenet and/or SC2 Lowers Background Volume Every time I open SC2, which opens the Battle.net app first, it lowers the volume of all background sound media. This happens to youtube videos playing on Safari (or Chrome), and just sound in general. Is there a setting on my macbook pro or within the Battle.net menu to stop it from lowering my background volumes?Unbearable1 Oct 29, 2015
Oct 29, 2015 The Game freezes when trying to authenticate When I open the BattleNet app and I make click PLAY, it goes to full screen but freezes at the message "authenticating". I tried reinstalling, cleaning cache folders, deactivations firewall, restarting router and nothing... Help please!Chuck2 Oct 29, 2015
Oct 27, 2015 The game Freezes when trying autenticate... The Game freezes when trying autenticate in battlenet. I tried to solve the problem by deleting the cache folders. I dont use proxys either. I have a "MacBook Pro" @ 2Ghz core i 7 with Yosemite 10.10.5. Graphic driver Iris 1536mb. Even I downloaded the game in a windows PC and could play very well, so I think the problem may be for Mac users only. My game is starcraft SC2 Wings of liberty Please help me, I want to play Thanks!Chuck0 Oct 27, 2015
Oct 25, 2015 Start up crash So I am having issues. Every time I start up SC2 LofV, It simply remains a blank screen for a short period of time before I get my spinning rainbow loading wheel and then it exits it out, saying a fatal error has occurred. This is what I have done to try to fix it; 1. Scanning and Repairing (Didn't detect anything) 2. Reinstalling the game (Did nothing) I had this issue back in the beta for LofV and I passed it off as a issue that was being fixed. I want to assume this is a issue that is easy to fix without dissecting my Mac. My specs; Yosemite 10.10 iMac (24-inch Mid 2007) 2.8 GHz Intel Core 2 Duo 4 GB 667 MHz DDR2 SDRAM Macintosh HD ATI Radeon HD 2600 Pro 256 MBScotish6 Oct 25, 2015
Oct 25, 2015 Mouse scroll It doesn't work anymore. If I restart my computer it will work for a few games then for unknown reasons it stops working. Can't really play the game if I can't move freely around the map... Late 2009 iMac OS X El Capitan 10.11 3.06 GHz Intel core 2 duo 16 GB 1067 MHz DDR3 ATI Radeon HD 4850 512 MBGGYaDingus0 Oct 25, 2015
Oct 24, 2015 SC2 both clients randomly toggle pause/game This issues is on a Mac, with bootcamp windows 7.1 Game randomly pauses and unpauses. I tried watching a replay of the game, and the replay itself seems corrupt -- invoking a pause game during the replay.IIIIIIIIIIII0 Oct 24, 2015
Oct 23, 2015 battle.net it would not let me log in is there a update going on or maintenance today on october 23 im hooked tpo this gamelazy0 Oct 23, 2015
Oct 23, 2015 Starcraft Icon Show (interrogation) Symbol Hey Guys I have Mac OsX system "el Capitan" Upgrade My Computer is Core 2 Duo, when i finished my update of mac system my Starcraft game show Interrogation Symbol on Icon of starcraft, Can you tell me a Solution? Thanks!Inti0 Oct 23, 2015
Oct 19, 2015 Game Unplayable due to messed up screen Don't know what the problem is. Played the game 2 days ago and everything was fine. Sure Artanis in the background was still purple, but I could play campaign, arcade, and skirmish just fine. Now I can't play any missions due to massive screen interference. When I actually try to play, (even cutscenes/mission briefings) are a jumbled mess of black (mostly black, some color) streaks that jump all over the place and make it impossible to play. Sound still works for the most part. Also the background/menu screens are mostly stable, with some graphical glitches here and there, but nothing on the level when I actually try to place. Help please!Hawke2 Oct 19, 2015
Oct 18, 2015 OS X App Switching Creates a smaller cut out of screen when switching back / fourth from Finder. 2012 MBP Retina Scaled display -> more spaceExerciseVid0 Oct 18, 2015
Oct 18, 2015 Confine mouse doesn't work properly on Mac I am on Yosemite and the confine mouse cursor option does not work properly when using an external display after the UI update. Hardware Overview: Model Name: MacBook Pro Model Identifier: MacBookPro6,2 Processor Name: Intel Core i7 Processor Speed: 2.66 GHz Number of Processors: 1 Total Number of Cores: 2 Memory: 8 GBmilk0 Oct 18, 2015