authentication module issues?

Mac Technical Support
Everytime I try to login i get a "unable to download authentication module" error. So i reinstalled nothing worked. I googled for solutions but only found fixes for windows. Anyone else have this issue? Oh and please don't say "Try again later" Its been days...

Had to remove the Blizzard folder in Mac HD/Users/Shared
Worked perfect after.
THANK YOU! I have been nearly a week trying to figure this out. That worked for me.
Thank you!!! Deleting said file got rid of the message, but was replaced with the game trying to reach Deleted the Starcraft 2 folder in the same location and it worked!!
Unfortunately didn't work for me.

SC2 working fine on my iMac. Just installed on my MBP (via download) and getting this error. Deleting /Users/Shared/Blizzard didn't help. :-(
Zearin, could you send me a copy of your system profiler to and i will see if i can find something to help you out.

1. Click the Apple in the upper left hand corner and choose "About this Mac."
2. Click the "More Info" button.
3. When the System Profiler is finished gathering its data, click "File" then "Save As..."
4. Add your name to the filename, and save it to your desktop for easy location.
5. When you send it to, attach it as a file
ATS - Mac Tech
Cannot find a resolution on the forums, contact a Support Rep directly:
The Restrooms are for paying customers only.
having this problem on a windows 7 any ideas?
You will want to post in the Windows Technical forums here:
Thanks! The Google DNS worked for me.

Join the Conversation

Return to Forum