Stuttering Game, no explanation to be found

Technical Support
1 2 3 8 Next
FINAL EDIT: I do not have stuttering in single player. I have fixed it, by updating my network driver. I have not had this issue since.

Go to device manager, check your properties of your network card, go to driver date. Now find the latest driver online for your network card or onboard network device, update that #@@!. Your problem if it was truly stuttering multiplayer game without real lag or fps drops, you should have it fixed.

Let me know if this works .. also double check to make sure you updated your driver correctly.

So I have been trying to troubleshoot and search for a fix to the stuttering I experience every 3-5 seconds, I get 140 fps maxed graphics, tried all different settings, downloaded all drivers, tried rollbacked drivers, reinstalled windows (7). My net connection is DSL. I dont stutter lag in any other game, Please, people need a fix for this.

Watch this video: The guy has a solid frame rate but gets stuttering for no reason. This is what a ton of people are getting.

Edit #2: I stutter worse or as bad as that video, it varies depending on unknown variables.

Your ISP- Embarq Corporation
Your modem (should be supplied by your ISP).- Embarq 660 series
Your router.- N/A
Your hub/switch/whatever else networking splits you have in between your computer and your router- n/a

The stutter is usually an issue with limited internet connectivity. Other online games from MMOs to FPS all run smoothly with decent ping. I even have leatrix configged. Um so yeah thanks blizzard for ruining my life

ATI Radeon 5800 HD

4x 3.42 ghz black amd

64 bit windows 7

4gb ram

onboard "HD" audio

Let's get a fix for this ... it has to be a networking flaw with sc2 and certain computers.
Edited: Fix did not work.
Wow, I didn't change anything today and I have terrible stuttering again... makes for impossible microing and a terrible gaming experience. The port forwarding obviously didn't fix it, just a fluke
Still no blue replies, thousands of people have been having this problem after patch 13....
shameless bump
Having the same problem. I play with the AI, so I thought it might be overloading the processor with too much decision-making, but today I tried playing 1v1 with a Very Easy AI and it's the same thing.

The game stutters at random times, for up to 5 seconds. This happens not only in a match but in the lounge too. EVERYTHING but the mouse cursor stutters - graphics, gameplay, audio. I don't recall having these problems before the last patch.
I do not get stuttering in anything but games, not the lobby. BUMP
Yep, just started today for me (didn't play yesterday). Stuttering at the start of each game (as in workers do not move for 5-10 seconds)... and then I have now been dropped twice in a row for the first time ever from the game. Something is not right in the Blizzard network space.

Also seems to be the same for me, i Got a 1GB radeon 5650
I am not letting this thread die, the problem is not resolved...
This stuttering issue seems to revolve around radeon HD cards.... but it is not exclusive to them
this was posted 5 days ago.... still no reply from a mod
Same issue here. Microing units is impossible when this happens. No opponents have yalled about lag either oddly enough....
I've been having the same issue for about the last two weeks now. From what I can understand from what I've read on these forums, it seems to affect pretty much anyone with an ATI or geforce video card (I have a geforce).
I've tried a few solutions people have posted as well such as;

1. Running another directx game in the background which helped some people (most commonly used was WoW, i used Empire at War since I don't play WoW) I had a slight improvement in my fps (roughly 10fps, so minimal), but I still got what I've nicknamed comic book lag.

2. This was for geforce video cards. Setting the performance at maximum instead of adaptive. Did absolutely nothing for me.

I will admit I'm on a gaming laptop, not a desktop, but I have a 9800 Nvidia geforce card and I only get this lag on this game. I can run Borderlands and Dragon Age Origins on max settings with no lag and can even run Crysis on medium with none.

I could probably run ultra for SC2, but I kept my game on medium before this lag started for me (ran good, why switch it? haha) and had a constant 40+ fps. On low, I average 80+....but its pointless since I still get my comic book lag.
There's also a thread a few spots up on this forum where a Blizz mod told people to post their info about this lag. I don't believe another post has been made by a mod since it was created a month ago by one however.

I hope this helped some of you :D

TLDR (I know there's some of you that will say that xD) Some video cards hate bnet for some reason and seem to cause lag. Or Bnet hates some video cards and causes the lag. No fix yet.
Well, im not sure about what problems u guys are having (since my English isnt the best)
But regarding FPS drastic variations i read on Team Liquid that you could change a setting to set a max for fps. You just have to go to Documents >Starcraft 2> Variables.txt .
In that file look for the following: "frameratecap=" and set to ur preferences
This should set a max for fps variations in game, mine is "frameratecap=45".
Also look for "frameratecapGlue=" which should be the max for the Menu. Mine is "frameratecapGlue=30".

I hope that help u guys =/
I personally have already done that , did not fix the stuttering issue. I believe it to be a networking issue... but it's kind of hard to say that for sure
Going on 2 weeks now, no fix for a month old issue... thanks blizzard. your game is unplayable for people with this problem.
I've been having this problem with a new latop that should be capable of running the game on high/ultra easily. I've been doing A TON of research and I found that the ATI HD Audio Codec may be the problem. If you have the Catalyst Command Center, and are running the Audio Codec driver, that may cause not only stutterings with the audio, but also with the frame rate. This applies to other games as well. I recently downloaded the game Borderlands, I am suffering from the same problem. I've downloaded all of the appropriate drivers but to no avail. I guess we have to wait for a bug fix. The trouble is that ATI doesn't produce drivers themselves, instead relying on the computer makers to release the fixes, i.e. HP or Compaq. It sucks.

Join the Conversation

Return to Forum