Can't access 1v1 2v2 or 4v4

Technical Support
I have bought and own two copies of WoL and I have also bought the expansion, Hots. I haven't played in a couple months but I played one game today of 3v3 on Hots. Now, 1v1, 2v2, and 4v4 are not even visible buttons anymore. On top of this, I switched to WoL to see if that would work, and none of it is available at all. None of the buttons even show up faded, they just don't appear at all, even for vs ai. Only vs 3 ai shows up on HotS. At the bottom of the multiplayer page, I see the "play" button with the lock symbol for WoL. It says I need to upgrade to play.

I checked my bnet account and it also has no record of my two copies of WoL anymore. All that shows up is HotS standard edition. I have the hard copies of WoL, but I shouldn't have to use those, right? I have two step security on my account and there is no way that it has been accessed by anyone else.

Any help would be greatly appreciated. I just want to play the game that I bought.
same thing is happening to me
You're not alone, I'm in the same boat.
Same here. My friend and I just updated to the new patch. Both of us only have 3v3 appear on both the ranked and unranked options.

Edit: I tried deleting the Blizzard Cache and restarting Sc2. It did not work.
I'm having the exact same issue, but it started after I tried to join 2 1v1 matchmaking games, and got an error that the server timed out. Maybe their matchmaking servers are down for 1v1/2v2/4v4?

Also, in the 'training' matchmaking, the names of the races are no longer visible in the buttons, I don't know if that's related.
Same issue here. Guessing this is a server wide issue. Hopefully it gets resolved soon. =(
I'm having the same problem, but only on the Americas. EU is running fine.
same issue
same for me and a buddy playing 2v2, can't choose anything now.
I do believe they're trying to fix the issue right now. Just be patient, this will be fixed soon.

P.S.: I was able to access all of the game modes, but I haven't played anything since.
so glad this isn't just me...... maybe not haha
all I want to do is try my brand new gtx 660 :(
Well this explains a lot. Haven't played Starcraft in many months, go to play in Matchmaking and I get a message telling me to upgrade.

Thought I missed an expansion. :p
This issue occurs every once and a while and is very random. Sometimes if you log out then back in, its fixes it. Sometimes if you exit SC2 completely and go back into sc2 it works. Sometimes none of these work and you gotta just wait.

However, the best solution I have found is to simply change regions. I know its not ideal, as you have different stats, rank, placements etc and cannot play with your friends, but it beats sitting around and waiting for it to resolve. At least this way you can play.

This issue is currently happening to me on North American region. Switched to europe and its all good.
Happening to me as well - I saw ONLY the "3v3" option, and then tried deleted my cache and restarting computer...then I got some weird error message and then ALL the options disappeared, and the game was telling me that "I need to purchase the full version of SC2 to use these features" or some trash like that.

What's going on, Bliz? Help please.
Hey guys. Just wanted to provide an update to let you know that, while we do not have an ETA on this just yet, this issue with matchmaking is being investigated.

In the meantime, you may be able to play some games by swapping your client to another region (available just above the ‘Play’ button in the B.Net App, or alternatively from the SC2 client login screen).

Thank you very much for your patience as we look into this.
The only matchmaking issue is that I still don't have an option to disable matchups.
For god's sake, why the !@#$ do I have to play ZvZ in unranked?????
Any new update? Just got off work and have a few hours to kill - think this will be back up tonight?
05/31/2014 12:22 AMPosted by Jay
The only matchmaking issue is that I still don't have an option to disable matchups.
For god's sake, why the !@#$ do I have to play ZvZ in unranked?????

Just leave the game. Is it that difficult ? Its unranked ! it doesnt count !
05/31/2014 01:31 AMPosted by xoxoRomance
Any new update? Just got off work and have a few hours to kill - think this will be back up tonight?

If this is the issue I think it is then try looking at this post and see if the workaround it mentions helps you at all.
05/07/2014 02:09 PMPosted by Leviathan
What you are seeing is a known issue that Bliz is looking into as we speak:

So far there are two community devised workarounds:
1) When logging into the game, wait on the main screen (Kerrigan/Hyperion/planets) for a little while and let the client get all its connections to battlenet stabilized. (Let the adds in the upper right load up, let your league border load up, etc.) Then click over to the Matchmaking screen.
2) Log out and back in. It may not work every time, but it usually works in a few tries.

Join the Conversation

Return to Forum