An unexpected fatal error occurred.

Technical Support
1 2 3 6 Next
2 days ago my SC2 worked well. Today, I tried to log in the old way, but the game crashed while logging in. I get a black screen after pressing "PLAY" and 1 second later the error "An unexpected fatal error occurred." appears again and again, with each time a different error code. The last code i got was BAF8BD93-7B3D-4654-9CA2-242661F6EA94.

I tried it with the new starting screen, but the error keeps occuring. I downloaded 15GB of the public test realm, but i still cant login. No of the 4 regions work for me.

I am very frustrated right now, i am trying to fix this for 3 hours now, i just want to play the game! Can someone help me please?
Hey CraftyRaf,

Have you tried deleting the Battle.net files and cache folder yet? Instructions are here:

Delete the Battle.net Cache Folder
https://us.battle.net/support/en/article/delete-the-battlenet-cache-folder

Deleting Battle.net Files
https://us.battle.net/support/en/article/deleting-battlenet-files
Thanks man. I all tried this but it all didnt work...
Now i see i coincidently changed my name from Craftyraf to CraftyRaf.
Can that be it? How can i change my name again?...
And if that doesnt work, what's next? :-(
Let's try running the repair tool next, and see if that fixes the issue:

Repairing Blizzard Games
https://us.battle.net/support/en/article/repairing-blizzard-games

One other thing I'd also try, is booting your computer into Selective Startup mode, just to rule out any third party program interfering with the game.

Selective Startup
https://eu.battle.net/support/en/article/shutting-down-background-applications

Unfortunately, the Terran decoder ring that was given to me when I joined the CS MVP program on the EU forums isn't powerful enough to decode the error code in your first post. So if the issue persists after following the previously mentioned suggestions, we would most likely need assistance from someone with a more powerful ring, someone like Velnrak. =)
Thanks for helping me sir.

This is what i did:
1) i ran system recovery, to a point before i installed the new launcher.
2) i got another problem, the progress bar was stuck at 1/3. But i solved it with some help.
3) Now i am able to open the old launcher.
4) The problem is the same after the repair tool: fatal error.
5) The selective startup didnt work either...

Every time i get a new error message. Last error message was thisone: F36EB675-7000-49A1-8A89-683C8A9A2866

Velnrak, we need your Terran decoder! :-)
decoding....

igdumd32.dll

The Intel drivers are coming up in the error report. Have you checked recently to see if they're up to date?
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak
After 5 hours searching, downloading, praying,... i fixed the problem!!

Some days ago, my work replaced my fan because my laptop got overheated (after only 1,5y of use). To fix the problem i first had to download the latest version of java. After that, i tried to install the update for the graphical driver but that didnt work, because "the manufactorer blocked it". With some search on the internet i found how i could by-pass the problem! I had to follow a bunch of steps and update the graphical card manually...

Thanks a lot for the support and the fast replies guys!
Awesome, CraftyRaf! Good Hunting!
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak
okay I keep getting an unexpected critical error code 66273FE0-8A1F-48B7-BE2F-E6754A012707, any one know what that 1 means and what I can do to fix it?
LoneWolf, your error code is related to a bug, which we're working on. We apologize for the difficulty.
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

"They say the oaks are just too lofty
And they grab up all the light."
No it's fine thanks man I'm just happy I know it isn't anything on my end.
Can anyone verify if I am running into the same issue. Last error report was 66273FE0-8A1F-48B7-BE2F-E6754A012707. I am unable to load Campaign missions even though I completed the first 2 without problem :(
Murderblast, your error code is also associated with this same bug. Thanks for reporting it!
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

"They say the oaks are just too lofty
And they grab up all the light."
No problem, is there an active thread somewhere on the issue somewhere that has a temporary work around that works or is it something we just have to be patient for?
I'm not aware of any other threads with workarounds that refer to this bug, but it is slated to be fixed in an upcoming patch.
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

"They say the oaks are just too lofty
And they grab up all the light."
I'm getting this same error message with code: B516CBB2-13A5-4271-9912-CB139E8FBBC1
Game doesn't launch. I've been having this issue since updating to Windows 10. I've tried updating drivers, deleting cache, using compatibility modes. . . Any thoughts?

Now it's error: C08B0718-1CAA-41B5-9FAF-9521D1701EB3

Now: 1987DD8E-A3B4-4403-B31B-92ACA3B405C5
Can you post a dxdiag report, SunnyPwno?
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

"They say the oaks are just too lofty
And they grab up all the light."
I changed my Intel Graphic card 3D settings to "Balance" and it worked.
hello installing starcraft 2 and getting unexpected fatal error with the id 774C9014-46EC-4C63-9739-F72608F5F3A7.

please help am getting frustrated!
never mind to fix this i had to make the game run on 32 bit client..but does that mean i cant run it on 64?

and wats the difference between 32 and 64.

got windows 7 64 bit.

a response would be appreciated!

Join the Conversation

Return to Forum