Mouse Not Working in Windows 7!!

Technical Support
Anyone mind explaining why my mouse of all things won't work inside of StarCraft II? This renders the game completely useless. I could barely get past EULA. I've tried two different mice!
after screwing around for awhile i found tghat my cursor stays in one spot. i managed to get all the way into a game and play but cannot tell where the mouse is supposed to be as the cursor stays stationary.. also on windows 7

I'm guessing you've changed the font size in Windows 7. Try setting it back to the default of 100%.
Actually I haven't changed my font settings at all. But as a check I just went in and clicked 'Restore Default Font Settings'. Just tried that, No Change.
I am having the same issue that Doomsayer is
EDIT: Fixed! Thank You Martyt. The Font was at 150%. I never changed this so either it was the default when I purchased the computer a couple of months ago, or another program changed it to that on install. Thank You! That was extremely frustrating, if Blizzard has a way to test that and prompt ppl for future patches, I would recommend adding it.
PROBLEM: Your mouse/cursor works just fine in the desktop and other games, but when you launch SC2, the cursor is stuck in one place and you have a ghost/invisible cursor moving around.

CULPRIT (for me at least): The desktop/Windows font was set to the largest size.

SOLUTION: Simply setting this to default size (smallest one) fixed the problem for me - the next launch of SC2 showed the cursor moving as it should. In Win7, go to control panels, to fonts, to change font size. Select the "default" smallest one, log off and back on when it prompts you. All fixed. I haven't tried the medium font setting yet.

Thank you to datth (blizz customer service) who suggested this.

MY GEAR (just as FYI): Asus G73JH laptop, ATI Radeon HD 5870 / 1GB GDDR5, newest 10.7 drivers, Razor Death Adder mouse.
It is terrible that I have to disrupt my computer settings to play a game! I am on a 47" monitor the smallest font is unreadable when I have to minimize the game to do other stuff!!! We need a better solution.
Just purchased Heart Of the Swarm and can't play because of this bug.

I am using windows 8, Radeon 9790
I have had this problem in a few recent games. How on earth can games be allowed to publish with this kind of error? My font size is set to a certain setting for a reason. DPI scaling is a known dynamic and should be accounted for. how and why does this happen?? Very frustrating.
I'm having the Same problem, I'd love a fix so I could play SC2 again.
Rage, please create a new thread, and post some computer information from the Direct X Diagnostic Tool (dxdiag).

After you've created the dxdiag report file, open it up, and copy and paste everything, except after this section:
DirectShow Filters

After you paste everything into a post, highlight everything, and hit the "pre" button (It says "Code Blocks" when you hover your mouse over it). That'll make the information much more readable.

I'm locking this thread because it is a few years old.

Join the Conversation

Return to Forum