authentication module error

Mac Technical Support
Hi there,

I recently migrated to a new computer via Time Machine, and now I get an error when I try to log in stating that it can't load the authentication module. I opened a new account and it worked fine there, so I'm not sure what it is about my old one that is causing issues. I tried replacing all the blizzard files I could find in /user/library/ with ones from the new account, but that didn't change anything. Neither did a reinstall. Thanks for any help.
We have seen this issue with a few customers, and there are a couple of steps to try.

First is probably the easiest. Try a different browser.

Second, make sure that any security programs you have installed are either configured properly to allow the download or removed altogether.

If you are running any kind of torrent program, you will want to make sure that it is not running when you start downloading.

If that doesn't work, the DNS cache may need to be flushed. To do this go into the Terminal (Go > Utilities > Terminal) and type in the following:

For Leopard (10.5) or Snow Leopard (10.6):
dscacheutil -flushcache
Press Return

**Note: Terminal will not tell you if it's successful, only if there was a problem.

You can also try creating a new admin account:
1. Go to Apple menu => System Preferences => Accounts
2. Create a new Admin account
3. Log into that account
4. Go back into the and sign in
5. Now go ahead and download downloader
6. Download the installer into the following folder: Mac HD => Users =>Shared
7. Log back into your original Account
8. Run the installer from the shared folder
9. make sure to delete the Account you just created

Please make sure you're using a wired connection. Apple has acknowledged an issue with the latest AirPort software so a wired connection is going to be far more stable. *{3356-24821}*

** Please note: Blizzard does not offer direct support for proxies (Internet connection sharing), firewalls, or routers. The settings provided below are suggested settings only. You may need to contact your ISP or network administrator for assistance if you have opened the correct ports but still cannot connect to the game servers.

Also: If your Hard Drive is formatted as Case-Sensitive, StarCraft 2 will either not install or experience a wide range of installation errors. The default format should be Extended (Journaled).
To check the format of your HD, open a finder window and select Applications>Utilities>Disk Utility. Once disk utility is open, highlight your Mac HD>Erase or RAID tabs. Both of the tabs will show you what the format of your HD is, as well as at the bottom left hand corner of the screen. If it is set as (Case-Sensitive) or (Case-Sensitive, Journaled) then StarCraft 2 will not work properly.  
In the event that your HD is formatted as Case-Sensitive, you will want to contact the computer manufacturer for information on reformatting the drive to a non Case-Sensitive format.
If these steps do not resolve your issue, or if another step you have found resolve it, please let me know.

ATS - Mac Tech
Cannot find a resolution on the forums, contact a Support Rep directly:
The Restrooms are for paying customers only.
I'm not sure if you understood my question. I already had the game installed, so I don't understand what a web browser has to do with this. I uninstalled the game and reinstalled it (from the disc), but that didn't solve the problem. I still get the authentication error from within the game.

Flushing the cache didn't work.

Can you please list all the files that get installed in my /user folder? It must be something in there that is causing problems, as the game works perfectly in my new account.

I'm using a wired connection, case insensitive FS. No firewall or security software.
Fixed it. Deleted everything in users/shared.
I have run into a similar problem after re-installing my comp. The account says it failed to download the authentication module, but there is no user/shared data in either the c drive or the installed directory.

Any ideas?
I have run into a similar problem after re-installing my comp. The account says it failed to download the authentication module, but there is no user/shared data in either the c drive or the installed directory.

Any ideas?

C drive? Are you on Windows?
i am also having the same issue. I had to reinstall because of an OS crash, it says the same thing about the authenticator module. Diablo 3 is having same issue. i have completely uninstalled both and reinstalled and still same problem.
@SQUEEKS- I believe your issue is relating to the South East Asia/Japan ISP DNS issues. You can read more about it here with workarounds listed:
Im running Windows 7, sorry for the confusion on that.


I got Diablo 3 working, i chose a different country connection (Asia) then switched it back and that worked. is there a way to do the same for Starcraft2?
You'll want to post in the Windows forums, since these are Mac specific forums:
okay, so I have been having a similar error. I have tried everything the support site told me to do and it has not worked. I also redownloaded the game last night and it still has had the same issue. I have been at wits end trying to solve this issue. to put it shortly: Help!

Join the Conversation

Return to Forum