Starcraft Anthology video resolution issue

Technical Support
I recognize that this is the SC2 forums but the SC1 forums seem to not be up and running at the moment. If this needs to be moved, feel free to move it to the appropriate forum.

I loaded up the Starcraft Anthology from the thumb drive last night. The install went smoothly, but when I loaded it, for some reason, when it goes to full screen, the screen goes beyond the edges of my monitor. I searched the internet to see if someone else had a similar issue, and it seems the only problem in this vein is the video not scaling up enough. Mine seems to be scaling too far.

The bottom and right sides of my screen are missing quite a few pixels, enough that on the loading screen, all I see of the Blizzard logo is the top left portion of the "BLI".

Just to make sure it wasn't my video card having an issue, I loaded up Frozen Throne and it scaled properly.

Thanks in advance for your assistance.
Does your monitor have an "Auto Adjust" button you can push or access through the Monitor menu? Try that.
StarCraft runs at 640x480. It's fine for most monitors but TVs might be another story. What kind of display device do you have? What operating system are you running?

Tech Support/Billing

It's a Protoss unit, sarge, coming thru the south pass. He looks broke
I haven't touched the one from the thumb drive yet, but last week I installed my original 12 year old copies of SC & BW from the battle chest discs and had a similar issue.

I'm running Win7 x64, but to fix it I went and found the shortcut, right clicked, went to properties. One the compatibility tab there are 5 checkboxes in the settings area, check all of them. Do not check the "run in compatibility mode" in the top section. I also checked the box to run as admin but who knows how much that actually does.

You didn't list your OS but I'm guessing you're running Win7 or Vista. For me this made it work just fine, although I have noticed if I alt tab out of the game and back into it, it will often made the colors go 6 kinds of crazy, so I try to avoid that.

Also, make sure you install the newest patch after you install (I think it's 1.16.1) in the game options there will be a checkbox to enable CPU throttling. You want to check that, SC1 doesn't need anywhere near the amount of power that modern PC's have, but for some reason without that checked it will use a ton of the CPU. Checked it uses like 2% of mine.

SC1 and WC3 use completely different engines, there's not even any 3D rendering to be had in SC1. I plan on using the thumb drive to install the game to my Netbook (it's considerably more powerful than the PC I played it on 12 years ago lol).

Hope that helps. I've heard reports that opening the screen resolution controls in Win7 help prevent SC1's colors from going wonky, but I haven't noticed that myself.
Sorry, duh, I should have listed my OS! Posting at work makes me not as verbose as I should be.

I'm actually running XP still, and my monitor's a flatscreen Dell computer monitor (I don't have a Dell, though, it was just a spare monitor lying around). My video card is an nVidia GeForce 7300GS.

I did try right-clicking the shortcut and telling it to run in 640x480 mode, but it didn't change a thing. I also got the update for it since I was having trouble yesterday getting to a forum and I remembered had a tech support channel in it (it's not manned anymore :( ). I'll also remember to do the CPU throttling change when I get home.

I think I had loaded Starcraft on this PC once before, but I don't remember it having these issues. That's not completely reliable, though, cause I know the last place I played it was on my laptop, not my PC, so I could be remembering that instead.
Try going to Start -> Run -> dxdiag -> more help tab -> Override
Once there, type in 60 and hit OK. Exit dxdiag and then try the game again. That's a Windows XP and lower only setting.

Tech Support/Billing

It's a Protoss unit, sarge, coming thru the south pass. He looks broke
Okay, at home now, and gave this fix a whirl. It doesn't look like it did anything. I'm sorry, I know you guys have more pressing issues with SC2, so I really appreciate the help. :)
Would I be able to get some specifics about the screen resolution controls? My game plays fine but the colours go all wonky every once in a while, during cinematic and in game. During the cinematics it was on and off, but it was more wonky than not in game. Finally I tried alt-tabbing the game to see if when I came back the colours would be back to normal and they were, but my game froze and I had to restart my computer. Just wondering if I can get some info on how to stop the craziness. I'm using Windows 7 64-bit and I have an ATI Radeon HD 4850
Ever since I installed this in Windows 10, the resolution is so small it makes it almost impossible to play. It stretched in Windows 8 but it seems to have a problem with Win10. Any ideas?
Same issue over here, it's in the up-left side, win 7 x64, GeForce gt 430
Is there anything I can do using an hdtv. My game seems to be overscaling too, cutting off half the minimap and below and just as much on the right side. Using a radeon R9 200, on windows 10

Join the Conversation

Return to Forum