I can't load my saved campaign games

Technical Support
I see them in my directory in my 'starcraft 2' folder but when i boot up the game it says i have 0 achievements and it says 'start new campaign' or 'load' and when i press 'load' there is nothing there even though i just beat (and saved) the outbreak mission last night.

i tried just opening the saved files from the directory with the starcraft 2 launcher but that doesn't work--just boots the game up normally and then i run into the same problems. is anyone else having this issue? i guess i could just leave the game on until i beat campaign but i imagine i will run into similar annoying issues when i move onto challenges and online multiplayer play.

i also inexplicably lost my connection to bnet in the middle of playing campaign--im not sure if that's a contributing factor, but either way i have all my saves on my hard drive so i can't imagine there isnt some kind of resolution here
really? i'm the only one with this problem?
Ya im having this same problem. This is unplayble like this.

I have the same problem. I think it has to do with my crappy internet connection. I get frequent disconnects here in Canada with Rogers (seems to be a known issue with them). When I get disconnected (even for a second) I lose my Battle.net connection and anything "Saved" doesn't actually save and no achievements can be won, etc... Definitely a *huge* annoyance for me. Seems I can't play single-player because I get high latency causing frequent disconnects causing unsaveable game state. :-(
I have the same problem but it should be unrelated by my internet connection. In fact, I'm playing against the A.I. in "offline" mode.

I like to save and later load saved games but it won't permit this.
I updated to the current patch yesterday. It shows all of my achievements and I do not lose connection to bnet, but it didn't show any of my saved games. I started a new campaign and played till char in HotS and I saved it there but when I tried to load that save later it said it could not be loaded. All it lets me do is just start new campaigns
Tried again today, I started a new campaign, played a few missions and saved. When I quit the campaign and a few minutes later tried to load them, it said "unable to load save game"
Can you try taking Full Control of the StarCraft II folder in your Documents folder?

C:\Users\<username>\Documents\StarCraft II

  • Right-click > Properties
  • Click on the Security tab.
  • Select your User name, click on Edit...
  • Select your User name, check Full control.
  • Do the same for Home Users.
  • Click OK.
  • ________________________________________________

    Rate me! https://www.surveymonkey.com/s/Velnrak

    “Today, we retake our homeworld, and with it, our Legacy.”

    Join the Conversation

    Return to Forum