Cutscenes getting skipped.

Bug Report
Prev 1 6 7 8 11 Next
So, maintenance was performed today.

What are the odds they fixed this bug?

Don't squelch my optimism, Internet. :-P
02/23/2016 11:23 AMPosted by Zaroff
What are the odds they fixed this bug?


About 0%. It's too bad Blizzard's PR department doesn't have Saiyan biology. With all the damage it's taken at this point it'd be pretty much unstoppable.
Ok, so we've got 4th-or-so update since release, and I can NOT know whether this was fixed because the patch notes don't say a damn thing!
At least on my launcher, the patch notes show 3.1.2. stuff, nothing about this latest 3.1.3 update!
Same, though, here too:
http://eu.battle.net/sc2/en/game/patch-notes/3-1-2

How are we to know what was fixed?!!!

Time for a new bug report:
Patch notes missing newest patches?!

I'm vexed so HARD!
Bought a game with game-breaking bugs.
Next-to-zero communication from Blizzard on this bug report forum.
Patches upon patches and no fix on these issues.
And now even zero information on patch notes.
Bad.
02/23/2016 01:20 PMPosted by Renji
02/23/2016 11:23 AMPosted by Zaroff
What are the odds they fixed this bug?


About 0%. It's too bad Blizzard's PR department doesn't have Saiyan biology. With all the damage it's taken at this point it'd be pretty much unstoppable.


You got that right.
As for me and for one example, I'm 90% certain I won't purchase the Nova Covert Ops missions even if they ultimately fix these issues at some point. I've had enough.

It's been discussed how RTS genre is dying and now Blizzard is doing a wonderful job at letting the sort-of-last grand RTS game wither away, by first releasing a broken final part and then leaving it broken and customers abandoned. What an honorable end to it all.
this makes me mad. bought a broken game.
Blizzard don't even bother to comment to us. The way they treat consumer, really made me consider whether want to buy Nova Covert Ops.
The whole reason i bought LotV was because of the campaing. I am not interested of multiplayer anymore,
i don't play the co op mode too, not interested in arcade as well. Just from time in time I decide to enjoy the campaign, but is broken -_-.
I see this problem exists from very long, and yet not adressed.
I'm having this problem is there a solution?
Hi all,

I finally managed to get around this problem. Someone mentioned that deleting the Void*SC2Save files is helping in this direction. A number of people already replied that it helps only for some time.

The problem is that these files are synchronized with Battle.net storage. Every time you delete them, starcraft will restore them. I am guessing, there is some corruption in these files that causes these issues.

The solution is that you do not have to delete then, but instead you have to create empty files and then you have to write-protect them (so that starcraft cannot synchronize them anymore).

[WARNING: this will delete all your progress in the LOTV campaign]

These are the steps:
1. Hit Win+R. Type cmd and then hit Ctrl + Alt + Shirt + Enter. This will require administrator access.
2. In the command prompt, type
cd "\Users\%USERNAME%\Documents\Starcraft II\Accounts\{Your SC Account number}\{Your Region account ID}\Saves"

Your SC account number can be found if you open Documents\Starcraft II\Accounts
Your Region ID is a text with a couple of dashes. It is the folder inside your account.

3. Run in the terminal:
FOR /r %X IN (Void*SC2Save) DO (copy /Y /b NUL "%X" & attrib +R "%X")

Then start Starcraft II and play the campaign from the beginning. There will be no autosaving, so you have to save manually.

Once you get past shakuras, you can revert the changes. With the game running in a mission post Shakuras, go into the terminal, in the same folder and run:

FOR /r %X IN (Void*SC2Save) DO (attrib -R "%X")

Now switch back to the game and just save once more time.

This works in both 32bit and 64bit.

[Blizzard, seriously, you are making it hard for us to love you]
@Maintanos:

This looks promising but I am having the problem that the game somehow removes the write protection on the files after a period of time. It then simply re downloads them and messes up the campaign progress.

Edit: It seems that Starcraft removes the read-only attribute whenever the game is closed.
Restarting the game then causes it to synchronize with the battle.net servers.
I will try a playthrough where I make sure to reapply the read-only attribute every time.
@Raven:

Hm this did not happen to me. What else you could do, for each file, right click -> Properties and go on security tab.

There you have to click "Edit", on the top pane select your account and on the bottom one click Deny to "Full control". Apply and repeat for the next file.

IMHO, I think only VoidCampaignSave.SC2Save, VoidCampaignCompletedSave.SC2Save and VoidPublishArchive.SC2Save are important. The other 2 to 6 (depending on your progress) Void* files are related to the prologue and epilogue.
not broken the update of 3.1 was untested in 3.0 it was fine
hey dude i own a Mac do you by any chance know a way to fix it on a Mac???
@abyssTitan

You have to open a terminal and navigate to the folder where the Saves are. Then run:

chmod a-rwx Void*
I'll be sure to do this when I run out of servers, but right now, still got at least Asia and SEA not giving me Blizzard profile puke.
Just spent some 12 hours playing through the entire LotV campaign non-stop WITHOUT exiting the campaign at any point. All cutscenes & conversations worked perfectly. Further evidence that this bug is triggered when one exits the campaign and later continues.
Looks like my computer decided to shut itself down automatically to install an automatic update (I was in the middle of playing the mission 'The Host'). In order to continue the campaign without issues to the conversations, I'll need to start a brand new campaign, cheat my way through all the way to the end, and then reload the PREVIOUS mission's victory auto-save (Templar's Return), and only then, will the conversations work properly.

Blizzard, hurry up and fix this thing already.
Still happening. Still no further response. I'd rather not do any of the creative ideas I've read here; this product should be working as intended. Unless, of course, Blizzard intended to have zero replay-value of their Protoss Campaign.
sorry to say but im stupid so im gonna need some details XD
Anyone know if today's maintenance fixed it?

Join the Conversation

Return to Forum