Co-Op Crashing

Technical Support
About 1/6 attempts to load/play a co-op mission will result in it freezing and in place of the sound there is a loud feedback noise. :/ Only way to break this is by forcing a power cycle on my laptop.

Pls help.

- Win 10
- 64 Bit
- Latest Patch
- Graphics Card up to date

Usually happens during loading but I just played a game where at the very end (Isha literally said 'Victory') and then crash. So annoying.
Issue is still ongoing. Just got annoyed enough to post again. Today marked the second occurrence where it crashed right when they pronounce victory! Freaking again. I can suffer it to crash before the game starts but it's so much worse when it crashes right before credit can be received.

I have noticed that it glitches out at the end of each game for like half a second. Kind of stutters and makes the sound a tad, but then gets past it. Scares me every time.
Again just now, crashing at victory.

All 3 times it was playing the mission Oblivion Express. Not sure if coincidence or not.
3 More failed loads tonight so far. 2 for Oblivion Express and one for the Last Stand one (w/e it's called).

Gotta do a full power cycle and waste 7 mins to try again and load SC2.
this is happening to me 100% of the time. i cant play co op at all
I'm getting exactly the same thing too.. Please do something Blizzard!!!!!
When LOTV first came out I would get this problem probably 20% of my queue attempts, it's slowly increased to 100% and I havent been able to play for 2 weeks now...Seems like this issue is due for a solution Blizzard
Same issue here.

I am running a radeon gpu, what are you guys running?
Do you guys have Authenticators? I know I was having similar issues with Co-op and also Multiplayer. When I took my Authenticator off they crashes stopped. I spent a lot of time with support about this and they are looking into it. Something to check if nothing else.
First 3 time crash while in loading screen, 4th time too lag made me lose the match.
And yet the issue still persists. The driver stops working during co-op.

Looks like the issue is not Co-Op specific. :(

Spec information (a complete DxDiag can be downloaded using the link at the bottom of the post):
-Win10
-Intel i5 6600k
-16Gb RAM
-AMD Radeon R9 280

Currently I'm running the game in Windowed (Fullscreen) with Graphics settings set to Extreme and the following two commands which i found on the tech support page for a similar issue.

Extra arguments:
-frameratecap=60 -frameratecapglue=60

What I've tried so far:
- Different game settings
- Have Battle.net app close when starting the game
- Clean install the drivers
- Reinstall the entire game

In the game logs i can see the the driver is failing with the following errors right after the "PerfNotifiers initialized":

GFX 07:59:30.613 PerfNotifiers initialized
GFX 07:59:30.616 Lost D3D9 device
GFX 07:59:30.641
GFX 07:59:30.641 D3D9 Device Reset from unknown returned e_errorKindGfx(0)
GFX 08:11:49.944 Windows Timeout Detection and Recovery (TDR) detected!
GFX 08:11:49.945 Windows Timeout Detection and Recovery (TDR) detected!
GFX 08:11:52.948 Windows Timeout Detection and Recovery (TDR) detected!
GFX 08:11:52.949 Windows Timeout Detection and Recovery (TDR) detected!
GFX 08:11:53.387 DirectX call m_device->TestCooperativeLevel() failed with error code D3DERR_DEVICENOTRESET
GFX 08:11:53.399 DirectX call failed with error code D3DERR_DEVICENOTRESET
GFX 08:11:53.399 Lost D3D9 device


Is there a workaround for this issues?

Logs and DxDiag:
https://1drv.ms/t/s!AolC1YfUc2aS7C-Y4CpRy2h3qHl3
https://1drv.ms/t/s!AolC1YfUc2aS7C49XIbAQo_w4ijM
I'm still having the same issue, over a year later
Coop stopped working for me too. Once I got one error message saying out of core memory, so I googled and on Blizzforum it says to update the Graphicdrivers. I did, mine were 6 month old. Now it crashes without error messages. Once the in app browser crashed at the same time.

Other than updating the drivers I tried:
*clearing battlenet cash
*running as admin
*using compatibility mode Win8 (using Win10)
*scan and repair tool
*scanned my harddrive for errors

I did notice that Coop for some reason takes like 3600mb of my graphic-ram when running, while a normal game never goes over 2000mb.

Now I am trying to reinstall the game.
Next I can test my ram. But this issue is only with the Coop mode in Sc2, no other Problems on this PC. I really wish there were error messages with the crashes, completely in the dark here.
So reinstall didn't help.
Checked ram, is fine.

Deactivated ALL win10 background apps (I think only clock, security center and settings were still active). I guess one of them prevented my Video ram from being freed during coop missions, now ram is freed and goes down from 3300mb back to like 2000mb during missions and I can play without crashes.
So Blizzard, Linux Client, when?
I'm in 2019 and Co-op still crash at the end of Oblivion Express as well. One day it went very well for 5-6 missions but other day it just keep crashing till I don't wanna play anymore. Sorry for the other random player I team up with.
Locking this thread. Please be mindful of resurrecting older threads. A new thread or more recent thread can be created instead.

Join the Conversation

Return to Forum