Stuck entering lobby

Technical Support
Had one friend have this issue prior to the most recent patch, but since the new patch we all (4 people) are getting it every 2 games or so. It only seems to occur after playing an arcade game and trying to join a new game; it has all but the host getting stuck on "entering lobby".
When playing solo I seem to get it even more often.

Restarting the client fixes it, but it's a bit annoying having to do it every game when playing solo.
I have the same issue, but for me it's every second game in arcade; join the first one fine, then after get stuck in "Entering Lobby" and have to restart the client. Pretty beefy box so only takes 15 seconds or so to do, but still annoying and unnecessary.
Hey HazettuR and TheQuietOne, thanks for your reports. We're looking into this, and we'll let you know of any updates as we get them.
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

“Today, we retake our homeworld, and with it, our Legacy.”
This has been happening to me as well. It's been happening since the DDOS, though I am not sure if that is the cause.

50% of the time I need to restart Starcraft. I stay connected to BNet.
An update:

we found a quick workaround for when in parties, whenever it occurs it seems we can just reform the group and it'll let us try again.

And while playing single player I was noticing often 2 score screens after the game, as if one loaded, then the UI loaded, then the score screen flashed and loaded again. I tried always waiting for the second screen before pressing "join again" and I haven't noticed it happening as much.
Maybe I need to wait a certain amount of time (x) before trying.
I had hoped new patch would fix it. Nope.
this never getting fixed and driving me crazy
This continues to be broken. It's frustrating to make all of my friends wait while I reboot prior to a game.

Nice job Blizz. Easy fix I am guessing, too.
I've fixed this problem by quitting.
I have had the same bug for months now. Have to quit to rejoin a new game of the same game. I have removed SC2 from my system and reinstalled, same bug. Please fix this!
This is very annoying, this happens to me about half the time for a few months now.
I got the same problem sometimes again and again. :(
Yeah, the same problem day after day, "entering lobby" is always the end of my game. Restart, login, play again, and "entering lobby" again. For me, Blizzard and the pool of programmers doesn't care about fix this. Another item that need to be fixed is that you can't change your email = "You can't use your password as a email".
No way, they didn't fix this. I tried to change it 6 times and no luck.
I am having this issue for months now. Finally decided to look it up, apparently it's been going on for at least 3+ years from what I can find. Every time I get done playing a game and try to either join or create a new arcade game, it hangs and the circle just spins on entering lobby. Basically I have to exit the game and open it again to fix it. Very annoying. Sometimes I can get 2-3 games in before it does it, other times it'll do it after just one game.
This is STILL happening to me. Often after every game.
Logging out and back in again fixes the problem. (A client restart is not required).

It's annoying as hell, and I don't understand how this hasn't been fixed yet?
I am not getting the 1v12v23v34v4play keys or my friends portraits at all can not get into the game since the last maintenance you just had
Please fix the bug. Still occurring
Real talk Blizzard this has been a problem for years...
YEARS
I also am having the same problem, Blizzard has great customer support although I would appreciate it if they took such an integral part of their game and FIXED the damn thing!

Join the Conversation

Return to Forum