Firewall is keeping me from completing install

Technical Support
Recently purchased a new laptop and am trying to install Starcraft 2 on it, but I'm getting a message saying: "The tracker is not responding. Your computer appears to be behind a firewall." Is there anyone else who has run in to this issue? Can anyone walk me through the steps necessary to fix this?
Howdy! We have a support article located here that covers the Operating System firewall and I recommend reviewing the portforward.com to ensure the router isn't blocking your connection all located Here.
Simply turn off all Windows Firewalls. Voila problem solved!
In my case, it turned out to be Avast that was blocking it. The provided instructions (above) for Windows 8 firewall didn't do anything. I couldn't even find the right area, but I used those instructions to track it down in Avast and it finally got the update done!

In Avast, find Internet Security. I found Blizzard under "other". Click on "packet rules". Under "protocol" pick "TCP". That opens the "port" window. Enter the port number, then "add". That should do it.

Ports for Starcraft II are - 1119, 6113, 1120, 80, 3724

Join the Conversation

Return to Forum