Unplayable on 3.1.5 MacOSX (Crashing)

Bug Report
1 2 3 11 Next
Game crashes on 3.1.5, MacOSX 10.12.5 / NVIDIA GeForce GT 650M 1024 MB

I tried two 3v3's and one 1v1 in ranked and all 3 games crashed within 1 - 6 seconds. Just says unexpected fatal error occurred.

The report ID of one of the crashes was: F5D0C914-2A15-489A-B8CD-FFCE658D47C3
Same here.
Same here with Mac
Hi all,

Thanks for the reports, we're looking into this now. oGsHukk and Fiorex, can you let me know what game mode you were in and what was going on right before you crashed? Also if you have the report ID that would be helpful as well!
06/20/2017 01:16 PMPosted by Kelphe
Hi all,

Thanks for the reports, we're looking into this now. oGsHukk and Fiorex, can you let me know what game mode you were in and what was going on right before you crashed?


It happens in any game mode I have tried... There is also another thread in the mac technical support forum with 10+ users having the same issue.

Ive tried
Campaign/Multiplayer/Arcade

Users have also reported that a re-install has not fixed the issue.
Multiplayer->custom
Tried several maps.
contact me directly if you want at twitter @diegofiore
Same Problem! Re-Install does not fix issue.
Multiplayer game mode, 1v1, unranked.
Happening here on Mac, sierra 10.12.5, intel HD4000. Ran fine before the patch.
Same here, in coop, multiplayer 2v2, 1v1, 1vsAI.
Tried system repair, tried un/reinstall, seems like a problem with the patch.
+1. Consistent crash. Mac OS X 10.11.6 on Intel Iris Pro.

Relevant error report: A9F84F1B-37DE-496C-8BF5-58C94BFE76A8.
Me too. Tried to play CoOp and multiplayer. A couple seconds in, CRASH.

macOS 10.12.5 on a 2016 MacBook Pro (MacBookPro13,3) Radeon Pro 460 4096MB.
Happening here as well. Single player mission starts fine. Crash doesn't happen until I select first unit. Mac OS 10.12.5 Intel HD Graphics 4000

Report ID: D5B9AAB8-4E22-4CEB-B0AE-68D2BF6FF9F6
Tried single player custom and Campaign, crashing shortly after start in both. In campaign, the crash is after the in-game cinematic starts. Tried repair and then reinstall, neither worked to solve the issue.

Mac OS 10.12.5
MacBookPro 2015 Radeon R9 M370X 2048 MB
i have the same issue.

report id
F056306A-12D6-4996-849A-0C7117927FB8
Same here.

Mac OS 10.11.6
2 x 2.66 GHz Quad-Core Intel Xeon
20 GB 1066 MHz DDR3 ECC
ATI Radeon HD 5870 1024 MB
+1 and others on Mac said same thing. please address this asap blizzard.
27" iMac running OS X iMac (Retina 5K, 27-inch, Late 2015)
4 GHz Intel Core i7
32 GB 1867 MHz DDR3
2T SSD
AMD Radeon R9 M395X 4096 MB
macOS: 10.12.5 (16F73)

Upon entering an arcade game, within the first ten seconds of game play the screen resizes from full screen into a window all by itself and then the game crashes with the error

unknown error. please reinstall the game.

The game is now unplayable.

Also tried an arcade game with the window minimized. The game doesn't attempt to resize the window but just crashes within the first second of game play. D2DAE257-4888-4758-805C-28FE6524537D
Same here, mac 10.12.4
Report ID:
8BE2E900-6154-4724-A022-D2F9EA4CC2F2
Ditto here
OSX 10.12.5
Any game mode crashes: Coop, Arcade, Campaign
Tried:
- Scan and repair
- Deleting *.idx, then Scan and repair
Problem code: 44AF70BE-851F-4C2A-90A0-D4E4FF065EE8
06/20/2017 02:40 PMPosted by Kelphe
Hi everyone,

Thank you all for your reports and detailed information, we're looking into these crashes and will provide an update as soon as possible. Our sincerest apologies for these crashes.


From Blizzard CS on another thread concerning the Mac post patch crashes.

Join the Conversation

Return to Forum