error 2:-1073741819

Technical Support
Been playing basically every day for a few days and then when I booted it up today, it gave this error. I tried uninstalling/reinstalling, checking/unchecking 32bit mode trying both, repair, running as admin, etc. Brand new issue with a previously working install.
Running Windows 7
Ran a disk diagnostic and there is no problem with my harddrive
No other presently known problems with the computer.

edit: Due to another bug, I've also cleared the cache.
So, after uninstalling and an attempted reinstall, now I can't even get it to reinstall. I'd say it's a little over 80% complete and stuck. Just stays 'Waiting' and won't change.

https://puu.sh/wysyJ/c35ad64e1e.png <--- Link to a screenshot of the stuck install progress
Hello Kri!

Sorry to hear you're havin g issues reinstalling StarCraft II ><

Seeing the installation stuck there, I'd recommend trying clearing out temporary data for the Blizzard installer app, which may be damaged or incomplete. This won't affect any of the SC2 data you've already received:

Deleting the Battle.net/Blizzard app Cache Folder

Then re-run the app and see if it goes!

Best of luck in your adventures :)
installed again, and still getting the same error code.
still looking for help on this. Can't even start the game cause of this error.
I have the same problem. How was it resolved?
Howdy!

Error 2:-1073741819 when launching Starcraft 2 can often occur when the Blizzard app is blocked by a security program or doesn't have proper permissions. I'd recommend to check the following steps:

Step 1) Ensure any personal anti-virus software is setup with the Blizzard app and game on it's safe list or exceptions list. You may also try to temporarily disable your anti-virus for troubleshooting. We have seen Avast cause this error.

Step 2) Now is also a good time to ensure the Blizzard app and game are added to your Operating System's firewall following the steps Here.

Step 3) Make sure the Blizzard app is running as Administrator following the steps Here.

Retest!

Now if the issue continues check for the following:
- Make sure Secondary Logon is enabled Here.
- Going to the the Starcraft 2 directory open the Support64 folder, find SC2Switcher_x64.
Right-click and select Properties
Click the Compatibility tab, then select "Run this program as an administrator" Apply and Ok.
- Make sure the Blizzard app is installed to your Operating System drive, installing it on external drive may cause issues launching software.
- Try reinstalling the game from an external drive to the OS drive.

Thank you!
I accidentally had avast installed on my computer when i was installing CCleaner. Didn't see those pesky check boxes until it was too late.

Join the Conversation

Return to Forum