Save Failed.

Bug Report
Hello,

Trying to play through nova's campaign and whenever I try to save the game and/or the game attempts to automatically save after a checkpoint, I get a "Save Failed." message.

I was searching through the internet and apparently there used to be a sticky thread about this but it is now gone(404). Information on the issue is scarce and nothing conclusive. I am logged in as Admin and the Documents/Starcraft 2 directory has the correct permissions... Help?
Hello Spawn,

Sorry for the late reply on this.

Try this workaround:
1. At the Campaign select screen click on more to the load save game menu.
2. Open the "Show in Folder" button.
3. Delete the entire "Saves" folder, in the account folder area the "Show in Folder" button brought up.
4. Start a campaign game.
5. See if auto saves and manual saves work again.

Hope that works to resolve this issue!
Thanks,
-Kelphe
Same problem, above solution does not work.

I just downloaded LoV and in the second mission the problem showed first (unable to save games, and unable to load save games). Not sure it matters, but in the load menu, autosaves show up but have a little red exclamation mark next to them.

As per the the above, I deleted the folder but now simply have to replay the first missions. Is there a solution? or a cheat so i don't have to play them again?
Same problem. This happens since the game got one of the useless updates a few weeks ago.
Had this problem while trying to finish the Into the Void missions. Luckily I was able to power through them so I didn't have to save, but otherwise this would've been a huge problem. Someone should definitely look into this.
I get the same problem when playing prologue of Legacy Of The Void on Brutal on Windows 10. Saving worked normally until the end of the 2nd mission. Now the save file is created, but the error message says about failed save and saves cannot be loaded. This mode is kinda Mega Brutal :)
Is this still going on? Can't progress my campaign well at all this way.

Deleted the save folder, and while battlenet remembers where I was, I can't save any more progress.
Not sure about 4.0, but 3.19 certainly still had this problem. It seem to happen with all campaigns without the story "ship" mode between the missions (e.g. the first 3 missions of Legacy, before getting to Spear of Adun). Usually restarting the game and starting the mission from beginning resolves the problem (you can save through the existing mission), but as soon as you advance to next one, the problem resurfaces.

EDIT:

Maybe it's related to this known issue?

Saving the campaign during the ""For Aiur!"" mission then loading that save causes the player to be unable to save during the next mission.


Only that it seem to apply to all missions that doesn't have the "Story mode" in between.
It appears as if sc2 stops getting write access to save folder. Read deanx reply

https://eu.battle.net/forums/en/sc2/topic/15161831158?page=1
I have given write access and it doesn't work.

I have tried all that crap.

Every other update makes it impossible to play. Why did I pay for this crap?

Join the Conversation

Return to Forum